1. yilmazrts's Avatar
    Hey guys,

    i shut down my Q10 to put my SIM Card into my iPhone for a while. After putting my SIM Card back in my Q10, it wont turning on.

    I had over 80% accu capacity when i turned it off. At the time I switched my SIM Card, I pulled out my accu from my Q10 for the meanwhile.

    I tried many things but with no success. Even the LED wont blink.

    Would be nice if someone can help me.
    06-13-15 09:24 AM
  2. martinjdub's Avatar
    The SIM card should impact the boot sequence ...but stranger things have happened

    Try trickle charging the q10 - insert power for 5 second, remove, repeat like 50 times....
    Try connecting to BlackBerry link
    Try a new battery or clean the contacts with eraser
    Takes it to a cell store and pop in another working SIM and see if you get different results

    Hope that help!
    06-13-15 10:12 AM
  3. yilmazrts's Avatar
    The SIM card should impact the boot sequence ...but stranger things have happened

    Try trickle charging the q10 - insert power for 5 second, remove, repeat like 50 times....
    Try connecting to BlackBerry link
    Try a new battery or clean the contacts with eraser
    Takes it to a cell store and pop in another working SIM and see if you get different results

    Hope that help!
    Hey thanks mate for your reply.
    Unfortunately nothing works. No LED, No nothing.

    do u have another suggestion? :/
    06-15-15 11:23 AM
  4. martinjdub's Avatar
    Seems to me that the prognosis is bad bro

    Posted via CB10 app and BlackBerry Passport 
    06-15-15 07:19 PM
  5. yilmazrts's Avatar
    Seems to me that the prognosis is bad bro

    Posted via CB10 app and BlackBerry Passport 
    My problem is mysteriously solved by father time. I tried the most things/ tricks to do when a phone is bricked or whatever. But nothing worked and my q10 didn't turn on and had no LED blinking either. No reaction.

    Then I read a post in which some guys experienced strange things. They said that pulling out the battery and keeping the q10 plugged in at the wall charger and waiting at least about 24 h would bring back live into the q10.

    So I did the same thing. Pulled out the battery and plugged the q10 into the charger at let it alone for about 2 days with occasionally trying to turn it on. But nothing happened.

    Then I unplugged the device from the charger. Pulled out the battery. Let both alone for about a day and all of the sudden it turns on :S I don't know why but it seems father time solved the issue.

    God bless the queen

    Seriously, much thanks for your comments!

    Posted via CB10
    06-16-15 05:00 AM

Similar Threads

  1. Video app on z10 only plays sound
    By goonerkhan in forum BlackBerry Z10
    Replies: 11
    Last Post: 06-23-15, 05:31 PM
  2. Why won't my Q10 turn on?
    By yilmazrts in forum BlackBerry Q10
    Replies: 3
    Last Post: 06-16-15, 04:54 AM
  3. Best Crackberry Apps are on iOS and Android
    By CrackedRosco in forum Site and App Feedback & Help
    Replies: 19
    Last Post: 06-14-15, 07:45 PM
  4. Need help link won't find my backup. Can't do a restore
    By nuangel2 in forum General BlackBerry News, Discussion & Rumors
    Replies: 3
    Last Post: 06-14-15, 09:50 AM
  5. Need help for z10 STL 100-3 model os update in India
    By bala-bb in forum BlackBerry Z10
    Replies: 13
    Last Post: 06-14-15, 01:20 AM
LINK TO POST COPIED TO CLIPBOARD