1. Benjamin_NYC's Avatar
    I have a plethora of BB chargers, and the one I have semi-permanently set up in my living room is from my old Curve. I've had the Q10 for two months, and up until today, this Curve charger always worked fine on the Q10. Now, today, when I plug it in, I get a popup that says: "To charge your phone faster, use the charger that came with the device" (or something like that). Then, a few minutes later, it stops charging altogether.

    I can understand it charging slower, since maybe this old one produces less amps (is that right, amps?), but not charging at all? I have not updated my software or anything. Anyone seen this recently?

    Thanks, -BJ
    08-05-13 03:56 PM
  2. BergerKing's Avatar
    It is entirely possible that the contacts in the connector have become worn over time and it just isn't making a secure enough connection any more. Do you have the fixed or replaceable cable on the charger?
    08-05-13 04:10 PM
  3. aiharkness's Avatar
    Agree with above. Sounds like charger has finally failed, or worn and not making contact somewhere. Try another charger and verify problem is not device, unless you've done that already.
    08-05-13 04:19 PM
  4. Benjamin_NYC's Avatar
    It is entirely possible that the contacts in the connector have become worn over time and it just isn't making a secure enough connection any more. Do you have the fixed or replaceable cable on the charger?
    I guess that's possible, but it's strange that it "gives" up charging after the same exact amount of time every time I plug it in. This charger pre-dates the kind where you can change the cable. It's afixed to the part that plugs in...

    I think it actually is still charging, just VERY slowly. The battery meter seems to be going up, even though there is no lightening bolt.
    08-05-13 04:21 PM
  5. Benjamin_NYC's Avatar
    Agree with above. Sounds like charger has finally failed, or worn and not making contact somewhere. Try another charger and verify problem is not device, unless you've done that already.
    Yikes, I hope it's not a device issue...<searchesforothercharger>
    08-05-13 04:22 PM
  6. Benjamin_NYC's Avatar
    Yikes, I hope it's not a device issue...<searchesforothercharger>
    Not a device issue. Q10 charger works fine. Guess the old charger is dying. Seems strange though, seems to be it would either die completely or not.
    08-05-13 04:28 PM
  7. Benjamin_NYC's Avatar
    Funny enough if I DON'T click "Close" on the popup about using the proper charger, it continues to charge (with lightening bolt). Sounds like a strange software issue, which is odd that it's coming up all of a sudden.
    08-05-13 04:30 PM
  8. aiharkness's Avatar
    Haven't experienced a failed charger yet myself. And I don't know the ways in which they fail. But I doubt it is a software issue. For whatever reason what the BlackBerry is seeing is out of spec. There is enough voltage or current to charge, apparently, though at a slower rate. Good thing it is failing that way a not in a destructive way, which I bet is by design.
    08-05-13 05:00 PM
  9. Benjamin_NYC's Avatar
    Haven't experienced a failed charger yet myself. And I don't know the ways in which they fail. But I doubt it is a software issue. For whatever reason what the BlackBerry is seeing is out of spec. There is enough voltage or current to charge, apparently, though at a slower rate. Good thing it is failing that way a not in a destructive way, which I bet is by design.
    Sounds about right.
    08-05-13 05:03 PM
  10. Benjamin_NYC's Avatar
    LOL now it makes a red "!" in the battery meter. Time to toss it I guess.
    08-05-13 05:04 PM
  11. Benjamin_NYC's Avatar
    It was the charger. Found a "new" old Curve charger in the box, and it works perfectly!
    08-05-13 07:34 PM
  12. BergerKing's Avatar
    It was the charger. Found a "new" old Curve charger in the box, and it works perfectly!
    It is usually a cable that fails, repeated flexing over a period of time, pulls, contact wear, etc and they may even show charging, but give poor results. Recently replaced 3 bad cables on various chargers, nothing was wrong with the block, but the cables just weren't cutting it. That's one of the reasons I am glad that the newer chargers come with a replaceable cable nowadays.

    Sent from my SPH-L710 using CB Forums mobile app
    08-06-13 10:04 AM
  13. Bratza's Avatar
    Didn't read the posts, but using any charger lower than 750mAhh causes NO charging with BB10 devices. Try to google this "issue".

    Posted via CB10
    08-06-13 06:52 PM
  14. mmagliaro's Avatar
    Since the newer Q10 and Z10 claim to need at least a 750mA charger,
    if you are using an old Curve charger, look at the nameplate. If it's like mine, it says that the maximum current output is 700mA.

    If you plug a Q10 into it, and it draws 750mA, you are overloading the charger.
    It might work for a while, but eventually, the charger will fail unless it is actually
    built to deliver more than its rated current. 700 is pretty close to 750, but who knows.
    You are really pushing it.

    That is most likely what happened. You are plugging a charger with too low a current capacity into the phone. It will keep "eating" chargers until you use one rated over 750mA.
    room2046 likes this.
    01-27-14 02:23 PM
  15. chrisro's Avatar
    A bit off-topic question : I use both my new and old Curve charger on my z10, since they both are 750mAh. Wanted to ask you guys, using the Playbook's 1.8Ah on the phone would harm it in some way?

    Sorry for the noob questions, but I'm Extremely left-handed when it comes to electricity and stuff.

    Posted via CB10 from my exquisite Z10
    01-27-14 03:12 PM

Similar Threads

  1. Replies: 5
    Last Post: 08-11-13, 07:18 PM
  2. Error with debug sideloading
    By JBML007 in forum BB10 Android App Sideloading
    Replies: 4
    Last Post: 08-06-13, 09:10 AM
  3. Youtube buffering problem...
    By caintiger in forum BlackBerry Z10
    Replies: 1
    Last Post: 08-05-13, 08:16 PM
  4. Impressed with z10 camera
    By Ukandy69 in forum BlackBerry Z10
    Replies: 4
    Last Post: 08-05-13, 05:45 PM
  5. Q10 Unlocking
    By Paco709 in forum BlackBerry Unlocking
    Replies: 2
    Last Post: 08-05-13, 03:58 PM
LINK TO POST COPIED TO CLIPBOARD