06-15-14 11:54 AM
30 12
tools
  1. JCMM's Avatar
    Hey guys i've been struggling to repair my Q10. When i woke up this morning the touch screen was not working.

    1. I tried a battery pull --> no result
    2. Restart --> no result
    3. I disassembled the back and middle cover to check if the lcd flex cable was well attached --> no result
    4. I completely removed the circuit board and all the components attached and put it back together --> touch screen worked for like 4s
    5. The phone was in "Airplane mode" so i thought it could be some kind of bug, using BB Link a did a FR --> no result and stuck in setup
    6. The screen went black with a red flashing light every 3s, using autoloader i installed the 10.2.1.1925 --> screen still black
    7. I disassembled the phone again and i touched the lcd flex a bit --> screen is working again but touch screen still don't work

    I've been messing with the phone for about 8h in order to get it fixed, still no lucky...

    I don't know what to do anymore and i'm scared to order a lcd replacement part and in the end having these same issues, what should i do?

    I'm sorry if my english isn't perfect, i'm doing my best.
    sdevins likes this.
    01-04-14 03:34 PM
  2. anon(1852343)'s Avatar
    Why did u take it apart, it is under warranty, just swap it out with your network provider

    Q10 with 10.2.1.1925 Leak Installed
    01-04-14 03:44 PM
  3. JCMM's Avatar
    i bought it used, i'm not the primary buyer of this phone, was previously opened by the person who sold it to me.

    right now the only thing i can see in my device is this screen, and no way i can complete the setup

    URGENT Q10 need some help-p1050447.jpg
    Last edited by JCMM; 05-15-14 at 09:48 PM.
    01-04-14 03:48 PM
  4. anon721037's Avatar
    i bought it used, i'm not the primary buyer of this phone, was previously opened by the person who sold it to me.

    right now the only thing i can see in my device is this screen, and no way i can complete the setup

    Attachment 235965
    Send it back to blackberry and see how much to fix, through your provider, usually they give you a loaner to use.


    Posted from my Z30
    sdevins likes this.
    01-04-14 03:56 PM
  5. JCMM's Avatar
    What price should i expect from a repair like this? i was trying to avoid it at all cost

    I didn't drop the phone.. nothing.. from one day to the other touch screen stop working.
    sdevins likes this.
    01-04-14 04:06 PM
  6. anon721037's Avatar
    What price should i expect from a repair like this? i was trying to avoid it at all cost

    I didn't drop the phone.. nothing.. from one day to the other touch screen stop working.
    I would just return it saying that, as I have sent one back before and when they returned it it was better than new.

    Posted on my Z30 on CB10.
    sdevins likes this.
    01-04-14 04:27 PM
  7. anon(3993749)'s Avatar
    i bought it used, i'm not the primary buyer of this phone, was previously opened by the person who sold it to me.

    right now the only thing i can see in my device is this screen, and no way i can complete the setup

    Attachment 235965
    It's a software issue. Just install the latest leaked OS on it and it will be fine.

    Posted via CB10
    sdevins likes this.
    01-04-14 05:19 PM
  8. JCMM's Avatar
    I've done it already and still can't get touch screen to work
    sdevins likes this.
    01-04-14 05:26 PM
  9. anon(3993749)'s Avatar
    I've done it already and still can't get touch screen to work
    The digitizer is probably dead then. You could buy a new one and replace it yourself, but I'm not sure it's worth it.

    Posted via CB10
    01-04-14 05:30 PM
  10. JCMM's Avatar
    Can someone confirm if the digitiser connects to the circuit board Via LCD Flex or if it has some clip by itself, maybe i missed something and that┤s the reason of its failure.
    01-04-14 06:28 PM
  11. anon(1852343)'s Avatar
    Doesn't matter who previously purchased it, still has one year warranty



    Q10 with 10.2.1.1925 Leak Installed
    01-04-14 06:34 PM
  12. zten's Avatar
    The warranty is void since he took it apart, the screws have stickers on them that show if the phone was disassembled.



    Posted via CB10
    01-04-14 06:48 PM
  13. slagman5's Avatar
    Sounds like a loose connection somewhere in the flex cable. You will need to replace the whole screen/digitizer unit...

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    01-05-14 12:05 AM
  14. Morty2264's Avatar
    In my opinion (which isn't esteemed, but it might be somewhat useful ), it sounds like a software issue - something to do with the touchscreen or its parts? One user said it sounded like a connection problem.

    Send a direct message to @BlackBerryHelp on Twitter - maybe to ask about repairs? They have great response times (usually only under a few hours), and always follow up with you to make sure they've answered your questions. A fellow CrackBerry user suggested this to me and I got good results!

    Are you still in contact with the previous owner of your phone? Do you have a receipt or any proof of purchase? Did the previous owner mention any kind of touchscreen issues or anything else before you bought it?

    As another user stated, sending it into BlackBerry is also a good idea.

    Try not to worry, and good luck! You'll probably get a loaner phone, so don't worry about being without a phone if you do decide to send it back! Please let us know what happens!

    Posted via CB10
    01-05-14 12:18 AM
  15. anon(8263181)'s Avatar
    Maybe the person who sold it to you new it was no good did a quick fix and got rid of up! It's always a 50 50 when you buy something used. Don't get me wrong it could happen straight from the store but atleast you have a better chance of having it replaced

    Posted via CB10
    01-05-14 02:42 AM
  16. anon(8263181)'s Avatar
    Wish you luck though

    Posted via CB10
    01-05-14 02:42 AM
  17. slagman5's Avatar
    How is it so many people have come to the conclusion that this is a software issue? Did anyone read his post? He says it would work if he wiggles the connector ribbon sometimes... That is the BY THE BOOK wiggle test. Yes, it's actually called that, and the purpose of that test is to narrow it down to that particular harness or connector you are "wiggling." It's a hardware issue... Wiggling the ribbon would not affect a software issue people...

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    sdevins likes this.
    01-05-14 04:01 AM
  18. DivideBYZero's Avatar
    This man knows about the wiggle.

    Posted via CB10
    01-05-14 04:06 AM
  19. slagman5's Avatar
    This man knows about the wiggle.

    Posted via CB10
    LOL

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    01-05-14 04:07 AM
  20. JCMM's Avatar
    guys you won't believe this. Last night i turned the phone off and i put him to charge with the amber flashing light at the top until it turns green.

    This morning i press the power button, the device starts normally and the touch screen works... i don't get it...
    Morty2264 likes this.
    01-05-14 06:37 AM
  21. slagman5's Avatar
    guys you won't believe this. Last night i turned the phone off and i put him to charge with the amber flashing light at the top until it turns green.

    This morning i press the power button, the device starts normally and the touch screen works... i don't get it...
    Don't bump it too hard, maybe it'll keep working, lol.

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    01-05-14 11:46 AM
  22. Morty2264's Avatar
    guys you won't believe this. Last night i turned the phone off and i put him to charge with the amber flashing light at the top until it turns green.

    This morning i press the power button, the device starts normally and the touch screen works... i don't get it...
    Congratulations!!!

    Posted via CB10
    01-05-14 03:11 PM
  23. JCMM's Avatar
    I'm starting to doubt if the problem was with the lcd flex or something else.. something related with the firmware written on the main board.

    I'm going to explain everything i did the night before it stopped work.

    I turned the phone off to charge during the night, few hours late i noticed that the amber light was still flashing. I turned the phone again and it was the battery stuck on 92% and not charging. I had read in the forums before that it could be fixed just by putting the phone in airplane mode in order to complete the charge. So i put the phone in airplane mode and i turned it off.

    I went to sleep and the next morning when i turned it on the digitizer was not working. Maybe all this is related with the charging process.
    01-05-14 04:49 PM
  24. slagman5's Avatar
    I'm starting to doubt if the problem was with the lcd flex or something else.. something related with the firmware written on the main board.

    I'm going to explain everything i did the night before it stopped work.

    I turned the phone off to charge during the night, few hours late i noticed that the amber light was still flashing. I turned the phone again and it was the battery stuck on 92% and not charging. I had read in the forums before that it could be fixed just by putting the phone in airplane mode in order to complete the charge. So i put the phone in airplane mode and i turned it off.

    I went to sleep and the next morning when i turned it on the digitizer was not working. Maybe all this is related with the charging process.
    You mentioned before that you would move the flex cable and try it again and it'll work a little bit after that. So unless it was doing the same thing before but you stated as if moving the flex cable changes it, then that would suggest it had something to do with it. Of course I wasn't there when you did it so I can't say if you did everything the same after moving the cable or if you did something different (which would void that test)...

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    01-05-14 06:07 PM
  25. JCMM's Avatar
    Only worked once and it was still during the startup logo (when we touch and it shows the %). The failure its in the hardware thats for sure, but could be something related with the firmware
    01-05-14 07:04 PM
30 12

Similar Threads

  1. Did they really need a new OS?
    By hanexs in forum General BlackBerry News, Discussion & Rumors
    Replies: 315
    Last Post: 02-22-16, 08:55 PM
  2. Help! Notifications Hijacked by Advertising!
    By Amy Rosa in forum BlackBerry Z30
    Replies: 8
    Last Post: 03-21-14, 08:43 AM
  3. How to sideload True Caller ID on Q10?
    By Pankaj Jaju in forum BlackBerry Q10
    Replies: 16
    Last Post: 01-29-14, 10:55 AM
  4. Problems I still have with BB10 - Help If you can
    By NursingNinja in forum BlackBerry 10 OS
    Replies: 11
    Last Post: 01-05-14, 12:41 AM
  5. Leaks help!!
    By Alvin Loh in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 01-04-14, 11:30 AM
LINK TO POST COPIED TO CLIPBOARD