1. weiberry's Avatar
    I am using AT&T Q10 with latest leaked OS. When I roam in China, it is 4G network. Sometime the cellphone is warm, and the battery drain in just a few hours.

    I remember when I used 9900, it was the same. I bought a large battery, and it lasted barely 12 hours.

    I wonder if it has something to do with the network. Because it happened to different devices, I don't think it is due to the devices or the app defect. Also, I installed same apps to my Q10 and Z10. Z10 is for a Chinese local SIM card, and it is with 2G network only. The battery lasts forever.

    Posted via CB10
    03-28-14 07:01 AM
  2. pkcable's Avatar
    It sounds like you may be in a remote area where coverage is spotty and the device is constantly searching for signal or may be changing network protocols, this will cause your battery to run hot and drain more quickly than usual.
    03-28-14 08:22 AM
  3. weiberry's Avatar
    Indeed. I just switched to manual selection on network settings. Hope it will solve the problem. Thank you very much!

    Posted via CB10
    03-28-14 08:51 AM
  4. weiberry's Avatar
    After switching to manual selection of network, the battery performance is better. It lasts 9 hours now. But that is still not good...

    Posted via CB10
    03-29-14 09:19 AM

Similar Threads

  1. Replies: 3
    Last Post: 03-28-14, 10:32 AM
  2. Not capitalizing i {space} to I on Q10
    By LolaPagoda in forum BlackBerry Q10
    Replies: 9
    Last Post: 03-28-14, 08:45 AM
  3. Earnings announced - here is the press release
    By Tariq Nasir in forum BBRY
    Replies: 1
    Last Post: 03-28-14, 08:00 AM
  4. Help needed for Q10 factory restore
    By nigelcross in forum BlackBerry Q10
    Replies: 1
    Last Post: 03-28-14, 06:54 AM
  5. Is anyone else having a problem with the Facebook ap?
    By brianchapnick in forum BlackBerry Q10
    Replies: 1
    Last Post: 03-28-14, 05:55 AM
LINK TO POST COPIED TO CLIPBOARD