1. MaskedMagi's Avatar
    Having to use public wifi so sorry this is brief.

    All of a sudden, out of the blue, the q10 won't detect my sim card. I literally just rewiped it two weeks ago because of some other problems and really don't want to do it again.

    Anyone else had this problem before? Is there an easy fix?

    Thanks.

    Posted via CB10
    06-20-13 08:27 AM
  2. Kris Simundson's Avatar
    Are you using the proper size sim card? If not make sure the pins are alined properly. If you are, check to make sure your surface areas are clean, if they are I'd suggest trying another SIM card to see if it detects it. If it does, than that means your SIM card is faulty, and it needs replacing.
    06-20-13 09:28 AM
  3. kwm1337's Avatar
    Kris gave you some of the best troubleshooting advice there, I'd hardly doubt based on the information provided that wiping your device will do any good. I mean odd things happen, but it sounds like either you need a new SIM, you need your SIM reprogrammed, or it is not easily interfacing with the device.

    and yes this is a common issue with SIM based devices... not common as in it happens to everyone, but when you ask if we've heard of it before, yeah most definitely
    06-20-13 10:15 AM
  4. MaskedMagi's Avatar
    Thanks for the advice guys. It is actually a regular size SIM which I cut down about 6 months ago and it's been working fine till this afternoon.

    I've now tried it in both a Z10 and Q10 and it doesn't work. For some reason though, it DOES work in a Galaxy S4, which is really quite strange...

    I've ordered a replacement SIM but I have to wait a week for it to arrive. Incredibly annoying

    I wonder why it doesn't work with both BlackBerry devices?

    EDIT: Even stranger - when the SIM is in both the Q10 and Z10, I get the extra EE SIM icon for the EE app. That's ot present when my SIM card is out of either phone. And yet it keeps saying it's not detected...
    06-20-13 11:03 AM
  5. kwm1337's Avatar
    Off the top of my head I do not know what information is needed by the S4 to operate with your carrier, but it's possible that some addressing on the SIM card is inaccessible that the BlackBerry needs for the SIM based networks that the S4 doesn't need. Just a thought, I have seen something like that before, it wouldn't surprise me with a SIM card, they are fickle to say the least at times. In other words its possible the BlackBerry's are getting some data off of the card, but not everything. Oversimplified I know, but I hope that makes sense. Be sure to let us know if the new SIM card works for ya!
    06-20-13 11:18 AM
  6. paul24241's Avatar
    Most guys on here are not helping,they are just writting up some stories we need good engineers on this forum
    07-18-13 03:53 AM
  7. blackberryq10betaospro's Avatar
    Take it out and put it back in, worked for me. I was getting no signal

    Posted via CB10
    07-18-13 05:00 AM
  8. MobileMadness002's Avatar
    Most guys on here are not helping,they are just writting up some stories we need good engineers on this forum
    Rude much. If you want engineers on this site, go to school and become one of our first registered engineers.. That being said, and engineer wont do anything here as they wont have the hands on approach and ALL trouble shooting starts with basics.

    Did anything change recently on the device software wise?
    Did any error messages display recently?
    Was the device dropped or jarred?
    Does the SIM card still work in another device?
    Does another SIM work in this device?
    07-18-13 06:40 AM
  9. aarthy bala's Avatar
    hai this is me bala
    from india
    i have problem with my bb q10 - sim not detected
    i guess the sim tray has been damaged & need to be repaired
    can you help me on this
    12-20-15 06:31 AM
  10. octeon2's Avatar
    I have posted an observation in another thread on the same topic. I am not able to post the URL here.
    It could be related to the SIM type (H1 v/s H4)
    01-13-16 09:05 AM

Similar Threads

  1. Sim card not detected!!!
    By lambrosio in forum BlackBerry Z10
    Replies: 10
    Last Post: 08-13-13, 09:16 AM
  2. [HELP !] Sim card not detected
    By Luke Silvestre in forum BlackBerry Pearl 8100
    Replies: 6
    Last Post: 06-02-13, 01:29 PM
  3. Sim card not allowing to send/reply to text messages???
    By Seeleeg in forum BlackBerry Pearl 8100
    Replies: 2
    Last Post: 12-09-07, 08:31 PM
  4. "Sim Card Not Found"
    By berrynewb in forum BlackBerry Curve 83xx
    Replies: 2
    Last Post: 12-07-07, 04:30 PM
LINK TO POST COPIED TO CLIPBOARD