1. JG_Agustin's Avatar
    As the title reads, after updating OTA to 10.2.1.2102 and also downloading the most recent BlackBerry Link (1.2.3, I believe), Link stopped communicating with my Q10.

    The problem began about two weeks ago, when I attempted to back up the Q10. My laptop had a problem and shut down in the middle of the backing up process. After this, the previous Link version (1.2.2, I think) couldn't communicate anymore, but the Q10 worked fine and seemed unaffected.

    I proceeded to do an OS factory reset with Link (using the new 1.2.3 version), which it did. After setting up the Q10 and updating OTA to 10.2.1.2102, I once again plugged the phone to Link and the problem came up once more: "Can't communicate with device" (so I couldn't restore any data).

    Afterwards, I've tried using Link on two different computers (Laptop and PC), both running Windows XP, with the same result. Previously (with prior Link versions), I had no problems at all and even did a back up when 10.2.1 first came out (end of January).

    Additionally, my girlfriend's Q5 also stopped being recognised, although it used to be with prior Link versions. Take into account that unlike my Q10, her Q5 did not go through an interfered/incomplete back up process. Thus, it would seem that the Q10 is not the issue.

    I've tried disabling McAfee's (PC) and Norton's (Laptop) firewalls (after reading some forum suggestions) and then reinstalling Link, with no success. I've also tried BlackBerry's "official" solution of turning on and off the device while being plugged to Link, again, it didn't solve the problem.

    Curiously, the volumes do actually mount and therefore I'm able to access the folders and files of the Flash and SD memories on the Q10 (and gf's Q5), even wirelessly.

    Could it be that Link's new version is somehow incompatible with 10.2.1.2102 or some sort of glitch is causing this? I've read in some posts that a driver may not be properly installed by Link on the computer, if so, how can this be fixed? Or could there be a file missing on my Q10 (and gf's Q5) which did not come with the 10.2.1 update?

    After spending several days trying to solve this problem, the only way I was able to do a back up was using Sachesi. By the way, Sachesi showed 0 MB for Application Data, although once the back up file was ready it had a total size of 2.25 GB. For Media it had shown about 226 MB and for Settings 4 MB, so this would seem to indicate that it did back up the Application Data after all.

    My only thought at the moment (aside from using Sachesi and hoping it backed up all my data) is to wait for the release of a new Link version or of some OS update for the Q10 and Q5 which fixes the problem.

    I would be very thankful if someone could provide any ideas on how to solve the BlackBerry Link issue and perhaps some insight into Sachesi's Application Data indication?

    Likewise, If anyone has a working file for a previous version of BlackBerry Link they can provide, I could give it a shot. BTW, I downloaded a previous version of Link available on CNET's webpage. However, after it installed, an error came up saying a dll file was missing and likewise couldn't communicate with the Q10...

    I truly love my BlackBerry Q10, have used several BBs for the last 6 years (only having one Android device for about 3 months), but this Link issue has me a quite pissed off. I know many people have complained that Link is problematic, but I can't believe it is not being dealt with by BlackBerry, would a signed petition letter help out?

    As additional info, I'm running 10.2.1.2102 on an unlocked Q10 (SQN100-3) with Telcel (Mexico). My gf has an unlocked Q5 (SQR100-2), also running 10.2.1.2102 with Telcel.

    P.S. Sorry for such a long post, but I've tried to give as much useful information as possible, really hope to find a solution. Thanks in advance for any help you can provide, cheers!

    Posted with my awesome Q10!
    Last edited by Sir_Augie; 03-13-14 at 05:31 AM.
    anon(870071) likes this.
    03-13-14 03:48 AM
  2. Uobot Catalonia's Avatar
    I wish someone helps you cos I am having the same prob since Jan that I updated my Q10. I even rebooted it through my link as it adviced me too but still can't communicate with my laptop. I have searched for answers and I am getting feed up honestly. When I used my 9780 I never complained anything for once but with this Q10, I always have something to say.

    Posted via CB10
    03-13-14 09:22 AM
  3. Uobot Catalonia's Avatar
    I just fixed my prob now. I am not sure of wat exactly fixed the issue but I did 2 things,
    1. My laptop was connected to the Internet so it can download any driver if the need arise.
    2. I check a plugin from my avast anti-virus from my device manager and found out it was blocking some kind of connection with its DNS firewall bla bla!! cos it was faulty, so I basically uninstalled it through my device manager form my laptop.
    3. Switched my fone off while it was connected to link and waited for 10secs before switching it on and noticed my laptop was downloading and installing a driver for my BlackBerry. And wallaa!!! It worked. . . I am now connected to link. Try it too. If it possible uninstall ur anti-virus if u still have the installation software. When u done with all and it connects u can install ur anti-virus back. GOODLUCK bro

    Posted via CB10
    03-13-14 10:09 AM
  4. JG_Agustin's Avatar
    Thanks for the tip. After reading your answer I began experimenting a bit more and have seem to come up with a solution. I'll try to describe my actions as best as I can for those who may be having similar issues.

    I tried reinstalling Link a few times on both my laptop and PC (both have Windows XP), with no success at first. Later, I opted to reinstall Link while disabling the McAfee's Firewall on my PC. Next, I plugged the Q10 as to allow it to install the drivers with the Firewall still down and voila: Link finally recognised my device! Not sure if it had anything to do with it, but I had also installed on my PC the most recent Adobe Air.

    Parallely, I bought a Z30 and handed my Q10 to my gf. Funnily enough, we tried plugging the phones on her new laptop (Windows 8) and Link worked flawlessly with both (as well as with her Q5).

    I've repeated the process on my laptop (only with the Z30): disabled Norton's Firewall, installed Link and plugged the phone. Link recognises my Z30 both via USB and wirelessly. I just hope once the Firewalls are reactivated, things will still work...

    I don't know what is it with Link and anti-virus programs, but BlackBerry should look at solving this issue. Hopefully things we'll run smoothly from now on, specially with my new Z30. I'll keep you all updated of any change, cheers!

    Love my Q10 but now it's Z30 time!!!
    04-07-14 07:16 PM
  5. JG_Agustin's Avatar
    Found this on another thread, it seems to be the answer to the issue many of us we're facing with Link: http://btsc.webapps.blackberry.com/b...ListHelperImpl

    Love my Q10 but now it's Z30 time!!!
    04-14-14 02:11 PM

Similar Threads

  1. Replies: 5
    Last Post: 05-19-14, 10:18 AM
  2. Why can not developers control the camera?
    By quizm in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 03-16-14, 06:43 AM
  3. Why Does my Q10 Delete my Email Account?
    By velkod in forum General BlackBerry News, Discussion & Rumors
    Replies: 11
    Last Post: 03-14-14, 04:26 PM
  4. Virgin Media offer a line rental discount with the BlackBerry Q5 on their VIP tariff
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 03-13-14, 03:22 AM
LINK TO POST COPIED TO CLIPBOARD