Sign up now for Disney+
  1. blackshark's Avatar
    Wifi was working but it wouldnt let me back up thu wifi, so turned it off to use usb. Device is not recognized thru usb in Link software and you need usb to turn wifi back on. Any tricks to get usb to hook?
    Have tried three cables I know work, 3 diff ports. Device shows as a drive but not in the link software.
    10-20-15 05:21 PM
  2. BB-JAM215's Avatar
    Have you tried installing (or re-installing) the latest version of Link? It includes the software drivers needed to connect via USB.
    https://swdownloads.blackberry.com/D...5C7D7B210455DE

    When you connect your phone via USB you should see the BlackBerry Device Manager pop up in the lower right hand corner of the screen.
    10-20-15 06:25 PM
  3. Ningai's Avatar
    I have had this issue for months on multiple computers. None of them with any OS or PC or Mac will recognize my Q10. I have the latest OS for both and have spend hours trying to figure it out. Any ideas?
    10-23-15 12:41 AM
  4. BB-JAM215's Avatar
    Most likely cause then is a damaged USB connector on your Q10.
    10-23-15 01:31 AM
  5. muellerto's Avatar
    Have you mass storage mode on? This is an option in the device settings. Mass storage mode and BB Link are not good friends.

    If you want to use BB Link to access the device memory or the SD card via USB you must switch mass storage mode off. Then the driver on the PC which has been installed with BB Link will mount two USB drives, one for the device memory, one for the SD card.

    Another situation is when BB Link is not installed on the PC and also switched off on the device. Then you can switch on mass storage mode and the PC will recognize at least the SD card and mount it as an USB drive. BB Link isn't needed at all for this. I use only this way because I have a Linux machine.
    10-23-15 01:47 AM
  6. Ningai's Avatar
    Mass storage is off. It actually brings up a warning that it won't connect to Link when you turn it on. I just need to backup my phone so I can switch to a Classic.

    Consequently, I bought a second, used Q10 off ebay for a backup and it won't connect to any computer, either. There's a machine with Windows 8, Vista and a new Macbook that I've tried. Could it be the cable? I'm really at a loss here.
    10-23-15 02:23 AM
  7. HarvMan's Avatar
    Hi,
    Recommend that you use Backup Pro available at BlackBerry World.
    10-23-15 02:50 AM
  8. Ningai's Avatar
    Will that allow me to transfer between phones? That's really the big thing I'm looking for.
    10-23-15 02:51 AM
  9. tex3523's Avatar
    I'm sure you've tried this but just in case:

    Turn off WiFi on computer and device. Reboot both devices (wait like 10 minutes)
    Plug in device and see if it launches link.

    Posted from my awesome Q10
    10-23-15 12:07 PM
  10. Ningai's Avatar
    Just tried that, didn't work with WiFi off on both. I have tried with the WiFi off on the phone.
    Last edited by Ningai; 10-23-15 at 10:19 PM.
    10-23-15 10:07 PM
  11. Ningai's Avatar
    It was the cable!
    10-24-15 12:37 AM

Similar Threads

  1. Why is it so hard to find here the EXIT ?
    By Mee Kiu in forum Site Feedback & Help
    Replies: 6
    Last Post: 10-21-15, 02:17 PM
  2. New to BBM
    By TRMP87 in forum General BBM Chat
    Replies: 2
    Last Post: 10-21-15, 12:44 PM
  3. Replies: 3
    Last Post: 10-21-15, 05:16 AM
  4. forum search send me to yahoo aggregator
    By blackshark in forum BlackBerry Q10
    Replies: 1
    Last Post: 10-20-15, 06:04 PM
  5. How to change my blackberry id on z10?
    By dora tabaco in forum Ask a Question
    Replies: 1
    Last Post: 10-20-15, 04:02 PM
LINK TO POST COPIED TO CLIPBOARD