1. letrantrung's Avatar
    Hi everyone,
    I am experiencing terrible lagging for replying/composing an email (text, whatsapp, bbm, CB 10 comment, etc is no problem)
    I am using 10.3.1 now. Both Offical or Leaked version could not solve the problem.
    Due to high demand of using emails everyday, does anyone know how to solve this?
    Thanks a lot in advance.

    Posted via CB10
    03-21-15 07:44 AM
  2. letrantrung's Avatar
    Hi all, need your help.

    Posted via CB10
    03-21-15 09:21 AM
  3. letrantrung's Avatar
    ...

    Posted via CrackBerry App
    03-21-15 07:11 PM
  4. curves2000's Avatar
    Not sure if this would actually help or not but a few suggestions perhaps would be.

    1) Hard reset by holding down the power button at the top of the phone.

    2) Battery pull. I know BB10 doesn't need it but once in a blue moon I find that it helps to reset the phone and re calibrate everything. I do this probably once ever 3 months if my phone seems a tad sluggish.

    3) You might be able to get things to speed up a bit by deleting any unnecessary messages or BBM, Emails etc. This doesn't sound like a great option but if you have some super long message history's from close family or friends that aren't important it might speed things up.

    Wish I could offer more. Good luck!

    Posted via CB10
    03-21-15 11:03 PM
  5. jevinzac's Avatar
    2) Battery pull. I know BB10 doesn't need it but once in a blue moon I find that it helps to reset the phone and re calibrate everything. I do this probably once ever 3 months if my phone seems a tad sluggish.

    Posted via CB10
    Never do a battery pull on any BB10 device, it will corrupt the OS! BBOS and BB10 are completely different! BB10 is based on QNX and BBOS is based on Java. There's nothing similar in the OS.

    @OP: Which OS is installed on your Z10?

    Posted via CB10
    03-21-15 11:34 PM
  6. curves2000's Avatar
    What exactly do you mean by corrupt the OS? On my Q10 I haven't ever had any issues with freezing or anything like I did with my 9900. Once in a while after a long period of ultra heavy use (lots of emails, messages, downloads, calls) etc at the same time the phone gets a little sluggish. I will take the battery out and place it back in within a minute and all is well.

    Thx

    Posted via CB10
    03-22-15 12:02 AM
  7. jevinzac's Avatar
    What exactly do you mean by corrupt the OS? On my Q10 I haven't ever had any issues with freezing or anything like I did with my 9900. Once in a while after a long period of ultra heavy use (lots of emails, messages, downloads, calls) etc at the same time the phone gets a little sluggish. I will take the battery out and place it back in within a minute and all is well.

    Thx

    Posted via CB10
    Same thing that happens to a Windows OS on a PC when the power shuts off unexpectedly.
    You either can do a hard reboot with vol up/down keys, or long press power button, click shut down, and then take out your battery!

    Posted via CB10
    03-22-15 06:47 AM
  8. letrantrung's Avatar
    Never do a battery pull on any BB10 device, it will corrupt the OS! BBOS and BB10 are completely different! BB10 is based on QNX and BBOS is based on Java. There's nothing similar in the OS.

    @OP: Which OS is installed on your Z10?

    Posted via CB10
    I tried Leak from 10.3.0, then 10.3.1.1154, and Official 10.3.1.2243.
    Now I am using 10.3.1.2258.
    All versions resulted in similar issue.
    I did not have this issue with 10.2.1 before.
    So, if this can be solved, this phone is a perfect device to me
    I tried reboot almost everyday - reset, battery pull (because I had a spare battery). But things did not change until now.
    Will consider your suggestions but if you have any other ideas, I am very welcome!

    Posted via CB10
    03-22-15 10:03 AM
  9. jevinzac's Avatar
    I tried Leak from 10.3.0, then 10.3.1.1154, and Official 10.3.1.2243.
    Now I am using 10.3.1.2258.
    All versions resulted in similar issue.
    I did not have this issue with 10.2.1 before.
    So, if this can be solved, this phone is a perfect device to me
    I tried reboot almost everyday - reset, battery pull (because I had a spare battery). But things did not change until now.
    Will consider your suggestions but if you have any other ideas, I am very welcome!

    Posted via CB10
    Try OS10.3.1.2582.

    Posted via CB10
    03-22-15 08:40 PM
  10. letrantrung's Avatar
    Try OS10.3.1.2582.

    Posted via CB10
    Thanks for the advice.
    Is it very much better in all aspects - battery, wifi, emails, hub, etc.

    Posted via CB10
    03-23-15 02:20 AM
  11. jevinzac's Avatar
    Thanks for the advice.
    Is it very much better in all aspects - battery, wifi, emails, hub, etc.

    Posted via CB10
    On my Q10 it's so smooth, battery seems to be unpredictable. It's smoother than previous OS on my friends' Z10.
    Cannot comment on WiFi since I don't use it.

    Posted via CB10
    03-23-15 05:38 AM

Similar Threads

  1. Cannot Open Links For New Tabs in Background???
    By deuce2290 in forum BlackBerry Passport
    Replies: 9
    Last Post: 03-25-15, 02:34 AM
  2. Why does my Q10 get hot often even if I have no running apps.
    By Mayowa Pitan in forum Ask a Question
    Replies: 4
    Last Post: 03-21-15, 08:46 PM
  3. Help to use apps...
    By kpkp123 in forum Ask a Question
    Replies: 1
    Last Post: 03-21-15, 09:22 AM
  4. Weird bootup glitch 10.3.1.2558 (Q10)
    By InfinityBob in forum BB10 Leaked/Beta OS
    Replies: 1
    Last Post: 03-21-15, 09:17 AM
  5. Why are my Emails sending twice?
    By Jessie0123 in forum BlackBerry Q10
    Replies: 1
    Last Post: 03-21-15, 09:12 AM
LINK TO POST COPIED TO CLIPBOARD