1. Jm9301's Avatar
    Hello, maybe someone can help me out.

    My q10 which was replaced 4 months ago seems to be out of sorts. I was listening to some tune in radio, sitting in my kitchen, had roughly 30% battery left. When all of a sudden it starts he shutdown count and powers off. Odd I guess, but maybe I misjudged the battery, so I go take it to the charger, and the red led starts blinking its on for about 5 seconds, then off for maybe two, constantly, and then the blackberry logo comes on as if booting up for a couple seconds, which then disappears and it starts the red blinking thing over again.

    Tried a battery pull, nothing, tried the power button, nothing. Tried putting on charger, nothing, the same blinking patern, only the blackberry logo doesn't come up on screen.

    Anyone had this problem? Also I just updated the latest OS earlier today.

    Thanks, John
    07-09-14 12:02 AM
  2. anon721037's Avatar
    I would plug into link and reload the software, or install via an autoloader.
    Nayalm likes this.
    07-09-14 12:05 AM
  3. anon721037's Avatar
    I think there have been a few problems out there with the update done via OTA.
    Nayalm likes this.
    07-09-14 12:05 AM

Similar Threads

  1. My Z10 pocket dialed 911 again
    By JTon in forum BlackBerry 10 OS
    Replies: 34
    Last Post: 09-08-14, 11:17 AM
  2. Utility Keys on Passport Keyboard?
    By BACK-2-BLACK in forum BlackBerry Passport
    Replies: 4
    Last Post: 07-17-14, 08:41 PM
  3. Android app not working over 3G, but OK over WiFi Z10
    By boxerboomjay in forum BlackBerry Z10
    Replies: 18
    Last Post: 07-09-14, 10:43 AM
  4. curve 9380 is not switching on
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-09-14, 01:41 AM
  5. How to increase the amount of emails stored on my Q10
    By George Leck in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 07-08-14, 10:22 PM
LINK TO POST COPIED TO CLIPBOARD