1. zap7's Avatar
    Hi,
    it started yesterday and drives me nuts: When I went to bed, I wanted to open the clock app as usuall and set my alarm. But the clock app wouldn't start. It just shows "Blackberry 10" on a black background (like it briefly does for 1-2 seconds when you go into your settings screen). I tried it 5 times. From the seetings screens with choosing "Alarm" and with starting the clock app icon. I waited for 2 minutes each time, but the clock never showed, it was stuck at the "Blackberry 10" screen. I rebooted the device. It stayed the same.
    Never happened before and the only thing I did yesterday was updating two of my Andriod apps (Tripit Pro and Jawbone Up) that I am using since last year.

    I have looked for one hours but can't find anything about this problem anywhere, all that shows up is people complaining about the alarm not sounding when the device is turned off. But for me, the clock simply won't start up! The alarm does sound, but I can't adjust or set it. And I can't see the clock.

    What should I do? Any idea?
    I want to avoid the full factory reset because I am travelling through some foreign countrys at the moment with only 20 hours and lots of appointments in between, and I need all those Apps, data and settings on my device. I am afraid a factory reset will take 5-7 hours to restore all the Apps, their data and settings afterwards....
    Thanks,
    zap!
    04-28-14 12:31 PM
  2. eldricho's Avatar
    Hi,
    Sorry to hear about your problems
    First thing that jumped into my mind, was to sideload a clock bar file to overwrite the current one OR you could also try doing a handset reset by holding the volume rockers and trying the clock again when it boots up

    Posted via CB10
    zap7 likes this.
    04-28-14 02:02 PM
  3. nicolas hendrawan's Avatar
    excuse me... is that working for handset reset? I have the same problem for 2 days until now. because when I try it and booted up, my clock still appeare that black background with "blackberry 10" letter, i just little afraid to doing sideloading, because I never done that... or is there any method to reset for BB Z10? I just try holding the power button until it appear the blue blackberry icon, because it can't reset when i try holding the volume rockers (in the middle of volume right?)

    sorry for my bad english and thanks before...
    05-28-14 11:50 AM
  4. zap7's Avatar
    The problem seems to come from a corrupted alarms database. No reset or reinstalling of the clock app helped. Before it occurred, I copied a line of text from an email message to the clipboard and pasted it to an alarm to remember it. When I went back to adjusting the alarms, the text had gotten much longer with special characters in it, so some special letter or character from the text or just the overall length must have caused the alarms database to get corrupted. I tried to find and delete the database with the alarms, but with no luck: I spend 6 hours on it and didn't find it. Does anyone know how to delete this database, how to reset it, or how to delete it from a device backup (so I could do a factory reset and reinstall everything else except the alarms database)?

    A reset does NOT help (no matter which method you use) and re-installing the clock .bar file also does NOT help. I could install the Porsche clock (only one alert instead of multiple ones) to have a clock again, but the other clock still won't start AND the old alarms will sound every time. I lost my blackberry in a taxi/cab after I tried to find and delete the database file with the alarms for 6 hours with no success. That was on a trip on the other side of the world four weeks ago and the device is now found and on its way back to me.

    The only option I see is to do a factory reset and installing all data again which I hate because I'll loose some settings (Wifi network keys etc)... I f I would put a backup back on, I'll either have the corrupted alert database that causes the problem or old data...

    Does anyone know how to delete just the database with the alarms or how to reinstall a fresh database?
    Thanks,
    zap!
    05-29-14 04:01 AM
  5. blee4's Avatar
    Some of the problems that plague Blackberry devices are just amazing.
    05-29-14 09:11 AM
  6. zap7's Avatar
    Solved! Guys, if you can't open the alarm clock anymore because it crashes/freezes even after a reset, OS update, reinstalling the clock app via side loading and installing of the Porsche clock, here is how I solved it:
    Just received my lost device back after customs released it from a journey around half of the world. I did spent 10 hours to try to find the database with the alarms - once it gets corrupted, you won't be able to change them anymore and won't be able to run the clock. I tried to decrypt and change the file in my backups - no success. I tried to restore a backup with all data except this database but couldn't select the single files in BB Link.

    I was close to giving up, but then I found an old backup from my migration from the old BB 9900 to my Q10. I selected to restore it, deselected "all data", and only selected "clock options". So I basically restored an old clock options file from my BB9900 via Blackberry Link to my Q10. Fortunately the files seem to have the same name, to be at the same location and the new clock is able to read it. So this killed the corrupted database and my clock now starts up again!

    So if anyone else of you has this problem, I hope it'll help you to solve it without spending a whole day looking for what to do...
    Cheers,
    zap!
    06-11-14 03:13 PM
  7. tex3523's Avatar
    Have you tried swiping down from the lock screen. See if you can get it to open that way? Its bedside mode.

    Posted from my awesome Q10
    06-11-14 04:03 PM
  8. zap7's Avatar
    Thanks, but no matter how you try to start the clock, when it's froozen because of a corrupted alarms DB, nothing works to start it. Not bedside mode, not hitting "alarms" on the quick settings menu you can pull down from the top of the screen, and tapping on the clock icon also won't work. No reset, battery pull, OS upgrade or re-sideloading the clock works either.

    It's an error in the clock app since it can handle multiple alarms: Once you have too many alarms with texts that are too long - which can be caused by non standard characters inserted into the alarm via copy and paste (that will make the text longer each time you edit your alarms), it will never start again , there will be no way to edit your alarms and they will always sound if the device is not fully switched off. The solution is in my post above: Restore an old clock options database from a device you used before switching to BB10.

    If anyone knows any other way to reset or delete the "clock options" database (resets, sideloading of clock app or OS updates will NOT help, see above), please post it here. My problem is solved and the way described it will also work for anyone else who had an old BB 5/6/ device before switching to BB10 and still has the backup. But if anyone who started with BB10 will run into the same problem, he needs to find another way...

    Cheers,
    zap!
    06-11-14 06:44 PM
  9. tmac1983's Avatar
    Zap,

    I am having the same issue, but I do not have the old backup from my migration from the old BB 9900 to my Q10. is there a way to do this without this file?

    Thank You,

    Tara
    07-06-14 05:20 PM

Similar Threads

  1. What is your best applications on Q10.
    By Ashraf Altayeb in forum BlackBerry Q10
    Replies: 26
    Last Post: 07-13-14, 11:38 AM
  2. T-MO Black Q10
    By Furell in forum Buy, Sell, Trade - Sold / Archived
    Replies: 13
    Last Post: 05-09-14, 12:14 PM
  3. Wifi issue on Q10
    By AnthonyWhoso in forum BlackBerry Q10
    Replies: 3
    Last Post: 04-28-14, 12:34 PM
  4. Replies: 1
    Last Post: 04-28-14, 10:52 AM
LINK TO POST COPIED TO CLIPBOARD