1. hairnova's Avatar
    Just went to take a picture this morning and I'm getting a black screen. I can tap it and it makes the shutter noise but the picture doesn't get taken and it freezes up. Tried other apps with camera use and same thing.

    How do I go about fixing this?
    12-13-13 11:51 AM
  2. snoozininsomniac's Avatar
    to start off simple, have you tried a device restart? (press and hold volume rockers + and - for about 30-45 seconds; ignore the screenshot notice, keep it held down until you see boot-up logo.)
    then try the camera again.
    12-13-13 01:57 PM
  3. hairnova's Avatar
    to start off simple, have you tried a device restart? (press and hold volume rockers + and - for about 30-45 seconds; ignore the screenshot notice, keep it held down until you see boot-up logo.)
    then try the camera again.
    Just tried that and nothing changed.
    12-13-13 02:04 PM
  4. snoozininsomniac's Avatar
    are you using a stock OS or leak?
    do you know how to sideload?
    perhaps you may want to try and sideload a version of the 10.2.1 camera that has facial recognition.
    12-13-13 02:17 PM
  5. hairnova's Avatar
    are you using a stock OS or leak?
    do you know how to sideload?
    perhaps you may want to try and sideload a version of the 10.2.1 camera that has facial recognition.
    I'm using 10.2.0.429.

    I know how to sideload but is that compatible with my OS?
    12-13-13 02:48 PM
  6. hairnova's Avatar
    Having the same issue with that camera. Black screen.
    12-13-13 03:07 PM
  7. snoozininsomniac's Avatar
    so without taking the picture, you can still see the image on the screen right? only when TAKE the picture, does the picture end up black? or the camera app itself freeze on black; rendering you to minimize/close app to continue? (trying to see if its the picture viewer app that has an issue, or the camera app that has an issue. if it was hardware, you would not see anything coming from the camera at all)
    12-13-13 03:15 PM
  8. hairnova's Avatar
    so without taking the picture, you can still see the image on the screen right? only when TAKE the picture, does the picture end up black? or the camera app itself freeze on black; rendering you to minimize/close app to continue? (trying to see if its the picture viewer app that has an issue, or the camera app that has an issue. if it was hardware, you would not see anything coming from the camera at all)
    When I open the camera app, this is what I see.



    When I tap the screen to take a picture, it makes the shutter noise but doesn't do anything.

    The front camera works though.
    12-13-13 03:21 PM
  9. snoozininsomniac's Avatar
    hmm, when you move the phone around, does the autofocus work?

    i cant say i know all the inner workings but i would guess that after a reload of the camera bar, and the same problem still existing, that its either a deeper rooted OS issue (resolvable by reloading of the OS or newer OS) OR there is a physical hardware problem with the camera itself. maybe someone else can chime in..

    if it were me, and i had the time, i'd load up a leak os just to see. this could be a good excuse to try out a new leak
    12-13-13 05:00 PM
  10. hairnova's Avatar
    I'll have to look into getting a leak to see if it makes a difference but that'll have to wait for another day.

    Any other advice, anyone?
    12-13-13 08:48 PM
  11. azum4u's Avatar
    12-13-13 10:29 PM
  12. TheR1ck's Avatar
    Got same problem here

    Posted via CB10
    12-14-13 12:30 PM
  13. mEntal8y's Avatar
    This happened to me because I used an App that makes the shutter silent. When I open the camera application there is just a black screen. What I did to solve it was to play around with the settings like: change camera, use the video recorder and then suddenly it just started again. SO. Play around with the settings and maybe it will work for you too.
    12-15-13 01:14 AM
  14. TheR1ck's Avatar
    This happened to me because I used an App that makes the shutter silent. When I open the camera application there is just a black screen. What I did to solve it was to play around with the settings like: change camera, use the video recorder and then suddenly it just started again. SO. Play around with the settings and maybe it will work for you too.
    Not woking even tried reloading factory os and still nothing. I believe it's hardware I just got the fone last week and I think it never worked to begin with.

    Posted via CB10
    12-15-13 12:37 PM
  15. HereinHalifax's Avatar
    I had this same problem as well. It was initially intermittent, then it got to the point where it would only show colour bars when I invoked the app. I ended up sending it off for repairs. That did the trick, and it has worked reliably ever since.
    12-15-13 12:47 PM
  16. hairnova's Avatar
    I'll probably have to send it off for repairs too.
    12-16-13 08:09 AM
  17. TheR1ck's Avatar
    My provider just gave a me an new Q10

    Posted via CB10
    12-16-13 11:17 PM
  18. leeboy82's Avatar
    My verizon Q10 had the rainbow affect and camera didn't work but the front facing one did. Pulled the battery out 3 times and it fixed itself. It's been 2 days now and no problem
    Q10 camera stopped working-screencap_130029-190020.jpg

    Posted via CB10
    01-01-14 01:25 PM
  19. jcchien's Avatar
    get the same problem here. how to fix this issue ? still can't figure out !
    04-19-14 06:43 AM
  20. pcwilliams's Avatar
    this thread is a few months old, but...i had this same problem...black screen on rear facing camera. turns out there was a loose connection. i opened my phone and checked all the connections. after putting it back together the camera now works. if you have the proper tools, and are not afraid to open up your phone, it may be a simple fix.
    06-14-14 12:24 PM

Similar Threads

  1. What is the Runtime Missing that iTunes Remotes Doesn't Work?
    By bendiep1991 in forum BlackBerry 10 OS
    Replies: 12
    Last Post: 02-02-14, 07:03 PM
  2. Camera Talk - Are Folks Disappointed?
    By quizm in forum BlackBerry 10 OS
    Replies: 67
    Last Post: 12-17-13, 12:50 PM
  3. Sudden, serious Q10 battery issues
    By caitlinx in forum BlackBerry Q10
    Replies: 6
    Last Post: 12-13-13, 08:12 PM
  4. BlackBerry Q10 Ripped Off
    By nerdydaddyo in forum BlackBerry Q10
    Replies: 1
    Last Post: 12-13-13, 08:31 AM
  5. Camera application missing on Q10
    By AdellieS in forum Site and App Feedback & Help
    Replies: 1
    Last Post: 12-13-13, 06:16 AM
LINK TO POST COPIED TO CLIPBOARD