04-27-14 09:41 AM
73 123
tools
  1. Dmitry Kisselyov's Avatar
    This is typical behavior of PIM Services these days: I turned the mobile data on about 20 minutes prior to this spike that again obliterated my daily data quota from the carrier. No apps were active at the moment, no messages sent or received -- nothing I have done, and nothing I can do to avoid this.

    PIM SERVICES! Has anyone successfully tamed this beast?-img_20140208_151518.png

    Note that PIM Wifi usage is pretty wild too.
    02-08-14 05:21 AM
  2. TheStoryUp's Avatar
    I'm going to point you towards this other thread where someone was having a very similar issue. There's lots of good information and I think you'll find your answer you need.

    http://forums.crackberry.com/showthread.php?t=882644

    Zed30
    02-08-14 03:58 PM
  3. niceup's Avatar
    I've set mine to manual.
    Seems tamed it a Lil bit. But most of us who are irritated by PIM services are mainly because it consumes data and battery without any ways to stop it.
    And I guess there's no other better option than set it to manual.

    Posted via Awesome Astro flying10.2.1.1925 on CB10. For a regular dose of Quotes, subscribe C001190A9 .
    How do you set your pim services to manual?

    Miami Heat Fan C00124BF1 | New York Business Broker C0010B9A9 @kylesellsbiz
    02-08-14 04:46 PM
  4. zed_10's Avatar
    The pim services really drained my battery

    Take a look at this

    Attachment 245506

    I dont use twitter and facebook, i only have 1 gmail account, no contacts n calendar synced, 15 emails per day, only for bbm (1.700+ contacts), and whatsapp. I have to charge it every now and then, the battery will dead at around 3-3.5hours.

    Posted via CB10
    Wow, that is some pretty crazy numbers there, if I read it right you drained from a full charge to 8% in just over 1.5 hrs......besides the 42% in pim services you also had 7% in text messages that seems very high to me as well...I'm not a huge texter?, but my percent at the end of a day is usually less than 1%,.....i also see almost 3% in BlackBerry Messenger which also seems high....
    I don't have any recommendations to correct your issue (apologies), I just wanted to point out what I see as an irregularity... maybe others have seen the same....i will try tomorrow to text for 1.5 hrs (will drive some people nuts) but I am really interested to see how it can get that high in such a short time...

    Update: just checked back on NY usage over 48 hours, and it seems as though sending and receiving pictures thru text messages is a huge pim, text, and battery hog.....i see spikes at those times and not where I was simply texting....my guess is that you had been sharing/receiving a large amount of pictures then?

    Posted via CB10
    Last edited by zed_10; 02-08-14 at 05:52 PM.
    emmberry likes this.
    02-08-14 05:19 PM
  5. TheStoryUp's Avatar
    Check sync settings for Box and Dropbox, do you have an Evernote account?

    Can you post pictures of your text message settings for SMS and MMS(find it in the Hub settings)

    Is BlackBerry Link on?
    Try removing your SD card (sometime indexing on a bad card will cause battery drain)

    Is Encryption turned on? (in security settings) turn off

    Is diagnostics turned on? (turn off)

    PIM consists of 4 core applications, Contacts, Calendar, messages and Remember. Other applications can have permissions to access these core applications.

    If you goto Settings > Security and Privacy > Application Permissions. In there is a drop down menu that let's you see what third-party app are allowed to access the core apps on the phone (text, camera, contacts, calender, notebook, phone, internet, locations, etc)

    Check the Text, contacts, calender and notebook. Grab a pen and write down every app that has permission to access to these core applications. Once you have your list set the drop down menu back to "All". Go through your list and ONE BY ONE turn off all the permissions for each of those apps. Space it out at least 30min between apps, checking the PIM % as you go.

    This may take a long time depending on how many apps you have, but it should narrow it down to what app is causing the problem. If this doesn't work you can pretty much eliminate it being a third party app.

    Zed30
    TeamBbryUSA likes this.
    02-09-14 12:01 PM
  6. NursingNinja's Avatar
    I use one active sync account, Facebook and Twitter and notice that I get a full day unless I'm giving my Z10 heavy use. Since I prefer not to conserve I carry a spare battery. They are cheap these days.

    Posted via CB10
    02-09-14 12:14 PM
  7. --TommesJay--'s Avatar
    PIM SERVICES! Has anyone successfully tamed this beast?-img_20140209_202439.png

    I'll do research on this.
    02-09-14 01:25 PM
  8. Dmitry Kisselyov's Avatar
    Seems to me it tries to replicate the same pattern it follows when on Wifi as soon as there is no Wifi connection but carrier's data available. I get it that some app might have a wrong permission. What I do not get is how this can affect mobile data even though no app has a permission to use it but the hub.
    02-10-14 12:02 AM
  9. Pete The Penguin's Avatar
    I've set mine to manual.
    Seems tamed it a Lil bit. But most of us who are irritated by PIM services are mainly because it consumes data and battery without any ways to stop it.
    And I guess there's no other better option than set it to manual.

    Posted via Awesome Astro flying10.2.1.1925 on CB10. For a regular dose of Quotes, subscribe C001190A9 .
    Where do you change the sync options?
    02-10-14 12:09 AM
  10. jafrul's Avatar
    Where do you change the sync options?
    Settings > device monitor > PIM services > accounts > gmail/yahoo mail > contacts > sync interval > manual


    Edit: LOL.. what a big u turn.
    You can actually go straight from settings > accounts > and do your settings as above

    Posted via Awesome Astro flying10.2.1.1925 on CB10. For a regular dose of Quotes, subscribe C001190A9 .
    Last edited by jafrul; 02-10-14 at 01:05 AM.
    Pete The Penguin likes this.
    02-10-14 12:49 AM
  11. jafrul's Avatar
    And oh yeah, if I'm not mistaken, I've read somewhere that when u set to manual, it will only sync with your account when you make changes in phone book or adding a new/edit contacts.

    Posted via Awesome Astro flying10.2.1.1925 on CB10. For a regular dose of Quotes, subscribe C001190A9 .
    02-10-14 12:51 AM
  12. davinci4real's Avatar
    And oh yeah, if I'm not mistaken, I've read somewhere that when u set to manual, it will only sync with your account when you make changes in phone book or adding a new/edit contacts.

    Posted via Awesome Astro flying10.2.1.1925 on CB10. For a regular dose of Quotes, subscribe C001190A9 .
    And someone said it was whenever you opened the phone book. *confused*

    Posted via CB10
    02-10-14 02:14 AM
  13. Pete The Penguin's Avatar
    Settings > device monitor > PIM services > accounts > gmail/yahoo mail > contacts > sync interval > manual


    Edit: LOL.. what a big u turn.
    You can actually go straight from settings > accounts > and do your settings as above

    Posted via Awesome Astro flying10.2.1.1925 on CB10. For a regular dose of Quotes, subscribe C001190A9 .
    Thank you.
    02-10-14 08:42 AM
  14. yeohda's Avatar
    Having the same issue here. Running Z30 with 10.2.1

    For me the issue is that when I unplug my phone from the charger and leave the house. In the course of the next hour or so it chews up around 20-30 percent of battery. Check out the pattern in the battery usage of PIM Services. Hope this gets settled soon.
    PIM SERVICES! Has anyone successfully tamed this beast?-img_20140214_081727.png

    Posted via CB10
    02-13-14 07:20 PM
  15. Dmitry Kisselyov's Avatar
    My hunch is that the key to this trouble is somewhere around here:
    PIM SERVICES! Has anyone successfully tamed this beast?-img_20140216_234713.png

    Notice how Wifi usage keeps jumping up to a certain point with almost regular intervals, in my case up to 188 MB. It UPLOADS something at the rate of several Gigs a day! I would love to learn from someone what causes this.
    02-16-14 01:50 PM
  16. davinci4real's Avatar
    My hunch is that the key to this trouble is somewhere around here:
    Click image for larger version. 

Name:	IMG_20140216_234713.png 
Views:	2670 
Size:	86.4 KB 
ID:	248533

    Notice how Wifi usage keeps jumping up to a certain point with almost regular intervals, in my case up to 188 MB. It UPLOADS something at the rate of several Gigs a day! I would love to learn from someone what causes this.
    Maybe it's dropbox

    From Zarafet my Z30.
    02-16-14 03:57 PM
  17. Pat Andres's Avatar
    I tried deleting my Facebook account and the pim just dropped to less than 10% from 50% cpu usage

    Posted via CB10
    02-18-14 08:40 PM
  18. Pat Andres's Avatar
    I've deleted and added again my yahoo account, and I think it's the mail that causes the problem..

    Posted via CB10
    02-18-14 09:16 PM
  19. Dmitry Kisselyov's Avatar
    I have set all my email accounts sync to 24 hours. As soon as I have done it my PIM services uploads went from approximately 190 to whopping 380 at a time several times an hour. A surprising effect, isn't it?
    02-19-14 11:37 AM
  20. Dmitry Kisselyov's Avatar
    PIM SERVICES! Has anyone successfully tamed this beast?-img_20140219_213204.png here is the screen shot: lowering spikes were when my sync intervals were between 5 mins and manual for for different accounts. Taller ones started appearing after setting everything up to sync once a day.
    02-19-14 11:39 AM
  21. Z30Rockz's Avatar
    For everyone having PIM Services and System issues. Have you tried rebooting your device? Does it fix the problem for you?

    Posted via CB10
    02-19-14 11:46 AM
  22. Dmitry Kisselyov's Avatar
    I had and it does not
    02-19-14 12:12 PM
  23. mjolnirgs's Avatar
    I get this problem periodically. I narrowed it down to one of my exchange e-mail accounts, connecting to an older mail server. The sync for my mailbox gets screwed up and it causes it to try to resync all of my mail, then errors out part of the way through and starts again from the beginning, in an endless loop.

    This causes the phone to get hot and wipes my battery out in record time. To stop it I just change the sync time frame from my usual 30 days to 14 days, wait an hour for it to finish syncing, and switch it back to 30 days. The phone cools down, and everything goes back to normal.



    Posted via CB10
    02-19-14 03:41 PM
  24. Dmitry Kisselyov's Avatar
    Thank you! Too bad I only have simple Gmail accts.
    02-19-14 08:53 PM
  25. Dmitry Kisselyov's Avatar
    Then I ordered my email accounts to manual sync. Here is my new pattern. PIM keeps UPLOADING roughly 390 MB at a time.
    PIM SERVICES! Has anyone successfully tamed this beast?-img_20140222_220019.png
    02-22-14 12:11 PM
73 123

Similar Threads

  1. Anyone having T-Mo 4G LTE issues?
    By Maestra in forum General Carrier Discussion
    Replies: 2
    Last Post: 02-09-14, 06:16 AM
  2. Does anyone have the Twitter 10.2.2.1 bar?
    By BKA22 in forum BlackBerry 10 Apps
    Replies: 5
    Last Post: 02-06-14, 03:40 PM
  3. Has anyone found a work around for Sky Go?
    By henfordd in forum BlackBerry Z30
    Replies: 1
    Last Post: 02-06-14, 01:11 PM
  4. Best z10 unlock service price?
    By acadia1106 in forum BlackBerry Z10
    Replies: 4
    Last Post: 02-06-14, 05:22 AM
  5. Instagram has deleted 2 of my accounts
    By drfever in forum BlackBerry 10 Apps
    Replies: 12
    Last Post: 02-06-14, 12:49 AM
LINK TO POST COPIED TO CLIPBOARD