05-12-14 01:25 PM
37 12
tools
  1. AmarC84's Avatar
    Hi,

    I have read multiple threads on this issue but I have not found a concrete solution to deal with this.

    I have got Q10, 3 weeks back. Since then I am facing a lot of battery drain under the header called as 'PIM Services' and then 'System'. Earlier I thought its due to the software update and it takes anything between 24 hours to a week settle down. So by now, I assume it would have settled down.

    But it has been 3 weeks and PIM services continue to drain my maximum battery (over 15-20% ). And then system (another 15-20%). I have 2 email accounts, 1 twitter account (which is not quite active), 1 BBM account (not very active with 1 contact only) and LinkedIn and What's app (active) in my BB hub. I have 2000+ contacts in my address book.

    My OS version is 10.2.1.2141. I have taken care of other battery saving measures like reduced display brightness, switching off diagnostics, location services, link etc.

    Can someone really help here?

    Thanks

    Amar
    04-03-14 08:58 AM
  2. Stwutter's Avatar
    I can only go from my own experience, but in case it's of use...

    Had my Z30 for about a month. About a week ago, it started getting VERY hot, and the battery started to drain a lot faster than usual - 20% gone in an hour instead of the usual 5-6%. PIM services were clearly to blame according to the device monitor. System was also similar in size, but I think this is likely to rise along with PIM if it's being worked-over.

    I couldn't work out what it was but then looked at Twitter - I have a large Twitter account (30'000+), and, after a reset, I found that my contact list took hours to rebuild itself - it seems that when you reset a BB10 handset, it automatically puts all accounts into your contacts list, even if they were deselected before - I obviously had Twitter to 'off' originally. Eventually, I deleted Twitter entirely (back using 'Blaq' now) and it settled down after an hour or so, and the phone cooled as the PIM usage went back to much more usual level, along with the System.

    Clearly not saying that Twitter may be your issue, but from what I have read on previous posts on this, it does tend to be and app. (maybe an Android one?) that tends to be the culprit.
    AmarC84 likes this.
    04-03-14 09:07 AM
  3. AmarC84's Avatar
    Thanks Stwutter for your response!! But I don't have those many twitter contacts nor do I get any messages from twitter.

    Can anyone else help here to get to the root cause and help me here?

    Posted via CB10
    04-07-14 09:24 AM
  4. blueyestm's Avatar
    PIM services are your email, texts, etc. How often do you have your emails set to check for new mails? How many mail accts do you have? Are they large accounts?
    04-07-14 09:31 AM
  5. Omnitech's Avatar
    I have read multiple threads on this issue but I have not found a concrete solution to deal with this.

    And all you accomplish by creating another thread about the same thing is diluting the amount of attention that can be given to the issue.

    I suggest you find the most active thread on it and post there so more people will see it.

    I would look that up for you but I'm using the CB10 app right now which has lousy search features.
    AmarC84 likes this.
    04-07-14 12:00 PM
  6. moe masoudi's Avatar
    And all you accomplish by creating another thread about the same thing is diluting the amount of attention that can be given to the issue.

    I suggest you find the most active thread on it and post there so more people will see it.

    I would look that up for you but I'm using the CB10 app right now which has lousy search features.

    PIM service battery drain on Q10-ahr0cdovl3pqlmrjexmua3ntb2jpbguuy29tl2xvz28vmjaxmy8xmc8xny8vmtm4mtk5otq2nf8yotq2my5wbmc-.png
    04-07-14 12:18 PM
  7. AmarC84's Avatar
    Hi omnitech,

    Sure, I will participate in the existing threads , the most active ones on this issue. Appreciate your advise.

    Hi blueyestm,

    My 2 mail accounts are push enabled and one of them syncs ones a day and another every 1 hour. How large are these ? If you are referring to the daily mails incoming and outgoing it may not be more than 70-80 or up to 100.

    But I just checked yesterday and I do have now 3000 + contacts associated with my personal account. Can that be an issue ?

    Regs

    Amar
    04-08-14 11:08 PM
  8. Omnitech's Avatar
    But I just checked yesterday and I do have now 3000 + contacts associated with my personal account. Can that be an issue ?
    If you are synchronizing them with external systems, I would imagine the answer would be "yes" - depending on some other variables.
    04-09-14 03:35 PM
  9. nsurace's Avatar
    Oh oh! I have The same problem! I took My Q10 and I've got too a Z30 but Pim services on Q10 are a disaster! I tried to eclude Facebook but The problem there is The same. The problem is only on Q10! Z30 is perfect! I think there is a problem with Gmail on Q10. Help us! The Q is The True BlackBerry but I'll came Back To Z30 if I don't find a solution

    Posted via CB10
    04-19-14 02:57 PM
  10. Omnitech's Avatar
    Oh oh! I have The same problem! I took My Q10 and I've got too a Z30 but Pim services on Q10 are a disaster! I tried to eclude Facebook but The problem there is The same. The problem is only on Q10! Z30 is perfect! I think there is a problem with Gmail on Q10. Help us! The Q is The True BlackBerry but I'll came Back To Z30 if I don't find a solution

    There is nothing unique about the Q10 in that respect. This is a software/configuration issue.

    First question is if you are running exactly the same OS build on both devices. That's one factor.

    Second has to do with what sorts of accounts you have configured on the device, and especially what is syncing externally.

    If you remove all email, social media, file syncing, calendar syncing accounts - the PIM services problem will go away.

    The question is WHICH one is causing the problem. You can experiment by adding them back one-by-one.

    You may have a corrupted calendar event that is causing this, or a corrupted contact, or a huge amount of contacts trying to sync, etc.

    Also: I recommend disabling Contacts/Settings/"Search for contact details".
    04-19-14 06:27 PM
  11. nsurace's Avatar
    I'll try with The calendar. When I had The Z10 I used an andorid app to monitor The task process in background and I remember that The problem was The calendar. But I don't remember more The Name of The app!

    Posted via CB10
    04-20-14 01:28 AM
  12. nsurace's Avatar
    The app is task manager! I tried but there was any Strange task! I continue to don't understand! I've an account Gmail push, Twitter and Facebook. Stop

    Posted via CB10
    04-20-14 01:58 AM
  13. Dmitry Kisselyov's Avatar
    Please check your Evernote acct. Mine failed to sync, but the device kept trying, squandering my daily data limit and battery. I had to delete Evernote account from BlackBerry, and these troubles ceased. I put the accounts back on BlackBerry later, making sure it synced from the beginning.
    04-20-14 02:07 AM
  14. wireless_surfer's Avatar
    I had this issue as well and just resolved it. It turned out one of my email accounts was corrupted and needed to be deleted and added back in. The way I figured out which one was to go into the hub and filter each account and the one that takes the longest to display is likely the one causing the issue. It doesn't necessarily have anything to do with Twitter or Facebook.

    Just my two cents, give it a go and hopefully it helps you out. My battery went from dying in about 4 hours and running at almost 40C to lasting 12 hours and running as low as 23C. I have 7 or 8 accounts on my Q10 so if it helped me, hopefully it helps you.

    Posted via CB10
    04-20-14 02:10 AM
  15. nsurace's Avatar
    Please check your Evernote acct. Mine failed to sync, but the device kept trying, squandering my daily data limit and battery. I had to delete Evernote account from BlackBerry, and these troubles ceased. I put the accounts back on BlackBerry later, making sure it synced from the beginning.
    I already Tried but nothing!

    Posted via CB10
    04-20-14 03:27 AM
  16. Omnitech's Avatar
    The app is task manager! I tried but there was any Strange task! I continue to don't understand! I've an account Gmail push, Twitter and Facebook.
    You may want to try removing the Twitter and Facebook accounts temporarily, especially if you have them syncing contacts.

    Re: the Android task manager - that only pertains to Android apps. And because of the way BB10 sandboxes Android apps from each other, sometimes you run the task manager and it can only "see" itself, no other running processes.

    I haven't yet figured out what determines why it seems to see other processes sometimes when you launch it, but doesn't see anything but itself at other times, even minutes apart.
    04-20-14 06:54 AM
  17. nsurace's Avatar
    Hey Boys I found The problem: it was more simply that I thought! I had The refresh of caldav and cardav Google every 30 minutes. Now I have setted on 24h and The situation is normalized. But I like knowing The rapport beetwen Pim services and system: I've 12% of system and 10 of Pim. I used only Whatsapp and email. Is it normal?

    Posted via CB10
    04-20-14 02:46 PM
  18. Omnitech's Avatar
    Hey Boys I found The problem: it was more simply that I thought! I had The refresh of caldav and cardav Google every 30 minutes. Now I have setted on 24h and The situation is normalized. But I like knowing The rapport beetwen Pim services and system: I've 12% of system and 10 of Pim. I used only Whatsapp and email. Is it normal?

    Because there are so many widely different variables associated with the way a device is configured and used, "normal" is very hard to define.

    I personally am not a big fan of Whatsapp and I feel that could be a contributor to this.

    In general, if you are trying to synchronize a large number of contacts or calendar events between multiple cloud providers it does increase the likelihood you will see this issue.

    Especially if there is any corrupted data in there.
    04-24-14 06:25 AM
  19. nsurace's Avatar
    One week alter and I've the same problem. It's not possible! The Q10 has same problem For me!

    Posted via CB10
    05-05-14 03:33 AM
  20. Omnitech's Avatar
    One week alter and I've the same problem. It's not possible! The Q10 has same problem For me!
    Try removing your email and social media accounts temporarily, then adding them back one-by-one.

    Be careful with the "forever" option for email sync and don't keep massive thousands of emails in synced email folders. Don't try to sync the "All Mail" folder in Gmail, for example.
    05-05-14 09:29 AM
  21. nsurace's Avatar
    Ok I'll try on the new leaked

    Posted via CB10
    05-05-14 02:32 PM
  22. eckl's Avatar
    Any update with the new OS? Any luck with this issue? Thanks.

    Posted via CB10
    05-07-14 06:56 AM
  23. nsurace's Avatar
    Sorry for the news about the new leaked. Two day late it's all right. It seems that all is established! Long baTtery Life and system is faster! Finally
    Omnitech likes this.
    05-08-14 03:00 PM
  24. craftEcowgirl's Avatar
    Do these look normal? I am getting crazy battery drain, when not even doing anything. I even tried deleting and readding my email accounts, but I believe its even worse. They are set to manual sync


    PIM service battery drain on Q10-img_20140511_072142.png
    PIM service battery drain on Q10-img_20140511_072118.png

    Q10, running 10.2.1.2141
    05-11-14 07:23 AM
  25. craftEcowgirl's Avatar
    I am about ready to go back to my Note 2, as I need battery to last a day

    Q10, running 10.2.1.2141
    05-11-14 12:11 PM
37 12

Similar Threads

  1. Replies: 75
    Last Post: 04-06-14, 10:09 AM
  2. Z10 battery life
    By SwissCuban in forum BlackBerry Z10
    Replies: 35
    Last Post: 04-06-14, 07:52 AM
  3. No feedback sound when typing on my Z30
    By Timewarp in forum BlackBerry Z30
    Replies: 3
    Last Post: 04-03-14, 03:17 PM
  4. Battery consumption question...
    By Chad305 in forum BlackBerry Z30
    Replies: 5
    Last Post: 04-03-14, 01:01 PM
  5. BBM Update on my Z10 this morning (with Stickers)
    By deercreekmichael in forum BlackBerry Z10
    Replies: 5
    Last Post: 04-03-14, 09:20 AM
LINK TO POST COPIED TO CLIPBOARD