1. michelle227's Avatar
    New user, both to the forum and to BB of any type. Bought the Q10 through the BB website and switched my number to it yesterday, having used my prior phone for roughly seven years. Service is with ATT and the phone seems to show I am getting LTE service at the moment.

    While I am still in the learning curve about some of what the Q10 does and how it functions, one thing I am certain of is that it is not receiving texts. I am also not sure if the couple I tried to send actually got sent.

    Looking on the web last night, it would seem I am not the first to have this problem but few of the solutions seem to have worked for others. ATT shows additional APN settings on their website but I cannot change the APN settings on this one. All that shows up in the APN field is 'phone' in the light grey lettering.

    I called BB this morning and they could only point me back to ATT, who does not open for a little while more today...

    Is there a simple setting I may be missing that I can go in and fix myself, is it really just an ATT issue or did I get a bad update when the phone brought down .2179 as the latest OS the other night? I would hate to think that a new phone is less functional than the antique I moved from that was running WinMob.

    thnx...
    07-31-14 09:58 AM
  2. anon1727506's Avatar
    New user, both to the forum and to BB of any type. Bought the Q10 through the BB website and switched my number to it yesterday, having used my prior phone for roughly seven years. Service is with ATT and the phone seems to show I am getting LTE service at the moment.

    While I am still in the learning curve about some of what the Q10 does and how it functions, one thing I am certain of is that it is not receiving texts. I am also not sure if the couple I tried to send actually got sent.

    Looking on the web last night, it would seem I am not the first to have this problem but few of the solutions seem to have worked for others. ATT shows additional APN settings on their website but I cannot change the APN settings on this one. All that shows up in the APN field is 'phone' in the light grey lettering.

    I called BB this morning and they could only point me back to ATT, who does not open for a little while more today...

    Is there a simple setting I may be missing that I can go in and fix myself, is it really just an ATT issue or did I get a bad update when the phone brought down .2179 as the latest OS the other night? I would hate to think that a new phone is less functional than the antique I moved from that was running WinMob.

    thnx...
    I have seen some say that they had to get a new SIM Card to get their new BB10 device to work. Someone even said that AT&T has a special LYE plan that you would need......

    I really don't know the answer, put the APN setting of phone is correct.

    Think you really need to visit your local store and ask for help.


    What is a shame is that even with them selling phones direct, BlackBerry refuses to offer any customer support.
    07-31-14 10:33 AM
  3. sk8er_tor's Avatar
    Did you have an iPhone previously? If so, you need to release your phone number from Apple's iMessage servers so that when your iPhone friends send you a message, it doesn't go to iMessage limbo. This is a common flaw with iMessage.

    If you did not have an iPhone previously, then you will need to contact your network provider as this has nothing to do with the phone itself.

    One more thing: if you did not upgrade your BB10 OS, then I suggest you connect to a Wi-Fi and upgrade because I believe the APN settings were fixed previously but you can now edit them.
    07-31-14 10:47 AM
  4. michelle227's Avatar
    Did you have an iPhone previously? If so, you need to release your phone number from Apple's iMessage servers so that when your iPhone friends send you a message, it doesn't go to iMessage limbo. This is a common flaw with iMessage.
    No, never did the iPhone. I had an old HTC flip that I have been using since the fall of '07 and that was running Windows Mobile. It was with ATT (who I have been using for ~15 years when one considers all the companies and name changes in that period).

    One more thing: if you did not upgrade your BB10 OS, then I suggest you connect to a Wi-Fi and upgrade because I believe the APN settings were fixed previously but you can now edit them.
    The OS was updated Tuesday night to .2179 which is what showed to be the most current version. No editing function exists for the APN unless there are APN settings sitting in more than one location...
    07-31-14 11:00 AM
  5. sk8er_tor's Avatar
    No editing function exists for the APN unless there are APN settings sitting in more than one location...
    The location I'm referring to is: from the home screen, swipe down from the top bezel. Select Settings. Then select Network and Connections. Then Mobile Network. Then click on the gear icon on the bottom of the screen to bring up the APN settings. This is for data.

    The other place you can look is in the Hub. Go into the Hub, then click on the three dots on the bottom right and click Settings. Click Text Messages and then click on the Advanced icon on the bottom. Ensure that everything is correct here. Service Center Address should be +13123149810
    Routing preference should be Circuit Switched Preferred.
    Send Text-Only Messages as: SMS
    Retries: 3

    Under this, you should also see the APN Settings which you should hopefully be able to configure.

    Also, see this AT&T website to determine if your SIM card is compatible and don't need a new SIM card: Non-AT&T Device
    07-31-14 11:21 AM
  6. michelle227's Avatar
    Problem is solved...seems ATT has changed the data plan and they didn't bother to say anything when they had installed the SIM yesterday (or during the attempt on Tuesday night). The data plan I previously had for the same price they have for the BB data LTE plan included my texts (the 1500 it allowed for was more than I generally use in a month). The BB plan (and apparently NONE of their data plans anymore) include texting...the better to soak for an extra $20 per month I guess.

    The location I'm referring to is: from the home screen, swipe down from the top bezel. Select Settings. Then select Network and Connections. Then Mobile Network. Then click on the gear icon on the bottom of the screen to bring up the APN settings. This is for data.

    The other place you can look is in the Hub. Go into the Hub, then click on the three dots on the bottom right and click Settings. Click Text Messages and then click on the Advanced icon on the bottom. Ensure that everything is correct here. Service Center Address should be +13123149810
    Routing preference should be Circuit Switched Preferred.
    Send Text-Only Messages as: SMS
    Retries: 3

    Under this, you should also see the APN Settings which you should hopefully be able to configure.
    The first one (swipe down) gets me to a APN screen that just says phone and cannot be changed. The SMS advanced section through the hub gives me nothing as far as APN information.

    Also, see this AT&T website to determine if your SIM card is compatible and don't need a new SIM card: Non-AT&T Device
    I double checked that last night...would have been really pissed if they had put in an incompatible SIM since it was done in an ATT company store. However another employee in that same company store this morning was trying to tell me the problem was that BB was out of business...was NOT the same kid I dealt with yesterday (and who eventually got things sorted out). I just about turned and walked out when they tried to tell me that.
    07-31-14 12:28 PM

Similar Threads

  1. Enterprise IM for Cisco and Contact Pictures
    By FlyFishingAddict in forum Ask a Question
    Replies: 4
    Last Post: 10-10-14, 02:17 PM
  2. Z30 and VZW Update
    By MGO in forum BlackBerry Z30
    Replies: 89
    Last Post: 09-09-14, 09:06 PM
  3. BlackBerry Q10 Users Down Under
    By Nerdal in forum BlackBerry Q10
    Replies: 24
    Last Post: 08-21-14, 08:56 AM
  4. Blackberry Z10 Battery problem
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 07-31-14, 08:21 AM
LINK TO POST COPIED TO CLIPBOARD