1. Emanuele BB's Avatar
    Hi everybody, I'm new to this forum. I have a BB Q10 and after two months the right hand side of the keyboard stopped working. Specifically, the keys "i," "o," "k," "l," "del," "m," and "$" do not respond if hit. I replaced the whole keyboard (with the flex cable) with a new one but the problem persists. What should I do?

    Thanks in advance for any suggestion.
    Last edited by Emanuele BB; 07-23-14 at 04:49 PM.
    07-23-14 10:55 AM
  2. Emanuele BB's Avatar
    Solved.
    07-26-14 12:42 PM
  3. MB64's Avatar
    So what did u do??


    Sent from another device other than my z10 ,using CB Forums
    08-04-14 02:00 PM
  4. Emanuele BB's Avatar
    It was a hardware problem, and I was able to understand it only after 4 or 5 mount-remounts. The plastic cover was asymmetrically pressing the connector of the flex cable (keyboard to motherboard), thus causing a slight rotation and a consequent stepping out of few pins (those corresponding to the keys I listed above). I solved it by placing few stripes of adhesive tape (1mm x 2mm) below (on one side) and above (on the other side) the connector itself.
    Last edited by Emanuele BB; 08-14-14 at 06:47 AM.
    08-12-14 01:35 PM
  5. bbnrs's Avatar
    Good job!
    08-12-14 02:03 PM

Similar Threads

  1. 2 questions please for my Q10
    By Naeg1995 in forum BlackBerry Q10
    Replies: 4
    Last Post: 07-26-14, 03:54 AM
  2. BBM doesnt work
    By imrankhan1994 in forum Ask a Question
    Replies: 1
    Last Post: 07-23-14, 12:54 PM
LINK TO POST COPIED TO CLIPBOARD