1. BriGuy19872015's Avatar
    I have two extra charger bundles for my Q10 and both have stopped receiving charge -- and no light on the unit either. My phone itself will still charge, and the power pack for my Z30 will still charge also. Has anyone seen this and/or do you have any ideas?

    Posted via CB10
    06-01-14 12:04 PM
  2. Branta's Avatar
    Please explain what you mean by extra charger bundle. These sound a little like they could be optional extras or third party gizmos and there are a lot of options out there to pick from. If we know exactly what youre talking about someone might be able to help.
    06-01-14 03:10 PM
  3. BriGuy19872015's Avatar
    One of the official BlackBerry units that is used to charge a battery --- http://www.amazon.com/gp/aw/d/B00BR1...UvbUpU10420261

    Posted via CB10
    06-01-14 05:11 PM
  4. Branta's Avatar
    Ok, extra battery with off-phone charging device, and you have 2 both malfunctioning. There are a few things I would try

    Do the batteries charge and work in your phone? (Test batteries in different connection)

    Are you using the same power supply (ac adaptor) for all charging? Try a different microUSB charger..

    ...etc and see where the faults move around until you find the common factor.
    06-02-14 12:40 PM

Similar Threads

  1. Update 10.2.1.2941 not working on Z10
    By a_roar in forum BlackBerry Z10
    Replies: 16
    Last Post: 06-09-14, 10:50 AM
  2. Will the Z30 work on Sprint Network?
    By texn884 in forum BlackBerry Z30
    Replies: 13
    Last Post: 06-02-14, 01:29 PM
  3. Need help. How can i retrieve my text messages icon?
    By goal320 in forum BlackBerry Z10
    Replies: 4
    Last Post: 06-01-14, 11:48 PM
  4. Replies: 12
    Last Post: 06-01-14, 04:11 PM
  5. Led problem plz help
    By Amitgarg2007 in forum BlackBerry Z10
    Replies: 4
    Last Post: 06-01-14, 10:36 AM
LINK TO POST COPIED TO CLIPBOARD