1. lustekarlis's Avatar
    So, I just realized even though I have a data plan (fixed data amount limit, after which the speed is decreased), I can not get data transfer to work. In other words, when my wireless is diabled, I can not access the internet.

    I have the set the APN settings according to the directions given by my provider. I am currently using the HSPA+/UMTS/GSM network mode. In the connection settings it says - 3g voice only.

    What have I missed? The version of my Q10 is 3.

    I always have full reception, and 3g written next to the reception bars.
    07-08-14 03:48 AM
  2. shorski's Avatar
    Is data services on?
    If so and you still have that problem, you might wanna take it to the provider to work on it.
    Happened to me on my Z10 and I had to take it to them to configure it for me.
    07-08-14 03:58 AM
  3. Ruslan Botsyurko's Avatar
    I'd contact your carrier. 3g means voice only, with data it would be a capital 3G. Also check if you didn't disable data on accident (settings/networks/mobile network/data services) and try a reboot. And before contacting carrier I'd try the SIM in another smartphone to check whether the data will work and find out this way if it's carrier or BlackBerry problem

    Posted via CB10
    07-08-14 03:59 AM
  4. anischab's Avatar
    In the Options, Netwok/Mobile network: enable 4G, 3G and 2G...
    If you enable 4G and 3G only, when you consume/reach your Data amount of your plan, the phone turns into slower internet, so you might enable it, too!


    BlackBerry*Q10, T-Mobile Germany - SQN100-3, Running OS 10.2.1.2941
    07-08-14 04:04 AM
  5. lustekarlis's Avatar
    Anis, could you rephrase the Gs to the acrual acronyms that are in the settings please? I keep confusing which one is 3/4 g and so on.

    I will go see my provider after work. I have tried turning data service on/off, did not help. I could swear though internet worked fine at one point, so it would make sense it has something to do with the data plan limit. After I used up 50 megs of data, I still have internet access but with lower speeds.

    So, which of the connection modes should I try?

    Also, I remember seeing H instead of 3g for sure once.
    07-08-14 04:14 AM
  6. anischab's Avatar
    Anis, could you rephrase the Gs to the acrual acronyms that are in the settings please? I keep confusing which one is 3/4 g and so on.

    I will go see my provider after work. I have tried turning data service on/off, did not help. I could swear though internet worked fine at one point, so it would make sense it has something to do with the data plan limit. After I used up 50 megs of data, I still have internet access but with lower speeds.

    So, which of the connection modes should I try?

    Also, I remember seeing H instead of 3g for sure once.
    When only "g" then no Internet data: so 2g 3g 4g is the indice that the speed/capability is there but in that moment your provider/you turned off data.

    When the data is enabled AND available, you see a capital "G":

    2G=GSM/EDGE
    3G=UMTS/HSPDA
    4G=LTE

    Data plan not working-img_20140708_102807.png

    BlackBerry*Q10, T-Mobile Germany - SQN100-3, Running OS 10.2.1.2941
    07-08-14 04:31 AM
  7. anischab's Avatar
    In the phone settings, I just meant this:

    Data plan not working-img_20140708_103207.png

    Data plan not working-img_20140708_103203.png

    Data plan not working-img_20140708_103155.png

    BlackBerry*Q10, T-Mobile Germany - SQN100-3, Running OS 10.2.1.2941
    07-08-14 04:35 AM
  8. lustekarlis's Avatar
    Well, nothing has helped so far. However, I remembered that it all did work for sure one weekend when I was definitely away from any other means of connecting to the Internet. So, it must be related to the limitations imposed by the data plan. Will visit my carrier after work and post back here.

    Thanks for all the help!
    EDIT: ok, turned of mobile connection and turned it back on. For now at least, it indicates H voice/data (hspa+ umts gsm mode).
    jamesharmeling likes this.
    07-08-14 04:43 AM

Similar Threads

  1. Square Enix Games Work?
    By rajbir01 in forum More for your BlackBerry 10 Phone!
    Replies: 8
    Last Post: 11-07-14, 06:12 AM
  2. Can not update os 10.2.1.2977
    By Sachin Jain2 in forum BlackBerry 10 OS
    Replies: 15
    Last Post: 09-06-14, 12:13 PM
  3. Not getting sound notifications for emails.
    By jt597 in forum BlackBerry Z10
    Replies: 13
    Last Post: 07-09-14, 07:44 PM
  4. Replies: 2
    Last Post: 07-08-14, 09:05 AM
  5. Z10 sync on BB Link over wi-fi is counting against data plan
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 07-08-14, 12:33 AM
LINK TO POST COPIED TO CLIPBOARD