1. 2machi's Avatar
    Hi,everyone
    As topic,i got my new charger bundle for my Q10 yesterday and found that the light turn green,and I charged it from 4:30 pm to 11:30 pm,but when I swap my battery and replaced the new one,it just only 85%,then I charged my original one after 11:30pm til this morning, it's still 83%,can anyone tell me wats going on to my charged bundle?is this normal?

    Posted via CB10
    02-11-15 06:55 PM
  2. Joshu42's Avatar
    You must wait for the light to be plain green, not blinking. Furthermore, don't store your battery in the charger bundle.
    2machi likes this.
    02-11-15 07:08 PM
  3. drbol's Avatar
    I just purchased one too, no problems. Just wait for the light to be a solid green. Are you using a low amp charger or a newer higher amp charger?

    Posted via CB10
    2machi likes this.
    02-11-15 08:01 PM
  4. 2machi's Avatar
    i swap the original one and replace the new one, and it really turned plain green,but i didn't see the blinking green ...
    02-11-15 08:42 PM
  5. 2machi's Avatar
    i use the original official bbQ10 charger...
    02-11-15 08:45 PM
  6. jope28's Avatar
    I've had mine for about a month and swap out daily. Haven't had such issues, but I imagine we might have that issue once batteries get old.

    Frosty White Q10/10.3.1.2267 CB10 [Hopefully NOT Edited by admin to be fair lol. ]
    2machi likes this.
    02-11-15 08:59 PM
  7. letrantrung's Avatar
    Not having this problem, mine is perfectly fine.

    Posted via CB10
    02-11-15 11:49 PM
  8. Diogo Cardoso's Avatar
    I'm having this issue with charger bundle for my Z10, after swapping battery it's not at 100% the battery inserted and I charge it till the green light isn't blinking, and it's new batteries, I'm I doing something wrong?

    Posted via CB10
    02-12-15 06:35 AM
  9. Diogo Cardoso's Avatar
    You must wait for the light to be plain green, not blinking. Furthermore, don't store your battery in the charger bundle.
    I cannot store my battery in the charger bundle till next change?

    Posted via CB10
    02-12-15 06:50 AM
  10. double_fault's Avatar
    The battery will drain if you leave it in the bundle charger. I put an elastic band around the battery and the charger is just to keep them together after the charge is done.

    Posted via CB10
    Diogo Cardoso and jope28 like this.
    02-12-15 06:58 AM
  11. jope28's Avatar
    The battery will drain if you leave it in the bundle charger. I put an elastic band around the battery and the charger is just to keep them together after the charge is done.

    Posted via CB10
    Wow. Had no idea. Thanks for the tip!


    Frosty White Q10/10.3.1.2267 CB10 [Hopefully NOT Edited by admin to be fair lol. ]
    02-12-15 04:09 PM
  12. 2machi's Avatar
    Another question guys
    What is the largest amp charger for my Q10 bundle? Can I use Sony 1.5 mmah output? Will that be dangerous?

    Posted via CB10
    02-12-15 09:16 PM
  13. Joshu42's Avatar
    Dangerous only for the life of your battery
    Your battery must not be hot while charging, it's the rule. So test and check, that's all.
    02-13-15 04:31 AM
  14. 2machi's Avatar
    Thank u so much!

    Posted via CB10
    02-13-15 05:07 AM
  15. hlg8888's Avatar
    I must admit that recently, I have experienced that my blackberry charger no longer is able to charge my batteries fully anymore and can only be charged using a higher ampere charger such as the one i'm using for my tablets.

    Posted via CB10
    02-15-15 06:17 AM
  16. aussie99's Avatar
    The battery will drain if you leave it in the bundle charger. I
    Even if the charger isn't turned on?

    Posted via CB10
    12-30-15 09:33 AM
  17. Joshu42's Avatar
    Even if the charger isn't turned on?
    Yes.
    12-30-15 02:25 PM
  18. barisxpeace's Avatar
    I'm having this issue too. It's been around half of a year since I've bought the bundle and the issue has started to happen. I'm not keeping the battery inside the charger after it's done charging, but everytime the phone starts with 98% every time or sometimes it's 97.

    Posted via Q10
    12-30-15 04:36 PM
  19. Joshu42's Avatar
    I'm not keeping the battery inside the charger after it's done charging, but everytime the phone starts with 98% every time or sometimes it's 97.
    If you switch between 2 batteries, this is normal. They probably don't have the same capacity anymore.
    12-30-15 06:27 PM
  20. aussie99's Avatar
    Yes.
    That's insane!! Never knew that. Wow.

    Why??

    Posted via CB10
    12-30-15 07:39 PM
  21. Warios's Avatar
    I use 6A (6port hub) last 8-9 mnth . and battery never get hot and can't see change in health . Device controls how many Amp's is in use .
    Like @Joshu42 say "battery must not be hot while charging".
    12-31-15 02:41 AM
  22. barisxpeace's Avatar
    If you switch between 2 batteries, this is normal. They probably don't have the same capacity anymore.
    Yeah, it's probably that. At least both of them last me through a day which is nice.

    Posted via Q10
    12-31-15 04:04 AM
  23. coffeeaddict305's Avatar
    I notice after swapping the batteries, then after reboot, the phone becomes hot for a minute or two then it turns normal. Hmmm..

     Blackberryist 
    12-31-15 06:44 AM
  24. Joshu42's Avatar
    I notice after swapping the batteries, then after reboot, the phone becomes hot for a minute or two then it turns normal. Hmmm...
    Check your apps that run with the Run in the Background permission and start on boot. Of course, you can also add to that the Accounts synchronization
    12-31-15 12:32 PM

Similar Threads

  1. Looking for passport and z30 users to test TextNGo
    By textngo in forum App Beta Testers
    Replies: 6
    Last Post: 03-13-15, 05:35 AM
  2. How Can I Change My Crackberry Profile Name?
    By Robertino BB-Z10 in forum Site Feedback & Help
    Replies: 2
    Last Post: 02-12-15, 04:59 AM
  3. How do i export my contacts from my 8900 curve to my media card?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-11-15, 09:25 PM
  4. Docs to go
    By Rob Longmire in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 02-11-15, 07:58 PM
LINK TO POST COPIED TO CLIPBOARD