1. thidisbogus's Avatar
    "To charge your device faster, use the charger that came with your device"--keeps popping up annoyingly. Only one problem.....i AM using the blackberry mfg charger that came with the device.

    What's up with this? Usb cable gone bad? Usb port in phone gone bad?

    Posted via CB10
    10-25-13 11:16 PM
  2. Spinal's Avatar
    could be, i use my old 9700 charger which has a lower output and never got that message, but for actual fast charging i use my playbook charger.
    10-25-13 11:19 PM
  3. kendrick272's Avatar
    That message appears when I use other charger.
    10-25-13 11:56 PM
  4. Naeg1995's Avatar
    I also use a Chinese 2.1 Ampere charger and iPad mini original charger also and never had problems

    Posted via CB10
    10-26-13 06:07 AM
  5. thidisbogus's Avatar
    So you all know, it was my USB port on the phone. I got it exchanged at Verizon.
    01-03-14 06:47 PM
  6. Dave Bourque's Avatar
    I would buy the BlackBerry premium charger. It wastes no time in charging.

    Z10STL100-3/10.2.1.1925
    cgallaer likes this.
    01-03-14 06:52 PM
  7. nappp's Avatar
    I get this when I use the car charger for my legacy BlackBerry. Fortunately nowhere else

    Posted via CB10
    01-03-14 07:52 PM
  8. lushpinkgirl's Avatar
    "To charge your device faster, use the charger that came with your device"--keeps popping up annoyingly. Only one problem.....i AM using the blackberry mfg charger that came with the device.

    What's up with this? Usb cable gone bad? Usb port in phone gone bad?

    Posted via CB10


    I get this all the time, no matter which charger I use. I just ignore it now.
    01-03-14 08:24 PM
  9. thidisbogus's Avatar
    No longer get it since I changed out the phone. Phone usb port had gone bad

    Posted via CB10
    01-05-14 03:51 PM
  10. luis12285's Avatar
    You can also use an iPad wall brick to charge your phone twice as fast..... Works on my iphone, Q10 and my wife's Note3(charges the Note 3 at a normal rate)
    04-15-14 03:41 PM
  11. BBGary's Avatar
    It's a hardware problem. Try to replace the phone with your provider if you can.


    Sent from my iPhone using CB Forums
    04-15-14 05:41 PM
  12. inkjet2's Avatar
    No longer get it since I changed out the phone. Phone usb port had gone bad

    Posted via CB10


    Posted via CB10
    04-15-14 06:15 PM
  13. 9of13's Avatar
    The only time I see that pop up is when I use the charging bundle.

    Post by 9of13's Q
    04-16-14 10:38 AM
  14. BitPusher2600's Avatar
    So you all know, it was my USB port on the phone. I got it exchanged at Verizon.
    I've read every so often of people having that charging issue. I sometimes use my old Bold 9900 oem charger with my Q10 and it works fine despite having a slightly lower output. I wonder if there is a big batch of faulty or soon to fail ports out there. Oh well, at least you're good to go now.
    04-16-14 11:06 PM

Similar Threads

  1. One android device two BBM account
    By usman_hidayat19 in forum General BBM Chat
    Replies: 4
    Last Post: 11-14-13, 06:08 PM
  2. How high/bright do you have your display on your phone?
    By TOfinest in forum BlackBerry Z10
    Replies: 42
    Last Post: 10-28-13, 12:14 AM
  3. USB device not recognized for BB Link.
    By thidisbogus in forum BlackBerry Q10
    Replies: 4
    Last Post: 10-26-13, 10:41 PM
  4. I decided to give BBM a try.....
    By sandman10 in forum General BlackBerry News, Discussion & Rumors
    Replies: 9
    Last Post: 10-26-13, 05:48 PM
  5. camera not working after updating to 10.2 os
    By kakanessa in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 10-25-13, 11:11 PM
LINK TO POST COPIED TO CLIPBOARD