1. mathieualexandre's Avatar
    Hi everyone,

    I am trying to buy Enpass on my Q10 using the Network Provider Billing option to debit my prepaid credit.

    Unfortunately it doesnt work and I get the following error message:

    This purchase could not be completed. Your transaction has not been processed. Please try again later or choose an alternative payment method to continue. (AWREJECTEDc)

    I have called Telstra, my network provider in Australia and they we re not able to fix the issue.

    Would any of you guys be able to help me?


    Cannot Complete Purchase in BlackBerry World (Error AWREJECTEDc) using Telstra Australia-img_20140802_175533.png

    Cannot Complete Purchase in BlackBerry World (Error AWREJECTEDc) using Telstra Australia-img_20140802_175854.png
    08-02-14 03:06 AM
  2. zocster's Avatar
    Can't say I have come across that. Have you tried another payment option as suggested? Maybe paypal?

    Sent from pin:2AD743B7 via Tapatalk Pro
    08-02-14 03:15 AM
  3. mathieualexandre's Avatar
    Hi Zocster.

    Yes I have tried other payment methods and it works well.

    I would just like to consume my prepaid credit as I have heaps of it...
    08-02-14 03:19 AM
  4. Tom Lohdan's Avatar
    Are you talking about your included Call Credit?

    Don't think you can do that, post paid accounts only, were they can debit a card.
    08-02-14 03:51 AM
  5. mathieualexandre's Avatar
    Yes I am talking about my call credit.

    Yes we can do that. I have just bought Enpass on my Windows Phone using exactly this payment method. Telstra has also just confirmed I can do it but they can't help me to fix it for my BlackBerry :-(
    08-02-14 03:54 AM
  6. Ducca683's Avatar
    Hi Matt,

    I just purchased some 0.99 utility app from BlackBerry World with "network provider billing" option... I'm on Telstra, as well, and using Z30, so not an issue with BlackBerry nor Telstra...

    Few suggestions: switch off WIFI while completing the purchase. Try the same prepaid card as you did for WP8 phone purchase...

    Let us know...


    Posted via CB10
    08-02-14 05:45 PM
  7. mathieualexandre's Avatar
    Hi Ducca683,

    So far, I have:
    • Updated BlackBerry Worl to the latest version (the one with the flat icon, PassPort ready haha)
    • Turned off wifi
    • Refreshed BlackBerry World
    • Restarted many times (inc. pulled the battery)

    I have just created a copy paste of my issue (since it has never been logged anywhere on Internet) on the official BlackBerry Support Forums:

    Next step: use the sim card of the Windows Phone to try to complete the transaction.

    I will keep you posted!

    Thanks for your help!
    08-02-14 06:11 PM
  8. mathieualexandre's Avatar
    I have just with the other sim (the one from my Windows Phone) and same issue.

    Looks like the problem comes from my BlackBerry or the App World...
    08-02-14 06:47 PM
  9. Ducca683's Avatar
    Hi Matt, I am on the latest BlackBerry App world version as well...as BlackBerry purchases are verified on the sever side, I don't think it's an issue with your device... I guess it will be something with your BlackBerry world account.
    Let's see what BlackBerry support have to say!

    Other thing you can try (and waste few dollars) is to open another account with the app world and try to log on and complete the purchase. But, I would suggest to wait until you hear from the support team...

    Good luck!

    Posted via CB10
    08-03-14 01:34 AM
  10. rainpas's Avatar
    Did u get solved ur problem, I have exactly the same one, would be good to know how to solve it?
    Thank u in advance,

    Posted via CB10
    Last edited by rainpas; 12-04-14 at 09:53 PM.
    12-04-14 09:31 PM
  11. CMcRob's Avatar
    Same issue here, getting very frustrated. Error message is exactly like the one in your screen shot. Multiple apps, multiple payment methods, different days, etc etc.

    Posted via CB10; Missouri, USA
    12-05-14 11:52 PM
  12. sstavo's Avatar

    I had similar problem on passport couple of days ago...
    This (strange) workaround worked for me:

    1) change phone language (Settings/Language and Input) - in my case from czech to english, for example
    2) realize purchase in BBW (without any issue!)
    3) switching language back

    Don't ask me for a technical explication, but anyway - it worked!
    Hope this helps...
    12-07-14 03:55 AM

Similar Threads

  1. Source for Z30 to use on T-Mo US?
    By p1800nut in forum General Carrier Discussion
    Replies: 15
    Last Post: 09-03-14, 12:03 AM
  2. I'm using STA100-1 (z10)
    By melvin_pradeep in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 08-02-14, 01:31 PM
  3. Cannot swipe to unlock Z30
    By stew_uk in forum BlackBerry Z30
    Replies: 3
    Last Post: 08-02-14, 07:45 AM
  4. Enroll in Razer Nabu Dev Program For BlackBerry 10
    By dikku11 in forum Developers Lounge
    Replies: 2
    Last Post: 08-02-14, 03:05 AM
  5. Replies: 1
    Last Post: 08-02-14, 01:45 AM