1. Steyrws's Avatar
    My browser isn't letting me go to new sites. After the first site I open, it just hangs on that page. I can't view any links and open any other site on new tabs.

    Posted via CB10
    09-03-13 07:33 PM
  2. VeniceBB's Avatar
    Have you tried rebooting your phone? Soft reboot, hard reboot? Tested it on different networks (cellular, wifi)? Do other things that use data work, such as email, twitter, other apps?
    09-03-13 07:36 PM
  3. Emaderton3's Avatar
    Search "frozen browser" in the forums and follow solution 2.

    Posted via CB10
    jamesharmeling and kimbonini like this.
    09-03-13 07:48 PM
  4. Steyrws's Avatar
    Thanks!!! It works. Why is it like this?

    Posted via CB10
    09-04-13 12:10 AM
  5. Emaderton3's Avatar
    I wish I knew. I have to do it every 3 weeks!

    Posted via CB10
    09-04-13 08:26 AM
  6. Emaderton3's Avatar
    Wouldn't you know it. I had to do it right after posting my response above. My suggestion would be to copy and paste the instructions into a Remember Note so you always have them accessible.

    Posted via CB10
    09-04-13 08:42 AM
  7. Steyrws's Avatar
    thanks so much!

    Posted via CB10
    09-04-13 11:03 PM

Similar Threads

  1. Temple run 2 working .bar file download here.
    By Aanchal Sethi in forum More for your BlackBerry 10 Phone!
    Replies: 10
    Last Post: 02-06-14, 12:18 AM
  2. Q10 Remember app and Calender not working!!!
    By jagsfan781 in forum BlackBerry Q10
    Replies: 4
    Last Post: 09-04-13, 10:16 AM
  3. Browser gesture idea
    By g2gcya in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 09-03-13, 09:14 PM
  4. Which Unlocked Q10 works on T-Mobile?
    By ChocPrez in forum BlackBerry Q10
    Replies: 3
    Last Post: 09-03-13, 08:23 PM
  5. Picture app just doesn't work
    By andrekb74 in forum BlackBerry Z10
    Replies: 6
    Last Post: 09-03-13, 06:33 AM
LINK TO POST COPIED TO CLIPBOARD