1. Joshu42's Avatar
    Hello guys !

    I have a BlackBerry premium headset ; yes, the original one found in the Q10 box. These headphones work great with any other phone, the button work on my wife iPhone too.
    When fully plugged into my Q10, the audio is awesome but the button do nothing... No play/stop, no voice control, no answer to a call, nothing.
    I check the jack, connection seems OK. Each little pins are there and ready to make contact with the jack...

    What did I miss ?

    Thank you !
    David.
    07-24-14 04:48 PM
  2. jaydee5799's Avatar
    Hmmm. I have purchased 4 or 5 blackberries and i never got any headphones.
    I have no idea why they don't work. What OS are you using? Maybe that makes a difference?
    07-24-14 05:32 PM
  3. BBRYQ10's Avatar
    While I have gotten headsets from BlackBerry with past devices I did not get one with my Q10.

    Posted via CB10
    07-24-14 05:40 PM
  4. blueyestm's Avatar
    The headset that comes with the phone aren't the premium ones. There are no media features like play/stop. You can do call so and so with voice and answer/end call with button but that's it. My button works on mine. I have 2 of them and a premium set.
    07-24-14 05:43 PM
  5. Joshu42's Avatar
    Thank you for your answer.
    As you noticed, the issue is not with the headphones but with the BlackBerry Q10 (last update). They works great with an iPhone for example. I mean I can answer a call, pause or play music,... they are fine.
    By the way, the headset for the Q10 is referenced as "premium" :
    http://shop.crackberry.com/blackberr...medium=content
    07-24-14 07:09 PM
  6. Joshu42's Avatar
    Ha, and I must add, the microphone doesn't work either. So, when I listen to music and receive a call, I have to take my phone from the holster, answer on it and speak near it. Audio is fine through the headphones though.
    07-24-14 07:13 PM
  7. blueyestm's Avatar
    Don't have another set to test on the phone? That'd be my only guess :/
    07-24-14 07:19 PM
  8. Danow11's Avatar
    I have noticed this also with my z10 and q10. (both if which game with their own headphones, bought from BlackBerry directly???)

    Anyway if the button press is acknowledged by the device it's way late, with perhaps up to a 5 second delay.

    Seems to he software related.

    Posted via CB10
    07-25-14 06:43 AM
  9. Hilton_K's Avatar
    Hmmm I bought a second hand Q10 and it had the premium headphones in it. They work great, hold the button down and it activates the voice commands. Never had to answer phone with it though.

    Q10SQN100-3/10.2.1.2141
    07-25-14 07:25 PM
  10. blackburberry's Avatar
    They work as advertised. Came with my Q10 and work great. Have yours checked out. Or....ensure that they are pushed all the way in. There is some resistance.
    07-25-14 07:36 PM
  11. Joshu42's Avatar
    Thank you guys
    As I said, they are fully plugged in and the audio is crystal clear. Only the button and the microphone doesn't work on my Q10, but all is working perfectly with my wife iPhone.
    I suspect the input socket of my Q10, but I see nothing wrong.
    07-26-14 04:10 AM

Similar Threads

  1. Get Google play patched apps and games directly on BlackBerry
    By officialpitt in forum Android Apps (Amazon Store & APK Files)
    Replies: 13
    Last Post: 07-25-14, 06:02 PM
  2. Blackberry Z30 Wav Files Messing Up Audio Settings!!!
    By thebum23 in forum Ask a Question
    Replies: 2
    Last Post: 07-24-14, 10:36 PM
  3. Call screen on 10.3???
    By aditya8800 in forum BlackBerry Z10
    Replies: 6
    Last Post: 07-24-14, 05:33 PM
  4. Q10 broken screen
    By Joao Oliveira in forum BlackBerry Q10
    Replies: 5
    Last Post: 07-24-14, 04:04 PM
  5. Cannot configure hotmail on Z30 OS 10.2.1.2977
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-24-14, 02:54 PM
LINK TO POST COPIED TO CLIPBOARD