1. skstrials's Avatar
    On my three day old Q10, I never got full bars even though I am living in the center of University of British Columbia.

    Then I went to the settings, and changed the network mode from "LTE&4G/3G&2G" to "4G&3G&2G" and now I have full bars. The thing is, even when the LTE was on, I rarely ever saw the LTE sign at the top right corner, but I just had 2 "BB logo" bars, so my phone was not even using LTE but it just had lower 3G and 4G signals compared to when LTE was off. .

    Now that my LTE is off, I am getting full signals.

    How do you explain this? Why do I have lower 4G and 3G signals when LTE is on? Turning on LTE should not affect 3G and 4G signals. It should just connect to LTE when it is available.
    03-21-14 06:42 PM
  2. FrankIAm's Avatar
    It locked on another tower? Shanenigans?

    BlackBerry 101 - Help Channel
    03-21-14 06:44 PM
  3. skstrials's Avatar
    Hahaha I found the issue.

    The phone DOES connect to LTE when my LTE is on, it is just that my phone is always connected to a Wifi network so the LTE sign was blocked by wireless signal sign.

    Actually about the whole LTE thing, how low should the signal be for the phone to transition from LTE to 3G/4G? I was just in a room with 1 LTE bar and I could not connect to internet, but I am sure I could have connected if my phone used 3G/4G instead.
    03-21-14 06:52 PM

Similar Threads

  1. I cannot download Android apps in my BB Z10
    By Cami02 in forum Android Apps (Amazon Store & APK Files)
    Replies: 26
    Last Post: 03-26-14, 12:54 PM
  2. Facebook on Q10
    By whm in forum BlackBerry Q10
    Replies: 1
    Last Post: 03-22-14, 10:17 AM
  3. Trapster on Q10/Z10
    By ccb056 in forum Android Apps (Amazon Store & APK Files)
    Replies: 3
    Last Post: 03-21-14, 11:29 PM
  4. Replies: 1
    Last Post: 03-21-14, 06:11 PM
LINK TO POST COPIED TO CLIPBOARD