12-12-14 07:29 PM
143 ... 456
tools
  1. Numero12's Avatar
    It's an Android port. I just tried it on my Passport and it worked fine but drained the battery like crazy, just as it did on my Q10.
    I downloaded 3.9 version from Mobogenie to my Z30 and works fine. But as You said, Waze always drains the battery too fast!

    BlackBerry Z30 - OS 10.3.0.1154
    09-29-14 08:05 PM
  2. Ed Gar's Avatar
    Current Waze doesn't work on my Q10. Have to load the older one.
    09-29-14 09:55 PM
  3. isrgish's Avatar
    I loaded the 3.8 version on my Q10. When I try to open it, I get a message that "Waze can't find Network. Please try again later." then it shuts down.

    Is ther something I need to turn on besides Location?

    Anyone use Waze?-img_20140930_045108.png

    Thanks

    Posted via CB10
    09-30-14 03:54 AM
  4. mixsiak's Avatar
    I just instaled update and It works on my Q10 with 10.3.0.1054
    09-30-14 05:09 AM
  5. GPuba's Avatar
    Posted via CB10
    09-30-14 06:06 AM
  6. isrgish's Avatar
    When I have Wifi connection than it works. But this is not feasible when using as a GPS.

    Can someone advise me on what I can do to get it to work?

    Thank You,
    Isr

    Posted via CB10
    09-30-14 06:36 PM
  7. Ed Gar's Avatar
    When I have Wifi connection than it works. But this is not feasible when using as a GPS.

    Can someone advise me on what I can do to get it to work?

    Thank You,
    Isr

    Posted via CB10
    Here it is:

    Anyone use Waze?-300541d1411697563t-no-internet-connection-my-apps-img_20140919_164820.png
    09-30-14 08:50 PM
  8. Numero12's Avatar
    Here's a screenshot of latest Waze version (3.9) working flawless on my Z30

    Anyone use Waze?-mockit_30092014071812.jpg

    BlackBerry Z30 - OS 10.3.0.1154
    ubizmo likes this.
    10-01-14 07:10 AM
  9. isrgish's Avatar
    Here it is:
    Thanks I will try this out.


    Posted via CB10
    10-01-14 10:40 AM
  10. isrgish's Avatar
    Thanks I will try this out.


    Posted via CB10
    Thanks again this worked perfectly.

    When it comes reporting, I can't report problem with map since it's missing the bottom part of the form. But I guess I should be happy that it's working.

    Posted via CB10
    10-01-14 06:47 PM
  11. calicocat2010's Avatar
    So I downloaded Waze with Snap, now when I open it up it remains a Black screen. So I downloaded it from the Amazon Store but when I press the 'open' button after it's installed, I don't see it on my Passport. Never used Amazon Appstore to get an app, so I don't know where to go next.
    12-06-14 10:05 PM
  12. isrgish's Avatar
    So I downloaded Waze with Snap, now when I open it up it remains a Black screen. So I downloaded it from the Amazon Store but when I press the 'open' button after it's installed, I don't see it on my Passport. Never used Amazon Appstore to get an app, so I don't know where to go next.
    For the newest version of Waze to work you need to upgrade your OS to 10.3


    Posted via CB10
    12-10-14 06:32 AM
  13. calicocat2010's Avatar
    For the newest version of Waze to work you need to upgrade your OS to 10.3


    Posted via CB10
    It is 10.3.1

    I got it working after visiting another thread.
    12-10-14 02:16 PM
  14. MorgothPT's Avatar
    Q10 here, downloaded it from Amazon, working fine.

    Posted from Angband using the mighty Hammer of the Underworld, my Q10
    12-10-14 02:23 PM
  15. lynnejohn's Avatar
    Been running Waze for a while on my Z30 (sideloaded via Snap) and loved it. Just upgraded to 10.3.1.1154 and used Amazon to download it. The newer version (read modified by Google) now wants phone numbers and it lost a couple nice features. Is there any way to get an older version, maybe from Snap, or does Snap just go directly to Google Play ?
    12-10-14 10:32 PM
  16. calicocat2010's Avatar
    Been running Waze for a while on my Z30 (sideloaded via Snap) and loved it. Just upgraded to 10.3.1.1154 and used Amazon to download it. The newer version (read modified by Google) now wants phone numbers and it lost a couple nice features. Is there any way to get an older version, maybe from Snap, or does Snap just go directly to Google Play ?
    Yeah search the forums. One of the threads has the older version. I forget where I found it but search the forums
    12-11-14 07:24 AM
  17. mrimperfect's Avatar
    It is 10.3.1

    I got it working after visiting another thread.
    I have the latest from Snap running on my Passport's 10.3.0.x. I have Waze version 3.9.2.0.

    At first it didn't work. Then I signed on to a fast wifi network, deleted the app and did a reinstall. I figure Waze downloads a bunch of data on initialization so that's why the fast wifi network helps. The deleting of the app probably removes the cache.
    12-12-14 04:17 PM
  18. calicocat2010's Avatar
    I have the latest from Snap running on my Passport's 10.3.0.x. I have Waze version 3.9.2.0.

    At first it didn't work. Then I signed on to a fast wifi network, deleted the app and did a reinstall. I figure Waze downloads a bunch of data on initialization so that's why the fast wifi network helps. The deleting of the app probably removes the cache.
    I'm using Waze from Cobalts's google play store with the dependencies Removed.
    12-12-14 07:29 PM
143 ... 456

Similar Threads

  1. Has anyone twitter been acting up?
    By Hockey711 in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 01-19-14, 06:48 PM
  2. Use native or Apk?
    By jdr1000 in forum BlackBerry Z10
    Replies: 9
    Last Post: 01-19-14, 07:29 AM
  3. Replies: 2
    Last Post: 01-18-14, 04:56 AM
  4. CrackBerry Asks: Do you use the BlackBerry 10 browser or a third party app for viewing YouTube?
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 1
    Last Post: 01-18-14, 04:14 AM
  5. Replies: 3
    Last Post: 01-17-14, 06:22 PM
LINK TO POST COPIED TO CLIPBOARD