Built for Business - Learn more about BlackBerry KEY2
  1. junk014's Avatar
    Cannot load video from Blackberry Priv (Facebook ver. 80.0.0.21.65)

    Have done all updates, uninstalled and re-installed FB app twice, and have tried it directly via mobile browser (chrome).
    Video states uploading but remains at 0.0% indefinitely......by indefinitely, I mean five hours and still at 0.0%. Tried with several lengths of video presuming it may be a file size issue, but same result for only a 37sec video. Even did the Android update to marshmallow 6.0 from lollipop, reloaded FB app and tried again. Same problem.

    STRONGLY FEEL THIS ISSUE IS SPECIFIC TO THE MOBILE APP........ becasue if I connect my Priv to my laptop, I can upload the same videos directly out of the phone's file directory without any problems whatsoever and also can play them directly or drag & drop to laptop and play via Windows Media Player.

    Also exhausted Priv's technical assistance.

    Any help would be appreciated. I'm getting to the end of my rope with this new phone. Time to completely abandon BlackBerry, return this device, and shop competitor devices, for the I'm beginning to think.
    xKingHopy likes this.
    06-14-16 10:28 AM
  2. smcv's Avatar
    Are you on wifi or mobile network? It should work either way, but perhaps your carrier is restricting something on the data side?
    Can you upload videos to other sites like youtube, vimeo, instagram? Could be a facebook-specific issue -- a google search for "cannot upload facebook mobile video" produces a lot of hits.
    06-14-16 01:28 PM
  3. junk014's Avatar
    Should work either way, yes. Carrier is Rogers. No data restrictions that I have ever encountered. But no, I’m doing this over wifi connection from home (very strong and quick).
    I haven’t tried anything like vimeo, instagram, etc because I don’t use any of that. I’ll try the google search again but haven’t been able to find any solutions so far.
    06-14-16 04:06 PM
  4. smcv's Avatar
    hmm.. very weird. I'm on Rogers too and don't have this issue. Have you tried an alternate wifi location?
    If you were in Ottawa, I'd say swing by the BlackBerry office
    06-14-16 04:47 PM
  5. junk014's Avatar
    Could it have something to do with an internal encryption or security setting maybe?

    If that's the case, I can't find options for that in settings anywhere. But I've only had the Priv for a few days so it may very well be something I'm not seeing.
    My rationale there is that if it works on your Priv with the same updates/apps, then that theoretically eliminates the FB app from being the issue. Also becasue as I said, if I connect to my laptop, I can upload the same videos to FB directly out of the Priv's file directory without a problem...... couple minutes wait (which is normal) but that's all.

    Haven't tried another wifi location since I have no problems with this with my Z10, and no (lol) not near Ottawa.
    Last edited by junk014; 06-15-16 at 10:02 AM.
    06-15-16 09:32 AM
  6. smcv's Avatar
    shouldn't have anything to do with filesystem encryption. that is transparent to everyone.
    you're not the only person to have problems with the facebook app though.
    the facebook app does some work in the background to transcode video files before uploading them, so that is the area I would suspect they are having difficulty.
    have you tried to access facebook via the web-browser on-device to see if you can upload that way?
    additionally, have you tried shutting down your wifi connection to see if it uploads over mobile?
    06-15-16 01:22 PM
  7. Johnpetter's Avatar
    I have the same problem,and Priv is the first of my phones for the past five years that can,t upload to FB.
    It should just work out of the box!!
    However,my "solution" is to install the Camera MX app and upload video from it.
    https://play.google.com/store/apps/d...agix.camera_mx
    Last edited by Johnpetter; 06-17-16 at 03:36 AM.
    06-17-16 03:24 AM
  8. junk014's Avatar
    Yes, tried through chrome. Wifi and mobile. Tried through FB app. Both wifi and mobile as well. Even with Priv Support assisting on the line actually. Problem remains in all cases it seems.
    The ONLY thing that I've gotten to work (on my own) as I said before, is connecting the device to a PC and using Facebook from there to upload directly from the Priv device files. To me, that means the file itself is fine and the problem is device isolated in some way whether app based or an actual Priv issue.
    But wtf. We need a workaround to upload video to facebook?!?!? Come on. And really though, it's not much of a workaround even, because it renders the "mobile" device entirely "immobile" for this purpose.

    Oh, FYI..... Priv Support has no official record of this issue they said. So to anyone experiencing this problem (even occasionally)..........

    CALL THE PRIV SUPPORT LINE WITH THIS ISSUE SO IT GETS ATTENTION AND A FIX 1-866-533-8067 (complimentary 12 month support on all new Privs, btw)

    I mean really. Difficulty?? With FaceBook video uploads?? Come on BB. On a retailing $899 (cdn) phone that's being touted as such a great device and BlackBerry's last ditch effort to woo back the "prosumer" market?? Spotty difficulties with something like this is completely asssenine and I 100% agree with Johnpetter.......should work right out of the box. And gorgeously at that. Needs a third party camera app to work properly?? Good heavens. But big thanks for that app tip. I'll try it

    At least I'm still within my 15 day device trial period, because if I come across more ridiculous issues like this she's a goin' back ........quickfast. I've been a BB guy almost since day one........7290, Pearl, 8900, Bold, Torch, Z10. That's why I'm giving Priv a solid go. But if I have to deal with dumb wastes of time like this swimming in a sea full of functional competitor devices, might as well try a premium one with better hardware (ie: camera for one). Yes BlackBerry s**t the bed on that one too....... the low-light and zoom images are total garbage.

    I'm actually kind of sad about it. Going to give Priv Support one more roll of the dice right now though. Stay tuned........
    06-17-16 08:37 AM
  9. smcv's Avatar
    It looks like you're not the only person having this problem.. someone with a Galaxy S7:
    Can't upload video to Facebook! - Android Forums at AndroidCentral.com
    So I doubt this is a blackberry-specific problem.
    That said, I'm making sure someone at BlackBerry takes a look at this issue. PM me your contact info.
    06-17-16 09:41 AM
  10. junk014's Avatar
    smvc: sent you my deets as requested. But sort of curious what pull you have with BalkBerry? Not that it makes any difference I guess...... a solved issue is still a solved issue regardless of who or how.

    Anyway, that link is an Android forum yes. Seen it before actually. No helpful replies yet. But it's specifically from a Priv user. I suppose since Priv is actually android, there's bound to be many posts to android specific forums now in search of problem fixes.
    06-17-16 11:04 AM
  11. smcv's Avatar
    smvc: sent you my deets as requested. But sort of curious what pull you have with BalkBerry? Not that it makes any difference I guess...... a solved issue is still a solved issue regardless of who or how..
    I'm the camera architect at BlackBerry so I am going to have our internal test lead take a look at reproducing your problem. While not necessarily our domain, we have sometimes had to dig into why some 3rd party apps are misbehaving.
    tonycara57 and bluesqueen23 like this.
    06-17-16 12:25 PM
  12. conite's Avatar
    I'm the camera architect at BlackBerry so I am going to have our internal test lead take a look at reproducing your problem. While not necessarily our domain, we have sometimes had to dig into why some 3rd party apps are misbehaving.
    You at the old QNX building in Kanata? I didn't know Android app development was happening here. Cool.
    06-17-16 12:42 PM
  13. Sigewif's Avatar
    I have not loaded the Facebook app on my Priv and instead just have accessed it via Chrome. Maybe I am missing something but I do not even find an option to upload videos accessing it from Chrome. I tried to upload a video where it shows you can upload photos. I clicked on a video instead of a photo, and I got an error message when I tried. I Mind you, I have not tried the other options and I do not use it very much on my phone--mostly on my PC. I could see if it works in Firefox.
    Update: I have tried it now with Firefox. I did not find the option for video upload by accessing FB via the Firefox app either.
    I am wondering if this is due to limitations of the Firefox app and Crome app and not the the Priv specifically. It seems that the options are limited for uploading Facebook when using Firefox or Chrome. I do not do uploads on my phone to Facebook often enough to check it out or know whether it is missing from the menu or if I just have not located it.
    Last edited by Sigewif; 06-19-16 at 11:48 AM. Reason: Added information about accessing Facebook via Firefox, on my Priv.
    06-18-16 02:24 PM
  14. smcv's Avatar
    You at the old QNX building in Kanata? I didn't know Android app development was happening here. Cool.
    We moved over to Innovation Drive a year or two ago.
    06-20-16 10:19 PM
  15. hndt38's Avatar
    Do a factory reset.
    When my PRIV get update, the Facebook app could not upload my video.

    Posted via the CrackBerry App for Android
    06-21-16 02:59 AM
  16. Johnpetter's Avatar
    What i find a bit strange is that it seems to happend to just a few phones. Not many users reporting upload errors.
    I tried a video on youtube and it uploads without any problems...
    I just don,t get why it dos not work on facebook
    I guess we all have the same FB app?
    Last edited by Johnpetter; 06-21-16 at 07:09 PM.
    06-21-16 06:58 PM
  17. jmo67's Avatar
    Sigewif,
    I believe your issue is that when you access Facebook on a mobile device via a browser, Facebook redirects to the mobile version of the site.
    The mobile version did not have an option to upload videos. You can use the desktop version on your mobile device.

    But with that said I just tried ( June27th) and the mobile site ( https://m.facebook.com) now appears to have an option to add Photos/Videos.
    But I also tried a second account and the Mobile site only shows me an option to add Photos and does not display Videos from the Galllery when selected.
    Must be variations in the mobile version of the site depending on the Facebook server you hit.

    You can tell the browser to use the desktop version if you want. It will give you the same experience as when you use Facebook on your PC.
    Start your Chrome browser, select the Overflow menu ( 3 vertical dots) and select the menu item Request desktop site.
    Now when you enter www.facebook.com you will not be redirected to the mobile site and instead get the desktop version you see on your PC.

    You can also enter www.facebook.com, you will redirected to m.facebook.com, select the overflow menu and set Request desktop version, the page refreshes to www.facebook.com and you can login like you do from your PC.
    06-27-16 11:07 AM
  18. Johnpetter's Avatar
    I re-installed the os with Autoloader yesterday. Same thing. It won't upload. So i just have to use the Camera MX app..

    Posted via the CrackBerry App for Android
    06-28-16 03:39 AM
  19. dbindley's Avatar
    I'm the camera architect at BlackBerry so I am going to have our internal test lead take a look at reproducing your problem. While not necessarily our domain, we have sometimes had to dig into why some 3rd party apps are misbehaving.
    The problem is the same as I'm having, but the issue of uploading is when wifi is turned on. Turning wifi off allows pictures to be uploaded and downloaded. This is just not a Facebook issue, but an issue with mms and other apps.
    11-27-16 09:00 AM
  20. Steve Weiterman's Avatar
    I'm have same issue. (Facebook only)_

    I have tried every way I can think of to upload a video to Facebook. No matter what I do, it just sits at 0% .

    It's been over a year. What is the issue??
    11-30-16 12:15 AM
  21. Wikichick's Avatar
    I can't get into facebook at all today on the priv. Works fine on the pc and on my android tablet if I go to the desktop version. The mobile site won't work on the priv or the tab though. Hopefully they will get it fixed.
    11-30-16 09:32 AM

Similar Threads

  1. cannot send videos......"file too large"
    By gphin305 in forum BlackBerry Z10
    Replies: 6
    Last Post: 06-14-16, 04:07 PM
  2. Replies: 2
    Last Post: 06-14-16, 01:38 PM
  3. Any new updates on how to send videos from a BB Z10?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 3
    Last Post: 06-14-16, 10:12 AM
  4. T-Mobile adds PBS, YouTube Gaming and more to its Binge On service
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 06-14-16, 09:22 AM
  5. Facebook is shutting down my browser
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 06-14-16, 08:40 AM
LINK TO POST COPIED TO CLIPBOARD