05-16-16 03:51 PM
28 12
tools
  1. FF22's Avatar
    I am at a resort. You have to log in periodically to revitalize the WiFi. I have Verizon and see a signal. I was trying to send an outgoing Gmail from the hub. It was locked with the clock icon. Did not send for ten minutes. Ah, I opened browser and resort log on. Email then finally sent. But also got a series of "stalled" emails that had not been received during the WiFi closure.

    Why won't the Priv use my cell signal. Why was it blocked from sending and receiving due to the WiFi "closure " when Verizon was on or there?

    I now realize this happened the other day, too.

    Seems odd or wrong to rely on WiFi when carrier is present.

    Posted via the CrackBerry App for Android
    05-12-16 08:35 AM
  2. Brulging_Jersey's Avatar
    This is an Android thing. It does not check for actual internet access when choosing to use Wi-Fi. It only checks for Wi-Fi signal. This is unlike BB10, and is stupid. This is not the Priv's fault.
    05-12-16 09:03 AM
  3. FF22's Avatar
    This is an Android thing. It does not check for actual internet access when choosing to use Wi-Fi. It only checks for Wi-Fi signal. This is unlike BB10, and is stupid. This is not the Priv's fault.
    GREAT. WONDERFUL.

    Downright STUPID.

    So, either continuously check that WiFi is on or disable it? Actually, it was on - it shows connected but does not work until re-energized by visiting the resort website. You don't even have to log in, just get forwarded to their page, then move on.

    But thanks for the answer. Guess I will have to check when I return after being out.

    Posted via the CrackBerry App for Android
    kbz1960 likes this.
    05-12-16 09:13 AM
  4. onlybuggin's Avatar
    May have something to do as well with the guests setting on the resort WiFi service itself. At home, my phone stays connected and reconnects as soon as soon as I return home. However my work's guest wifi requires me to log in everyday to access it. I'd guess this is an effort to reduce the inactive users to improve performance for active users.

    Posted via CB10
    05-12-16 09:38 AM
  5. FF22's Avatar
    May have something to do as well with the guests setting on the resort WiFi service itself. At home, my phone stays connected and reconnects as soon as soon as I return home. However my work's guest wifi requires me to log in everyday to access it. I'd guess this is an effort to reduce the inactive users to improve performance for active users.

    Posted via CB10
    That's okay. The resort should be in control of their WiFi. But the phone should then fallback to cellular and not fail to retrieve or send email because I don't "reconfirm" with the resort. I should not have to take any action to do my stuff. Cell should just be there automatically.

    Posted via the CrackBerry App for Android
    zephyr613 and kbz1960 like this.
    05-12-16 09:54 AM
  6. FF22's Avatar
    This is an Android thing. It does not check for actual internet access when choosing to use Wi-Fi. It only checks for Wi-Fi signal. This is unlike BB10, and is stupid. This is not the Priv's fault.
    Now that I'm home from vacation....

    So, there's no way around this glitch? This happened over and over for almost a week. It was not just email but trying to use the CB app or any internet dependent app. I'd have to open the browser (Firefox) and try visiting any site, then the resort's homepage popped up - I did not even have to log on, it just went to a resort screen, then I could browse and email would pour in.

    (and this is also a bump - hoping one of the BB folks reads/replies (c_bryant34 do you search for your ID? (g))
    05-15-16 11:50 AM
  7. CarvinSigX's Avatar
    Sounds exactly like accessing Internet at my college.

    Posted via the CrackBerry App for Android
    05-15-16 12:37 PM
  8. Brulging_Jersey's Avatar
    Now that I'm home from vacation....

    So, there's no way around this glitch? This happened over and over for almost a week. It was not just email but trying to use the CB app or any internet dependent app. I'd have to open the browser (Firefox) and try visiting any site, then the resort's homepage popped up - I did not even have to log on, it just went to a resort screen, then I could browse and email would pour in.

    (and this is also a bump - hoping one of the BB folks reads/replies (c_bryant34 do you search for your ID? (g))
    c_bryant can't help. This is an Android problem. I agree it's stupid. I simply don't use Wi-Fi, but I can see how annoying this would be.
    05-15-16 12:42 PM
  9. kbz1960's Avatar
    Why in the world. I know my dumb android can't use data while on the phone but still works fine whether or not I'm using WiFi.

    Maybe you have it set to only use WiFi when roaming F2?
    05-15-16 12:47 PM
  10. anon(9208252)'s Avatar
    Why in the world. I know my dumb android can't use data while on the phone but still works fine whether or not I'm using WiFi.

    Maybe you have it set to only use WiFi when roaming F2?
    Ya was just thinking the same

    from my Priv
    kbz1960 likes this.
    05-15-16 12:55 PM
  11. FF22's Avatar
    Why in the world. I know my dumb android can't use data while on the phone but still works fine whether or not I'm using WiFi.

    Maybe you have it set to only use WiFi when roaming F2?
    I'm game - where do I find that setting in the millions of Settings Locations?

    It is not under Wifi?

    Well, I was in the good ol' USofA. Anyway, I think Arizona is in the US although some might question that.

    Oh, the ROAMING setting. I do have that setting but just in case I forget when I got to Canada or Europe. But I have UNlimited and don't care in the US.

    And, of course, even if it is that setting, I'm now home so can't test.
    05-15-16 02:08 PM
  12. kbz1960's Avatar
    So it works at home if not on WiFi but not at the resort? Odd
    05-15-16 02:27 PM
  13. DenverRalphy's Avatar
    In Android, there is an option to turn on/toggle Smart Network Switch. It's intentional by design.

    If you toggle it on, and you lose internet because your WiFi connection blocks internet connection for whatever reason, then the device will look for a mobile data connection to the Internet.

    It's an opt in feature. Because it's better to know that you're not blindly incurring data charges. Smart Network Switch is usually found in your advanced WiFi settings on Android devices.
    05-15-16 02:52 PM
  14. DenverRalphy's Avatar
    This is an Android thing. It does not check for actual internet access when choosing to use Wi-Fi. It only checks for Wi-Fi signal. This is unlike BB10, and is stupid. This is not the Priv's fault.
    It's not an Android thing (more accurately it's not a fault). See my previous reply about the Smart Network Switch setting. Prior to lollipop (it may have been earlier but Android L is when I noticed it) it was automatic.

    It's better not to incur data charges when you don't wish to. Which is why Smart Network Switch should be an opt in feature. If you're at a resort that limits their session IDs/connections, not knowing when you switched from wifi to mobile data can be disastrous to your bill. Especially if you don't realize that you just uploaded a few gigs of video to a social network at the expense of your data plan or roaming instead of via WiFi.
    Last edited by DenverRalphy; 05-15-16 at 03:28 PM.
    05-15-16 02:58 PM
  15. Brulging_Jersey's Avatar
    It's not an Android thing (more accurately it's not a fault). See my previous reply about the Smart Network Switch setting. Prior to lollipop (it may have been earlier but Android L is when I noticed it) it was automatic.

    It's better not to incur data charges when you don't wish to. Which is why Smart Network Switch should be an opt in feature. If you're at a resort that limits their session IDs/connections, not knowing when you switched from wifi to mobile data can be disastrous to your bill. Especially if you don't realize that you just uploaded a few gigs of video to a social network at the expense of your data plan or roaming instead of via WiFi.
    OK, and I agree with you.
    05-15-16 03:33 PM
  16. FF22's Avatar
    In Android, there is an option to turn on/toggle Smart Network Switch. It's intentional by design.

    If you toggle it on, and you lose internet because your WiFi connection blocks internet connection for whatever reason, then the device will look for a mobile data connection to the Internet.

    It's an opt in feature. Because it's better to know that you're not blindly incurring data charges. Smart Network Switch is usually found in your advanced WiFi settings on Android devices.
    I don't see an option. Here's my screen capture. Below that are ip and mac addresses, no more options. Unless it is the second option and I don't know what Google will do with this - ALL OF THE TIME? Oh, and wifi was NOT technically OFF. It was just that the resort, I gather reconfirms by showing its home page (but no more log in requirements).

    when wifi is "closed" email not retrieved or sent-screenshot_2016-05-15-13-39-43.jpg
    05-15-16 03:45 PM
  17. kbz1960's Avatar
    Mine is under more



    05-15-16 03:54 PM
  18. FF22's Avatar
    No such option:
    when wifi is "closed" email not retrieved or sent-screenshot_2016-05-15-15-00-56.jpg
    05-15-16 05:03 PM
  19. kbz1960's Avatar
    Damn Jackd's Priv
    05-15-16 05:39 PM
  20. jamesharmeling's Avatar
    My Priv settings are like F2's and I experience the same data issue. Is the difference in the carrier Priv version or the software. I'm currently on ATT and still on 5.1.1.

    My name is Jimmy and I am a BlackBerryaholic.
    05-16-16 05:58 AM
  21. Uzi's Avatar
    Hi F2 maybe this one can help? It's in developer option
    Attached Thumbnails when wifi is "closed" email not retrieved or sent-1463397143927.jpg  
    05-16-16 06:12 AM
  22. DenverRalphy's Avatar
    Hrmmm... odd that the Smart Network Switch option isn't there. It shouldn't be a carrier OEM thing, because I've seen it on Nexus devices as well as other OEMs.

    Unless BB disabled/removed the feature for some reason.

    [edit] I just sent out a few requests from other Android users to see which different devices have the feature, to determine whether it's standard or not. As I mentioned, I am relatively confident I've seen it on Nexus and other devices.
    Last edited by DenverRalphy; 05-16-16 at 08:55 AM.
    jamesharmeling likes this.
    05-16-16 08:44 AM
  23. FF22's Avatar
    My Priv settings are like F2's and I experience the same data issue. Is the difference in the carrier Priv version or the software. I'm currently on ATT and still on 5.1.1.

    My name is Jimmy and I am a BlackBerryaholic.
    And I'm on Verizon.
    05-16-16 09:21 AM
  24. FF22's Avatar
    Hi F2 maybe this one can help? It's in developer option
    The "problem" now is that I'm home and can't test it.

    It really was irritating. Obviously, after a few "re-taps" in whatever app, I would realize "aha, wifi needs re-verification" and go to the Browser where the Resort Ad page showed up. Again, no LOG-ON needed, just the visit.

    But since I had full cell signal, it is stupid that it does not automatically use cell. And i don't see any option limiting data versus wifi. Now, again, when really Roaming I will not want data to kick in without Permission. Like when I occasionally visit Canada just a border north or in June when in Portugal, Azores and Madeira. I don't want to sell the house to pay Verizon!!!

    And being Verizon, still on Lollipop if that makes any difference in available options.
    Uzi and jamesharmeling like this.
    05-16-16 09:27 AM
  25. Sigewif's Avatar
    We had this problem in Nevada a few months ago and thought it was the hotel. It wasn't just the cell phones, as I remember. We also had a Windows tablet and an Ipad with us. It was very inconvenient because we were trying to check our flight status since it had snowed during the night. The hotel was right by the airport so they had flight info at the desk but our room was at the other end of the hotel from the front desk.
    FF22 likes this.
    05-16-16 11:28 AM
28 12

Similar Threads

  1. My Classic is not reading the SIM card!
    By mrad64 in forum BlackBerry Classic
    Replies: 7
    Last Post: 05-14-16, 06:54 AM
  2. Replies: 2
    Last Post: 05-12-16, 08:07 AM
  3. After I unlock my BlackBerry Passport the screen is zoomed in. How can I unzoom?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 2
    Last Post: 05-12-16, 08:05 AM
  4. Replies: 1
    Last Post: 05-12-16, 07:25 AM
  5. Replies: 0
    Last Post: 05-12-16, 05:01 AM
LINK TO POST COPIED TO CLIPBOARD