11-25-16 10:08 PM
26 12
tools
  1. grumpyaeroguy's Avatar
    So I am finally finding time to dive into the Priv a little deeper and learn where all the settings are, when I ran across the WiFi calling menu.

    Hadn't given it much thought since I had the phone, took for granted that it as working. My setting was "Cell Network Preferred". Had a strong WiFi signal here at home, so decided to try to make a call over WiFi and switched to "WiFi Only".... and....

    am greeted with the all to familiar (from my Z10 10.2+ days) REG99 ---Unable to connect error. Upon trying to make a (WiFi) call, Priv says to exit out of Airplane mode.

    In the not so distant past, my Z10 WiFi calling DID work on the same network when I had a TMo official OS10 release. Pretty sure it's not my network.

    Went into play store to see if there was a TMo WiFi calling app, and, if it's there, I can't find it. If this is tied to the My TMo app, that thing is disabled for well known reasons.

    This is not a huge deal, but, I DO find myself in situations where there is no cell signal, but good WiFi coverage. Bummed that this isn't working.

    Any wisdom out there?
    02-16-16 06:52 AM
  2. mousii's Avatar
    Isn't wi-fi calling controlled by the carier and they need to have it enabled... maybe even something specific for your plan?

    I would call them to see what they say.

    Powered by BB10
    02-16-16 07:13 AM
  3. grumpyaeroguy's Avatar
    I believe that is correct.... hence my comment that it worked on official TMO releases of OS10.

    I'll call them today to see what's up....Thought it may be an oversight on my end downstream of TMo.
    02-16-16 07:45 AM
  4. jonesy39's Avatar
    I'm curious to see what you find. My wifi calling connects, but I often pick up my phone and am greeted by that error for 30 seconds and I assume I wouldn't be receiving calls properly. And before someone asks,my wifi is set to not disconnect when the phone is sleeping.

    Posted via the CrackBerry App for Android
    02-16-16 07:48 AM
  5. jm1219's Avatar
    It happens occasionally to me but not all that often. Did you try turning WiFi on and off after setting it to WiFi preferred?
    02-16-16 08:45 AM
  6. grumpyaeroguy's Avatar
    It happens occasionally to me but not all that often. Did you try turning WiFi on and off after setting it to WiFi preferred?
    yes---with no change in behavior.

    I have called TMo, and they are sending some updates to my phone, after which we'll see if that makes any difference. At this point they are following their "scripts/protocols" to address it. It is certainly acceptable to try this first.

    If it doesn't work, then I can call back and invoke the "stop playing" rule and get some serious tech support.

    THo not a huge deal, there are times when I rely on the wifi calling. Let's see how this shakes out...
    jm1219 likes this.
    02-16-16 08:51 AM
  7. grumpyaeroguy's Avatar
    OK, so TMo pushed something to my phone, I rebooted as I was asked to do, and, WiFi calling worked for me on a WiFi network here at work.

    I will try later on my home network.

    Let's see if it sticks.
    02-16-16 03:02 PM
  8. Sigewif's Avatar
    @grumpyaeroguy: Are you using a T-Mobile issued Priv or an unlocked one (for example from Amazon or ShopBB)? I have an unlocked one from ShopBB and am with T-Mobile. I am asking because I wonder if the update you got is something that is available only for people who got their phone from T-Mobile or if it is anyone who has them as a carrier. I have kept my setting on "cellular network preferred" and everything works fine. When I had it on Wi-Fi preferred when I first got the phone, I would get errors and dropped calls like what is described here. It was explained to me at T-Mobile that the Wi-Fi and the cellular service "compete" when you call or receive a call, and that can cause these errors. At T-Mobile they advised me keep it on the "cellular network preferred" except when I am where there is no signal. (For example, out of the country etc.) I have not had my Priv in a place that would require that yet.
    02-16-16 05:28 PM
  9. mousii's Avatar
    OK, so TMo pushed something to my phone, I rebooted as I was asked to do, and, WiFi calling worked for me on a WiFi network here at work.

    I will try later on my home network.

    Let's see if it sticks.
    Good for you, thank you for giving us an update

    Powered by BB10
    02-16-16 06:18 PM
  10. grumpyaeroguy's Avatar
    @grumpyaeroguy: Are you using a T-Mobile issued Priv or an unlocked one (for example from Amazon or ShopBB)?
    TMo supplied Priv

    I wonder if the update you got is something that is available only for people who got their phone from T-Mobile or if it is anyone who has them as a carrier.
    I'm not completely sure. WHen they follow up, I'll ask, maybe they'll spill.....


    I have kept my setting on "cellular network preferred" and everything works fine. When I had it on Wi-Fi preferred when I first got the phone, I would get errors and dropped calls like what is described here. It was explained to me at T-Mobile that the Wi-Fi and the cellular service "compete" when you call or receive a call, and that can cause these errors. At T-Mobile they advised me keep it on the "cellular network preferred" except when I am where there is no signal. (For example, out of the country etc.) I have not had my Priv in a place that would require that yet.
    I actually forced mine to WiFi Only, and, it did connect. I did notice that it is a little fussy, but it DOES work, whereas before now I was receiving the TMo-common REG99 error.

    It is working now tho.
    02-16-16 07:16 PM
  11. grumpyaeroguy's Avatar
    Good for you, thank you for giving us an update

    Powered by BB10
    no problem. Maybe this will help some folks out.
    02-16-16 07:16 PM
  12. TheChosenDoge's Avatar
    I usually only get REG99 on my TMO when I'm switching WiFi networks or there is none available and then works all fine and it also helps to have good signal for it to work well

    Posted via the CrackBerry App for Android
    02-17-16 01:02 AM
  13. Charkatak's Avatar
    I have contacted T-Mobile over 2 weeks ago about this issue and also wrote in couple of forums(T-Mobile's and Blackberry's). I have a factory unlocked PRIV so did other users and also some of them had T-Mobile Variant PRIV and all have the following issue:

    1) When screen is on and WiFi calling is enabled, then user is able to make/receive calls via WiFi calling.
    2) When device goes to sleep and after about 10+ minutes, upon waking up, WiFi calling icon shows an X and then in about 30+ seconds should reconnect again.

    Here are the steps to reproduce it(another option can also be selected in WiFi calling menu, but this is better)
    1) Turn on WiFi calling in settings, and select "Never use cellular networks" - it will disable cell network and only use WiFi.
    2) Make a call or two to make sure it works
    3) Press power or leave the phone alone for 10+ minutes(has to go into sleep/standby) - if you don't wait long enough it may not repro.
    4) Call your phone and see if it will ring or go straight to voice mail.

    Couple of days ago I have noticed that if my device is connected to the charger, WiFi calling works fine even if device goes to sleep.

    It seems that there is a bug in the OS or WiFi sleep policy and T-Mobile and Blackberry aware of the issue and should issue an update.
    Last edited by Gogas Kumir; 02-17-16 at 01:29 AM.
    02-17-16 01:16 AM
  14. jonesy39's Avatar
    I have contacted T-Mobile over 2 weeks ago about this issue and also wrote in couple of forums(T-Mobile's and Blackberry's). I have a factory unlocked PRIV so did other users and also some of them had T-Mobile Variant PRIV and all have the following issue:

    1) When screen is on and WiFi calling is enabled, then user is able to make/receive calls via WiFi calling.
    2) When device goes to sleep and after about 10+ minutes, upon waking up, WiFi calling icon shows an X and then in about 30+ seconds should reconnect again.

    Here are the steps to reproduce it(another option can also be selected in WiFi calling menu, but this is better)
    1) Turn on WiFi calling in settings, and select "Never use cellular networks" - it will disable cell network and only use WiFi.
    2) Make a call or two to make sure it works
    3) Press power or leave the phone alone for 10+ minutes(has to go into sleep/standby) - if you don't wait long enough it may not repro.
    4) Call your phone and see if it will ring or go straight to voice mail.

    Couple of days ago I have noticed that if my device is connected to the charger, WiFi calling works fine even if device goes to sleep.

    It seems that there is a bug in the OS or WiFi sleep policy and T-Mobile and Blackberry aware of the issue and should issue an update.
    This is exactly my issue and I appreciate that you have logged it with tmobile and blackberry!

    Posted via the CrackBerry App for Android
    02-17-16 09:23 AM
  15. CivilDissident's Avatar
    Have my T-Mo Priv on the way. Soon as it's delivered I'll see what kind of luck I have with the ol' WFC. Fingers crossed! (Although, at this point I'm rather used to the unnecessary drama...)

    Posted via CB10
    02-17-16 09:56 AM
  16. grumpyaeroguy's Avatar
    I have contacted T-Mobile over 2 weeks ago about this issue and also wrote in couple of forums(T-Mobile's and Blackberry's). I have a factory unlocked PRIV so did other users and also some of them had T-Mobile Variant PRIV and all have the following issue:

    1) When screen is on and WiFi calling is enabled, then user is able to make/receive calls via WiFi calling.
    2) When device goes to sleep and after about 10+ minutes, upon waking up, WiFi calling icon shows an X and then in about 30+ seconds should reconnect again.

    Here are the steps to reproduce it(another option can also be selected in WiFi calling menu, but this is better)
    1) Turn on WiFi calling in settings, and select "Never use cellular networks" - it will disable cell network and only use WiFi.
    2) Make a call or two to make sure it works
    3) Press power or leave the phone alone for 10+ minutes(has to go into sleep/standby) - if you don't wait long enough it may not repro.
    4) Call your phone and see if it will ring or go straight to voice mail.

    Couple of days ago I have noticed that if my device is connected to the charger, WiFi calling works fine even if device goes to sleep.

    It seems that there is a bug in the OS or WiFi sleep policy and T-Mobile and Blackberry aware of the issue and should issue an update.
    The TMo rep followed up with me today ref my wifi calling issue. I told him that whatever they had pushed appeared to work, and WiFi calling appears to be working for me just fine now.

    I took the opportunity to ask him if he was aware of whether, or not, WiFi calling would work on their network with an UNLOCKED Priv. His response (please recognize that I am only the messenger here):

    "We only GUARANTEE that WiFi calling will work on a TMo branded Priv. We will certainly try and do our best to get an unlocked phone working with WiFi calling on our network, but won't, necessarily, guarantee that we can get it working. There are minute differences between frequencies and other technical and software details that we provide in our branded phones that may cause an unlocked phone from the factory or another carrier to not allow WiFi calling to work reliably".

    Does this even make sense, or is it even really the actual truth? I have no way of knowing. But, this is what I was told.

    But, it IS working well for me now. Just thought I would share.
    02-17-16 10:31 AM
  17. Charkatak's Avatar
    The TMo rep followed up with me today ref my wifi calling issue. I told him that whatever they had pushed appeared to work, and WiFi calling appears to be working for me just fine now.

    I took the opportunity to ask him if he was aware of whether, or not, WiFi calling would work on their network with an UNLOCKED Priv. His response (please recognize that I am only the messenger here):

    "We only GUARANTEE that WiFi calling will work on a TMo branded Priv. We will certainly try and do our best to get an unlocked phone working with WiFi calling on our network, but won't, necessarily, guarantee that we can get it working. There are minute differences between frequencies and other technical and software details that we provide in our branded phones that may cause an unlocked phone from the factory or another carrier to not allow WiFi calling to work reliably".

    Does this even make sense, or is it even really the actual truth? I have no way of knowing. But, this is what I was told.

    But, it IS working well for me now. Just thought I would share.
    I think it depends who you talk to. Different tech support people have different answers When I called multiple times I was never told if my phone is unlocked it may or may not work well with T-Mobile. The model # is the same, bands are the same including band 12, so there is not reason for WiFi calling to be any different. I have an unlocked Nexus 5x and WiFi calling has no issues. WiFi calling works well on the PRIV, but when phone goes to sleep it may not always work. The solution now is to keep phone plugged in for WiFi calling to work.

    I would like to add: One other user of Unlocked PRIV who bought the phone on Amazon, returned it and got T-Mobile variant of PRIV when it came out and still WiFi calling issue existed. Go figure...
    02-17-16 12:34 PM
  18. CivilDissident's Avatar
    Just unboxed my T-Mobile issued BlackBerry Priv and zero WFC issues with the device... went through its update, rebooted and went on to connect to WFC like it was destined to...

    Posted via the CrackBerry App for Android
    Attached Thumbnails TMo Priv WiFi Calling, deja vu...-1036.jpg  
    02-17-16 01:49 PM
  19. Charkatak's Avatar
    Just unboxed my T-Mobile issued BlackBerry Priv and zero WFC issues with the device... went through its update, rebooted and went on to connect to WFC like it was destined to...

    Posted via the CrackBerry App for Android
    When you can, just monitor WiFi calling when you wake up the phone and see if there is an X on the icon. Also you can do the steps I have outlined in previous post.
    02-17-16 02:11 PM
  20. CivilDissident's Avatar
    When you can, just monitor WiFi calling when you wake up the phone and see if there is an X on the icon. Also you can do the steps I have outlined in previous post.
    Will do... I discover with all my devices it isn't uncommon to awake and see a red phone or SOS or X. It happens from time to time with all my WFC devices, from my BlackBerrys to my random Androids and WPs... WFC to isn't a reliable science... usually a router tweak or outright router/modem reboot fixes things for me when I consistently have the WFC errors being thrown up nonstop. Sometimes on very rare occasion I have had to enlist T-Mobile to push an update on their end as well to reset the functionality... But I will monitor to see how it fairs and keep your enlightenments in mind...

    Posted via the CrackBerry App for Android
    02-17-16 02:56 PM
  21. Charkatak's Avatar
    Will do... I discover with all my devices it isn't uncommon to awake and see a red phone or SOS or X. It happens from time to time with all my WFC devices, from my BlackBerrys to my random Androids and WPs... WFC to isn't a reliable science... usually a router tweak or outright router/modem reboot fixes things for me when I consistently have the WFC errors being thrown up nonstop. Sometimes on very rare occasion I have had to enlist T-Mobile to push an update on their end as well to reset the functionality... But I will monitor to see how it fairs and keep your enlightenments in mind...

    Posted via the CrackBerry App for Android
    Thanks! You may see the issue better if you select "Never use cellular..." in WiFi calling menu. Also don't be plugged in, as this may not repro.

    Tweaking the router could work if you are at home, but in big organization that wouldn't be possible 2 of my other phones(Nexus 5X and Xperia Z3) behave properly on WiFi calling and yet to give me errors. So T-Mobile told me that this fix has to come from Blackberry and also they have discovered that WiFi calling settings may change by themselves. I think there is an issue with Google's WiFi sleep policy, which somehow tries to save power and puts WiFi in some kind of sleep mode without disconnecting it.
    CivilDissident likes this.
    02-17-16 03:02 PM
  22. jonesy39's Avatar
    Thanks! You may see the issue better if you select "Never use cellular..." in WiFi calling menu. Also don't be plugged in, as this may not repro.

    Tweaking the router could work if you are at home, but in big organization that wouldn't be possible 2 of my other phones(Nexus 5X and Xperia Z3) behave properly on WiFi calling and yet to give me errors. So T-Mobile told me that this fix has to come from Blackberry and also they have discovered that WiFi calling settings may change by themselves. I think there is an issue with Google's WiFi sleep policy, which somehow tries to save power and puts WiFi in some kind of sleep mode without disconnecting it.
    Yeah i have noticed wifi calling is enabled after a restart even tho "cellular" preferred is selected. Clearly some issues to work out.

    Posted via the CrackBerry App for Android
    02-20-16 06:47 PM
  23. grumpyaeroguy's Avatar
    hey folks,

    been outta circulation the last few days.

    When my phone awakes from a sleep, SOMETIMES, it does stumble getting WiFi calling "back"--- assuming it was there when it went into its slumber.

    I placed a "WiFi On/Off" short cut on my home screen. A quick toggle of WiFi wacks it back into shape.

    So, MY conclusion: TMo made it better. It was out to lunch prior to their intervention. I now have a minor annoyance described above.

    Needs a little "tweaking" but works good enough for me right now. Any improvement is gravy in my mind. I, for one, am OK with it. Just my $0.05.
    02-20-16 08:21 PM
  24. jonesy39's Avatar
    Just curious any progress on this? Has any seen any improvements?

    Posted via the CrackBerry App for Android
    04-01-16 08:53 PM
  25. Chavez78's Avatar
    I hate leaving wifi on. Im always sitting in my car with a poor wifi signal and not able to connect.

    Posted via the CrackBerry App for Android
    04-01-16 08:59 PM
26 12

Similar Threads

  1. No Twitter Notifications In Priv Hub
    By gnirkatto in forum BlackBerry Priv
    Replies: 20
    Last Post: 07-30-16, 11:42 AM
  2. How do I block incoming phone calls on a BlackBerry Passport?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 24
    Last Post: 06-16-16, 11:07 PM
  3. Marketing/Carrier support : Orange France offering 3 Privs (FB contest)
    By Superfly_FR in forum General BlackBerry News, Discussion & Rumors
    Replies: 4
    Last Post: 02-17-16, 02:14 PM
  4. Replies: 3
    Last Post: 02-16-16, 08:47 AM
  5. Problem with Instagram on Priv after update.
    By Watch-Site in forum Ask a Question
    Replies: 2
    Last Post: 02-16-16, 06:08 AM
LINK TO POST COPIED TO CLIPBOARD