1. Rescue_525's Avatar
    I have my Priv set for Priority only and was suppose to turn off when the alarm went off in the morning. Alarm went off but Priv is still set up as Priority Only, I did two reboots of phone and used side buttons to try to End Now but phone is still set as Priority Only. I get alerts for text messages and emails with the Priority Only turned on.
    03-30-17 10:11 AM
  2. CarGuy1368's Avatar
    Have you tried a hard reboot? Hold down the power button until the phone reboots on its own.
    04-02-17 01:42 AM
  3. BBinko's Avatar
    Same issue here. Rebooted, hard Rebooted, used buttons to take volume to vibrate and back to max... privacy will not turn off.
    04-06-17 06:44 AM
  4. anon(3641385)'s Avatar
    Same issue here. Rebooted, hard Rebooted, used buttons to take volume to vibrate and back to max... privacy will not turn off.
    Try a 32 second re-boot. So, hold power button and volume down key for 32 seconds. Time it.

    It's the equivalent of a battery pull.

    Post back if it sorted it. ๐Ÿ˜€
    04-06-17 06:51 AM
  5. BBinko's Avatar
    Try a 32 second re-boot. So, hold power button and volume down key for 32 seconds. Time it.

    It's the equivalent of a battery pull.

    Post back if it sorted it. ๐Ÿ˜€
    No, it didn't solve the problem. I did, however, get to a start menu that gave several options.
    04-06-17 08:15 AM
  6. siglerm's Avatar
    I am also having issues with the Priority alarm coming on. I turn it off and then at some point, I find the do not disturb is rengaged with only Priority alarms set. I keep turning it off but it still re-engages. I have also restarted the Priv and found when it came back on, the "do not disturb" with Priority setting was re-engaged. Something is definitely wrong.
    04-06-17 01:39 PM
  7. rr_bored's Avatar
    I'm ending years of lurking for this...especially if HW support from Blackberry is based here now...

    I have a DTEK50 - but it has itself set to the "Priority Only" setting, despite resets, rebooting and the "END NOW"/volume option. Although alerts from my emails and phone calls are still being received.

    Suggestions of a remedy are welcome.
    04-10-17 10:14 PM
  8. anon(3641385)'s Avatar
    Have any of you tried a notifications app from the playstore?

    I know it's not the solution to the stated problem , but it may sort it out till a solution's found.
    04-11-17 03:09 AM
  9. rr_bored's Avatar
    After some research around the Web, it seems it's an Android problem that's come up in the past. Probably triggered by this recent update that just got installed.

    It can be fixed by:
    Settings -> Sound & notification -> Do not disturb -> Automatic rules

    Turn on an automatic rule, then the "priority only" will change to Automatic (or something like that) and you'll be able to change the setting back to DND and it'll work like normal.

    Thanks to whoever posted this info originally.
    anon(3641385) likes this.
    04-11-17 10:33 PM
  10. GM1971's Avatar
    Ok, I just fixed mine with the above tip. Went into settings/sound and notification /do not disturb. Made an automatic rule that made do not disturb come on automatically for one minute, then shut off each day. Set it for a couple minutes ahead of the current time and after it did it's thing I could use do not disturb again normally. I even deleted the new rule. Thanks for the help!
    FF22 likes this.
    05-02-17 10:47 AM

Similar Threads

  1. Why has the KEYone been released with only 3GB of RAM?
    By greg overton in forum BlackBerry KEYone
    Replies: 85
    Last Post: 04-12-17, 05:42 AM
  2. I have a BB Priv and have been trying to turn on HD voice
    By CrackBerry Question in forum AT&T
    Replies: 3
    Last Post: 04-04-17, 09:52 PM
  3. Glitchy phone that won't play videos
    By Crystal29 in forum BlackBerry Priv
    Replies: 3
    Last Post: 03-30-17, 09:24 AM
  4. Replies: 1
    Last Post: 03-29-17, 11:53 AM
LINK TO POST COPIED TO CLIPBOARD