1. trutledge83's Avatar
    Hey guys I have a priv and the hub is so slow and laggy. Are there any ways to speed it up?

    Its bad enough I might use the dedicated messenger and email apps

    Any thoughts?
    04-03-17 07:51 PM
  2. medic22003's Avatar
    I don't have an issue on mine. Maybe you need to clean up some ram/ cache etc etc
    04-03-17 08:17 PM
  3. WaterTower's Avatar
    Had an issue with mine earlier today. I actually pressed the phone at the top and heard a snap. Worked just fine after that. It was the strangest thing
    04-03-17 09:11 PM
  4. anon(3641385)'s Avatar
    Hey guys I have a priv and the hub is so slow and laggy. Are there any ways to speed it up?

    Its bad enough I might use the dedicated messenger and email apps

    Any thoughts?
    Try a 32 second re-boot, so hold the power button for 32 seconds. Time it.

    It's the equivalent of a battery pull. 😀

    If that doesn't work, you could disable hub + services, turn phone off for several minutes, turn on and enable hub+ services again. (Settings, apps, BlackBerry hub+ services)

    You'd need to re-establish your accounts.
    04-03-17 09:52 PM
  5. Edge of Night's Avatar
    Hey guys I have a priv and the hub is so slow and laggy. Are there any ways to speed it up?
    I had the same issue, especially when opening a multi-email conversation. The BlackBerry Hub+ Services update yesterday made a huge difference.
    FF22 and anon(3641385) like this.
    04-09-17 12:30 AM
  6. Wezard's Avatar
    What all accounts do you have on the hub? I have 3 email accounts, text and of course the phone, and no lag at all. If you have Face Book, WhatsApp, and other similar social apps, all reporting notifications, I can see where it might get laggy.
    04-09-17 12:47 PM
  7. AZN's Avatar
    Try deleting some of your accounts from the Hub one by one. I had this issue and deleted my accounts individually until the Hub was lightning fast again. Hope that helps.
    04-09-17 01:29 PM

Similar Threads

  1. Priv using massive loads of data since April 1st no joke
    By mynewbed in forum BlackBerry Priv
    Replies: 20
    Last Post: 06-07-17, 09:14 PM
  2. Priv Bluetooth draining battery
    By heading4tomorrow in forum BlackBerry Priv
    Replies: 10
    Last Post: 04-17-17, 01:58 PM
  3. Why does my phone say safe mode on bottom left corner?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 04-05-17, 10:33 PM
  4. Hub: touch to Open an email skips to next email?
    By SoxFan in forum BlackBerry HUB+ Suite
    Replies: 2
    Last Post: 04-04-17, 09:19 PM
  5. Apps won't open when I press icons on my BlackBerry Q10
    By Marc Harrison in forum BlackBerry Q10
    Replies: 3
    Last Post: 04-04-17, 07:22 AM
LINK TO POST COPIED TO CLIPBOARD