1. Geoff54's Avatar
    I have an AT&T PRIV, unlocked, fully owned. My build and security patch is over a year old and AT&T keeps telling me that because I'm on 6.0.1 Android my software is current (and the PRIV keeps telling me this) and there is nothing they can do. I even spoke to a tech who said I had old software but he could not push current to me. He opened a case with advanced tech support and they closed it the next day with no reason. I spoke with another person and they said I needed to contact Blackberry as there is nothing they can do. This is ridiculous. I have done a factory reset and it just comes back to the same Sept 6, 2016 build AAG202. Their website shows that there are at least a dozen builds newer than mine. How can I get an update. I understand that one fix that later builds have is for the "No Service" issue that I constantly have with AT&T.
    01-17-18 12:32 PM
  2. Chuck Finley69's Avatar
    I have an AT&T PRIV, unlocked, fully owned. My build and security patch is over a year old and AT&T keeps telling me that because I'm on 6.0.1 Android my software is current (and the PRIV keeps telling me this) and there is nothing they can do. I even spoke to a tech who said I had old software but he could not push current to me. He opened a case with advanced tech support and they closed it the next day with no reason. I spoke with another person and they said I needed to contact Blackberry as there is nothing they can do. This is ridiculous. I have done a factory reset and it just comes back to the same Sept 6, 2016 build AAG202. Their website shows that there are at least a dozen builds newer than mine. How can I get an update. I understand that one fix that later builds have is for the "No Service" issue that I constantly have with AT&T.
    The build you're stuck on is before the NO SVC issue. There was a special download tool provided via link that had to be downloaded to get further updates. If memory serves me, download tool had purpose of factory unlocking device and remainder of updates were AT&T specific but pushed out from BB directly. Call BB if AT&T can't help further.
    01-17-18 02:03 PM
  3. newcollector's Avatar
    I have an AT&T PRIV, unlocked, fully owned. My build and security patch is over a year old and AT&T keeps telling me that because I'm on 6.0.1 Android my software is current (and the PRIV keeps telling me this) and there is nothing they can do. I even spoke to a tech who said I had old software but he could not push current to me. He opened a case with advanced tech support and they closed it the next day with no reason. I spoke with another person and they said I needed to contact Blackberry as there is nothing they can do. This is ridiculous. I have done a factory reset and it just comes back to the same Sept 6, 2016 build AAG202. Their website shows that there are at least a dozen builds newer than mine. How can I get an update. I understand that one fix that later builds have is for the "No Service" issue that I constantly have with AT&T.
    Is your phone factory unlocked or have you unlocked it but it was purchased as an AT&T device? If it was factory unlocked, the No Service issue did not affect those devices. It affected devices that were locked to AT&T that had been sold on eBay as locked with an unlock code provided, or sold as unlocked having been unlocked from the carrier after the fact.

    If the latter two options, then you should try an autoloader specific to your device model number. Or you can contact BlackBerry about it thru their @BlackBerrySupport twitter account. I do not know if the BlackBerry help page is up with the No Service thread and fix link still active.

    You may be out of luck though with BlackBerry since they no longer support the EOL Priv.
    01-17-18 03:33 PM
  4. dillyyo's Avatar
    I have an AT&T PRIV, unlocked, fully owned. My build and security patch is over a year old and AT&T keeps telling me that because I'm on 6.0.1 Android my software is current (and the PRIV keeps telling me this) and there is nothing they can do. I even spoke to a tech who said I had old software but he could not push current to me. He opened a case with advanced tech support and they closed it the next day with no reason. I spoke with another person and they said I needed to contact Blackberry as there is nothing they can do. This is ridiculous. I have done a factory reset and it just comes back to the same Sept 6, 2016 build AAG202. Their website shows that there are at least a dozen builds newer than mine. How can I get an update. I understand that one fix that later builds have is for the "No Service" issue that I constantly have with AT&T.
    I've went through this exact same problem for the last 14 months I have had a priv. Three privs later and ATT still cannot or will not push updates to my phone. They blame blackberry and blackerry support 2 times told me its a network issue and really no chance that three phones could all have the same hardware failure, even though its not a hardware issue. Even had the manager of ATT advanced network team tell me I'm essentially **** out of luck since they have done all they can and I was still paying for the phone then.

    The only way to update is to use autoloaders. Bite the bullet one day; download all of the missing patches via autoloaders; sequentially execute the autoloaders until the phone is fully updated and then set the phone up.
    01-20-18 11:12 PM
  5. Huussi's Avatar
    I've went through this exact same problem for the last 14 months I have had a priv. Three privs later and ATT still cannot or will not push updates to my phone. They blame blackberry and blackerry support 2 times told me its a network issue and really no chance that three phones could all have the same hardware failure, even though its not a hardware issue. Even had the manager of ATT advanced network team tell me I'm essentially **** out of luck since they have done all they can and I was still paying for the phone then.

    The only way to update is to use autoloaders. Bite the bullet one day; download all of the missing patches via autoloaders; sequentially execute the autoloaders until the phone is fully updated and then set the phone up.
    What? No.
    Install the latest image it contains all of the earlier patches, might have saved some time this way
    Wezard likes this.
    01-21-18 10:08 AM
  6. dillyyo's Avatar
    What? No.
    Install the latest image it contains all of the earlier patches, might have saved some time this way
    I was told each patch has it's own "value" and needs to be installed sequentially. I periodically would use an autoloader to update, but it's a PITA setting up everything each time. Luckily my contacts and emails are in the cloud. Still not acceptable.

    Mt last update is from sept and there is only one more patch, so I'm not sure if I will do it again for one last update. Time for PRIV to go to my 10 year old and I guess get a Motion.
    01-21-18 01:09 PM
  7. Wezard's Avatar
    Mt last update is from sept and there is only one more patch, so I'm not sure if I will do it again for one last update.
    That last update contained the Krack fix, pretty important update.
    01-21-18 05:54 PM

Similar Threads

  1. How can I install the Google Settings app?
    By ofure in forum Ask a Question
    Replies: 8
    Last Post: 01-19-18, 03:17 AM
  2. Replies: 4
    Last Post: 01-17-18, 01:05 PM
  3. Genuine Cases, Rocking Horse Do in Uk
    By AWB70 in forum BlackBerry DTEK50
    Replies: 2
    Last Post: 01-17-18, 12:44 PM
  4. BlackBerry's Trade Up Program for Priv and BlackBerry OS10
    By CrackPriv in forum General BlackBerry Discussion
    Replies: 6
    Last Post: 01-17-18, 11:52 AM
  5. Replies: 1
    Last Post: 01-17-18, 09:31 AM
LINK TO POST COPIED TO CLIPBOARD