1. Paullybob's Avatar
    Anyone else having a problem installing the latest Google update from the app store?? Downloads fine and attempts to install but shuts down the phone and reboots it without installing the update, When I check under "My apps and Games" heading, the request for the Google update remains. All others apps updated normally today except Google for the past couple of days,
    11-20-18 08:26 PM
  2. Gray's Avatar
    I noticed that Google applications seems to be updated. Not sure If the Google update finished because it's running again.
    Paullybob likes this.
    11-21-18 12:21 AM
  3. Gajja's Avatar
    Yeah I had that also, but it seems to be fine now.
    Paullybob likes this.
    11-21-18 06:39 AM
  4. mcelotto's Avatar
    I've had it happen where I try to install the update and the OS seems to update (not the phone), but if I try it a second time it takes forever but it works.
    Paullybob likes this.
    11-21-18 11:10 AM
  5. CrackPriv's Avatar
    I had this problem these days on my Priv. After clearing the cache it worked fine again.
    Paullybob and Gerard62100 like this.
    11-21-18 11:29 AM
  6. Paullybob's Avatar
    Finally got the update to load properly. Had to uncheck the Auto-update box and then apply the update. The download asked my if I wanted to auto-update from now on, I clicked "Yes" and away it went!! Don't know if its what I did or just a fluke but anyway, update is done!!
    11-22-18 06:26 AM
  7. Master Goa's Avatar
    I have been having this issue since mid September.
    The solution that works for me is the following:
    Update everything except Google.
    Reboot.
    Update Google. It will fail, you will also note that auto orientation is off if you usually have it on.
    Reboot.
    Update Google and it will work.
    Hope this helps.
    Note that sometimes, like the Oct 29th update went on normally without issues.
    However Nov 16th simply would not work, but Nov 22 worked as described above.
    If BB is watching this, please fix these shenanigans
    mcelotto likes this.
    11-27-18 09:25 AM
  8. Michael Liang's Avatar
    I had this problem these days on my Priv. After clearing the cache it worked fine again.
    I resolved the issue by clearing the cache in my internal storage as well
    11-29-18 05:23 AM
  9. MikePriv's Avatar
    Still having this issue, seems that clearing the Google app cache is not effective every time. what more can we do, this is ridiculous.
    12-10-18 02:25 PM
  10. Fed66's Avatar
    I do not know why. But my Solution is to keep the Phones Screen alive. When i make this update, I keep it in my Hands and scroll up and down to prevent that the Screen goes Black. Sounds funny, I know. But I had this Issue bevor and now I did this for the last four Updates and it worked every since. I takes a while and you must have a little patience. But it seems the only thing workes for me.
    Greetz. FED
    12-12-18 05:53 AM

Similar Threads

  1. Dtek Issues
    By Jason Stager in forum BlackBerry Priv
    Replies: 13
    Last Post: 11-23-18, 03:25 PM
  2. Call waiting issue
    By frontier1958 in forum BlackBerry KEY2
    Replies: 5
    Last Post: 11-22-18, 04:26 PM
  3. Megapost: state what Verizon store fixed issues
    By MB64 in forum BlackBerry KEY2 LE
    Replies: 8
    Last Post: 11-22-18, 02:01 PM
  4. Google map
    By abdbb in forum BlackBerry Passport
    Replies: 13
    Last Post: 11-21-18, 04:50 PM
  5. Update for Z10 didn't complete
    By Nkosinathi Romeo in forum BlackBerry Z10
    Replies: 1
    Last Post: 11-20-18, 08:45 AM
LINK TO POST COPIED TO CLIPBOARD