1. sooksook's Avatar
    I've had my Priv for almost a week now, and despite my best efforts Gmail refuses to sync in the Hub. None of the other email accounts I've added have problems (Outlook, Exchange). When I click on "Folders" in Gmail, it shows "Syncing" in green under inbox, drafts and sent, but nothing ever happens.

    Curiously, I can seemingly compose a Gmail message. I tried a test email and the ones sent from my phone show up in the sent folder.

    I've deleted the account from the Hub multiple times and re-added it, rebooted, etc. Also tried adding the account manually and double checking the port numbers. Played around with the sync intervals (currently set to 15 minutes, push on). Nothing works. Having to resort to using the Android Gmail App to check my emails is annoying, to say the least.

    Any ideas?

    Posted via the CrackBerry App for Android
    11-28-15 01:07 PM
  2. MGO's Avatar
    Disable Gmail app, shorten the sync period to 30 days. Let it sit over night. Do not touch. Same boat as you.

    BlackBerry Priv
    11-28-15 01:10 PM
  3. biochemgod's Avatar
    Well, mine just stopped syncing again... And i have my sync interval set to 90 days and haven't done anything new with the phone recently.
    Can't wait until BlackBerry sorts this out!!

    Posted via the CrackBerry App for Android
    11-28-15 01:33 PM
  4. sooksook's Avatar
    Do you mean change the "Email sync timeframe" to 30 days?

    I've long disabled the auto-sync for the Gmail App. But I still manually open it to check emails.

    Posted via the CrackBerry App for Android
    11-28-15 01:36 PM
  5. biochemgod's Avatar
    Yes, sync timeframe to 30 days for Gmail accounts, but sync interval to "never".

    Posted via the CrackBerry App for Android
    11-28-15 01:50 PM
  6. MGO's Avatar
    Yes but disable the Gmail app and do not open it to check.

    BlackBerry Priv
    11-28-15 02:17 PM
  7. biochemgod's Avatar
    Yep, my GMail has been disabled for 2 weeks. Looks like I'll be doing the Remove Accounts, Clear Hub, Add Accounts, Configure Accounts dance again. I wonder what the underlying problem is? I originally thought it was syncing large volumes of data, but seems to be something else (as well).
    11-28-15 02:29 PM
  8. slowsteve's Avatar
    An android phone that won't sync gmail? Pretty sad.
    11-28-15 04:29 PM
  9. sooksook's Avatar
    Yep, my GMail has been disabled for 2 weeks. Looks like I'll be doing the Remove Accounts, Clear Hub, Add Accounts, Configure Accounts dance again. I wonder what the underlying problem is? I originally thought it was syncing large volumes of data, but seems to be something else (as well).
    That's what I thought too, since I have quite a lot of folders and several gigs of saved emails. However I think a week is enough time for it to process. I've never had a problem setting up a Gmail account on any of my other phones before, including the Q10 that I am migrating from or my Samsung Galaxy Tab 4.

    An android phone that won't sync gmail? Pretty sad.
    The irony is not lost on me.
    11-28-15 06:21 PM
  10. c_bryant34's Avatar
    Yep, my GMail has been disabled for 2 weeks. Looks like I'll be doing the Remove Accounts, Clear Hub, Add Accounts, Configure Accounts dance again. I wonder what the underlying problem is? I originally thought it was syncing large volumes of data, but seems to be something else (as well).
    We know what the issue is and have a fix coming in our next release (soon). How many days were you trying to sync originally and were you trying to sync any folders?
    sooksook likes this.
    11-28-15 06:23 PM
  11. sooksook's Avatar
    We know what the issue is and have a fix coming in our next release (soon). How many days were you trying to sync originally and were you trying to sync any folders?
    It can't come soon enough! But I'm glad it's a known issue. I played around with the settings the first go-round but after I deleted the account and re-added it, I left everything to the stock settings. So 7 days. I just left the default folders to sync: inbox, draft and sent.
    11-28-15 06:26 PM
  12. biochemgod's Avatar
    I have 3 GMail accounts, set to Sync Never, use Push, Timeframe 90 days. Everything worked fine for 2 weeks and then suddenly stopped.
    I just fixed it by removing the accounts in HUB and then clearing the cache and data for blackberry services, then adding the accounts back to HUB one by one and letting them sync. So all is working now but I'm sick of setting up my custom notification lights, sounds etc for each account.

    edit: FWIW even with these issues I prefer BlackBerry Hub over all the other Android e-mail clients - I used K9 for many years but Hub, even in early Android form, is still preferable.
    11-28-15 08:58 PM
  13. c_bryant34's Avatar
    I have 3 GMail accounts, set to Sync Never, use Push, Timeframe 90 days. Everything worked fine for 2 weeks and then suddenly stopped.
    I just fixed it by removing the accounts in HUB and then clearing the cache and data for blackberry services, then adding the accounts back to HUB one by one and letting them sync. So all is working now but I'm sick of setting up my custom notification lights, sounds etc for each account.

    edit: FWIW even with these issues I prefer BlackBerry Hub over all the other Android e-mail clients - I used K9 for many years but Hub, even in early Android form, is still preferable.
    If it stops again (and I hope it doesn't) email bbappsupport@blackberry.com and address it to Cody. I'll get some logs and put it in front of the team.
    12-02-15 11:16 PM
  14. MGO's Avatar
    I have kept my Gmail at 30 days and it has been working for about a week BUT battery consumption is breathtaking and data is constantly going back and forth (so much so that often even plugged in it can not keep up and it gets really hot - over 125 degrees F). I hope the update (I am ATT carrier locked) for both the system software and the Hub fixes this. As others have said I can tolerate almost all other issues but the Hub is a must for me.
    12-03-15 09:06 AM

Similar Threads

  1. Is it possible to record audio onto Playbook from web sites?
    By CrackBerry Question in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 12-08-15, 05:29 PM
  2. Can I get some help setting up my new BB?
    By Jaano in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 12-01-15, 04:59 AM
  3. Why is Z10 hub covered by a white envelope?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 3
    Last Post: 11-29-15, 01:44 PM
  4. Replies: 2
    Last Post: 11-29-15, 01:13 AM
  5. Replies: 2
    Last Post: 11-28-15, 11:33 AM
LINK TO POST COPIED TO CLIPBOARD