1. absolutqt's Avatar
    Hey Everyone. Brand new member here hoping that someone can help me figure out a recent development with my PRIV.

    I'm on the Verizon network. Up until a few days ago, the phone worked just fine regardless if I was connected to home wifi data (Comcast) or the carrier signal. Now when I'm home and attempt to make a call, the phone says "Dialing" for about 15-20 seconds before giving me the, "Can't complete call..." message. Every once in awhile, the call will connect but it drops almost immediately. Texting seems to be fine. Everything else working fine. Just this recent development with making or receiving calls. I tried making calls when I'm on the road and those seem to be working too---so it seems to be something happening only when I'm home.

    I'm desperate. I love this phone--don't want to have to give it up.

    Thanks in advance to anyone who may have a suggestion. Verizon doesn't seem to support this device.
    08-07-19 04:34 PM
  2. Chuck Finley69's Avatar
    Hey Everyone. Brand new member here hoping that someone can help me figure out a recent development with my PRIV.

    I'm on the Verizon network. Up until a few days ago, the phone worked just fine regardless if I was connected to home wifi data (Comcast) or the carrier signal. Now when I'm home and attempt to make a call, the phone says "Dialing" for about 15-20 seconds before giving me the, "Can't complete call..." message. Every once in awhile, the call will connect but it drops almost immediately. Texting seems to be fine. Everything else working fine. Just this recent development with making or receiving calls. I tried making calls when I'm on the road and those seem to be working too---so it seems to be something happening only when I'm home.

    I'm desperate. I love this phone--don't want to have to give it up.

    Thanks in advance to anyone who may have a suggestion. Verizon doesn't seem to support this device.
    I’m assuming you’re on a VZW branded and supported PRIV and you’re having general tower or CDMA specific issues. Leaning toward general tower issues first because CDMA is technically still up and running unless your area won the LTE upgrade prize...
    08-07-19 05:06 PM
  3. absolutqt's Avatar
    Thanks, Chuck. I'm really baffled because husband's Samsung Galaxy and son's iPhone seem to be just fine so it's something specific to my PRIV. I thought maybe an update changed something in the phone's settings but I don't really see anything in the history...
    08-07-19 06:04 PM
  4. Chuck Finley69's Avatar
    Thanks, Chuck. I'm really baffled because husband's Samsung Galaxy and son's iPhone seem to be just fine so it's something specific to my PRIV. I thought maybe an update changed something in the phone's settings but I don't really see anything in the history...
    Welcoming to CrackBerry and I hope to see you around here often posting.

    That being said, I’m not an IT background person so all my suggestions are just anecdotal.

    If your device functions same as before all other places, it’s suggests not the device. However, it may be something internal hardware or software related has failed or changed performance. It may be that your signal where you live was already weak and your device is just not optimal enough for that connection anymore.

    If band frequencies were repurposed in your area to LTE and your family’s devices are newer VZW hardware, your PRIV may be missing certain band frequencies there’s aren’t missing. Those bands could be needed where you live but not when you leave the area you live.

    Most likely your only fix will be a newer VZW supported device.
    08-08-19 07:25 AM
  5. SteinwayTransitCorp's Avatar
    Hey Everyone. Brand new member here hoping that someone can help me figure out a recent development with my PRIV.

    I'm on the Verizon network. Up until a few days ago, the phone worked just fine regardless if I was connected to home wifi data (Comcast) or the carrier signal. Now when I'm home and attempt to make a call, the phone says "Dialing" for about 15-20 seconds before giving me the, "Can't complete call..." message. Every once in awhile, the call will connect but it drops almost immediately. Texting seems to be fine. Everything else working fine. Just this recent development with making or receiving calls. I tried making calls when I'm on the road and those seem to be working too---so it seems to be something happening only when I'm home.

    I'm desperate. I love this phone--don't want to have to give it up.

    Thanks in advance to anyone who may have a suggestion. Verizon doesn't seem to support this device.
    I had this problem once on AT&T, turned out to be a bad SIM card. Went to a store they put a new one in poof it worked. Might be worth trying as well as a wipe and restart as a new phone.
    08-08-19 11:16 AM
  6. absolutqt's Avatar
    I had this problem once on AT&T, turned out to be a bad SIM card. Went to a store they put a new one in poof it worked. Might be worth trying as well as a wipe and restart as a new phone.
    Thanks for the additional suggestion. I don't want to get my hopes up, but about an hour ago, my phone rang, the call connected and I talked for about 30 seconds without incident. Crossing my fingers that whatever gremlins were affecting it for the past few days have been wiped out.

    Also, I love the PRIV so much that I bought a spare from Amazon about a year ago when my phone got wet and I thought it was a goner. When it dried out, it was back to normal with no issues so I stuck the new one in a drawer figuring I have a backup when the original finally gets called home to glory. My husband's Galaxy is so beat-up, he grabbed the PRIV spare and attempted to swap his SIM and memory and he had the exact same issue of not being able to call out or receive. He went back to the beat-up Galaxy but my problem is truly solved, I think I'll have him try again.

    Thanks for listening and weighing in. You guys are great.
    08-08-19 03:12 PM
  7. Chuck Finley69's Avatar
    Thanks for the additional suggestion. I don't want to get my hopes up, but about an hour ago, my phone rang, the call connected and I talked for about 30 seconds without incident. Crossing my fingers that whatever gremlins were affecting it for the past few days have been wiped out.

    Also, I love the PRIV so much that I bought a spare from Amazon about a year ago when my phone got wet and I thought it was a goner. When it dried out, it was back to normal with no issues so I stuck the new one in a drawer figuring I have a backup when the original finally gets called home to glory. My husband's Galaxy is so beat-up, he grabbed the PRIV spare and attempted to swap his SIM and memory and he had the exact same issue of not being able to call out or receive. He went back to the beat-up Galaxy but my problem is truly solved, I think I'll have him try again.

    Thanks for listening and weighing in. You guys are great.
    This will sound like a stupid question. Are both PRIV the VZW model?
    08-08-19 04:33 PM
  8. absolutqt's Avatar
    This will sound like a stupid question. Are both PRIV the VZW model?
    They both claimed to be but I did get the spare one from a 3rd party dealer so who knows for sure? There was no branding or anything on the new spare to suggest that it could be tied to a different carrier.
    08-09-19 06:07 AM
  9. Sigewif's Avatar
    Thanks for the additional suggestion. I don't want to get my hopes up, but about an hour ago, my phone rang, the call connected and I talked for about 30 seconds without incident. Crossing my fingers that whatever gremlins were affecting it for the past few days have been wiped out.

    Also, I love the PRIV so much that I bought a spare from Amazon about a year ago when my phone got wet and I thought it was a goner. When it dried out, it was back to normal with no issues so I stuck the new one in a drawer figuring I have a backup when the original finally gets called home to glory. My husband's Galaxy is so beat-up, he grabbed the PRIV spare and attempted to swap his SIM and memory and he had the exact same issue of not being able to call out or receive. He went back to the beat-up Galaxy but my problem is truly solved, I think I'll have him try again.

    Thanks for listening and weighing in. You guys are great.
    I am on a different carrier (T-Mobile) so this may not apply to your situation. But I have had similar issues at times with my Priv. I found turning off the Wi-Fi made the problem go away. My T-Mobile plan has unlimited data and calling, plus I have a good signal where I live.
    PS: I am a big Priv fan as well. It is tempting to buy one to squirrel away like you did. Mine is semi-retired because I have a KEY2. I harbor a fantasy or dream or hope that there will be a follow up Priv2 type device some day....
    08-15-19 12:12 AM

Similar Threads

  1. Is there a Facebook app that still will run on the Passport?
    By Tim Heard in forum BlackBerry Passport
    Replies: 67
    Last Post: 10-01-19, 03:45 PM
  2. Texts and calls showing twice in Hub
    By Emaderton3 in forum BlackBerry HUB+ Suite
    Replies: 9
    Last Post: 08-10-19, 06:59 AM
  3. KeyOne: How Many Flashes on the Back?
    By Lionel Passport in forum BlackBerry KEYone
    Replies: 14
    Last Post: 08-08-19, 02:50 PM
  4. BlackBerry Motion the % symbol disappear in in sms
    By Corsari in forum BlackBerry Motion
    Replies: 1
    Last Post: 08-07-19, 09:07 AM
LINK TO POST COPIED TO CLIPBOARD