1. nomi1978's Avatar
    So I've had a Priv since Day 1 and I had issues with it running hot and losing signal. I got a replacement device and the heating issue is good but lately my signal is always bouncing between 3G/4G and LTE. I was having a similar issue with an iPhone and they thought it was a bad Sim so I got another one and same issue. It's even worse on the Priv.

    Second issue is Bluetooth battery drain. If I leave my Bluetooth on in standby I am loosing 2-4% an hour when a device is not connected and about 2% when a device is connected. Not sure if that isn't normal.

    I am on the Telus network and using an unlocked Rogers device. Thinking of doing a wipe and starting again.

    All apps are updated and I didn't use the content transfer tool.

    Posted via the CrackBerry App for Android
    12-15-15 07:29 AM
  2. JWWIII's Avatar
    I hear you on battery drain and absolutely with Bluetooth. I had a lot of drain w Bluetooth w my passport, too. I presume there are no solutions?

    Posted via the CrackBerry App for Android
    12-15-15 07:40 AM
  3. djenks76's Avatar
    Knock on wood, I've not experienced the heat issue or signal issue...either before or after the update. I leave my bluetooth on 24/7 connected to my pebble watch and my jabra in my car with no major battery issues.
    12-15-15 09:18 AM
  4. dpanda88's Avatar
    Make sure your preferred network type is set at LTE&4G/3G as Telus does not use 2G any longer.

    For all Roger users, best to keep it at LTE & 4G/3G&2G settings as Rogers still use 2G in low signal patches.
    12-15-15 09:21 AM
  5. nomi1978's Avatar
    Make sure your preferred network type is set at LTE&4G/3G as Telus does not use 2G any longer.

    For all Roger users, best to keep it at LTE & 4G/3G&2G settings as Rogers still use 2G in low signal patches.
    That is what I have it set to. Just sitting here in one spot I have gone from LTE+ to LTE to 4G and I haven't moved or touched the phone.

    Posted via the CrackBerry App for Android
    12-15-15 11:02 AM
  6. o4liberty's Avatar
    The Priv will heat up a little with heavy use but not as bad as my first one.

    Posted via the CrackBerry App for Android
    12-15-15 11:21 AM
  7. h_s's Avatar
    I had the same issue with the bluetooth. After several days of talking to Blackberry technical support, i factory re-set the phone, which completely resolved the bluetooth issue.
    12-15-15 01:33 PM
  8. nomi1978's Avatar
    I had the same issue with the bluetooth. After several days of talking to Blackberry technical support, i factory re-set the phone, which completely resolved the bluetooth issue.
    I think that will be my next step and hopefully that fixes spotty signal issues as well.

    Posted via the CrackBerry App for Android
    12-15-15 04:11 PM

Similar Threads

  1. Low Microphone volume issue
    By nonamenomore in forum BlackBerry Priv
    Replies: 1
    Last Post: 12-15-15, 06:47 AM
  2. Replies: 2
    Last Post: 12-15-15, 03:30 AM
  3. Email Issues
    By khathcock in forum BlackBerry Z10
    Replies: 1
    Last Post: 12-15-15, 02:57 AM
  4. How to fix the popping issue?
    By uhscale in forum BlackBerry Priv
    Replies: 1
    Last Post: 12-15-15, 01:04 AM
  5. Poll Results: Priv owners are using a balance of both the physical and virtual keyboard
    By CrackBerry News in forum CrackBerry.com News Discussion & Contests
    Replies: 0
    Last Post: 12-14-15, 10:51 PM
LINK TO POST COPIED TO CLIPBOARD