01-28-20 10:48 PM
472 ... 1112131415 ...
tools
  1. raino's Avatar
    Any info on Russell's news that says the STV100-1 will in fact work with Verizon with no issues? I emailed him this evening and he says no problems on Verizon?
    Wait...what? Is this Russell from Android Central?

    Outside the email, has he stated this somewhere?
    02-19-16 11:10 PM
  2. bbhybridchris's Avatar
    Yes the news story right on the front page of the site talking about unlocked phones working with Verizon.
    02-20-16 09:22 AM
  3. kg4icg's Avatar
    You are better off surviving getting hit by a a rail locomotive then trying to get a unlocked phone on Verizon. That isn't happening in this life time.
    02-20-16 09:34 AM
  4. bbhybridchris's Avatar
    I have had plenty of unlocked phones on Verizon in the past two years. Starting with the Moto Nexus 6 and as well as unlocked iPhones and the latest crop of Nexus phones. As long as you have a currently active sim it is no problem at all.
    02-20-16 09:39 AM
  5. kg4icg's Avatar
    I have had plenty of unlocked phones on Verizon in the past two years. Starting with the Moto Nexus 6 and as well as unlocked iPhones and the latest crop of Nexus phones. As long as you have a currently active sim it is no problem at all.
    You are talking about phones that Verizon approved to come on there network, white listed. Try that with a non white listed device. You won't get anywhere.
    02-20-16 09:42 AM
  6. bbhybridchris's Avatar
    You are talking about phones that Verizon approved to come on there network, white listed. Try that with a non white listed device. You won't get anywhere.
    Try the Moto Nexus 6 from release day which was not white listed until they released until months later. You could not activate it on the network unless you had a previously activated SIM card already handy. Verizon would not activate the phone because the IMEI was not in their database.
    02-20-16 10:34 AM
  7. kg4icg's Avatar
    I read the article, he said he put the phone on cdma/LTE only. Thing is, the unlocked Priv does not have cdma.
    02-20-16 10:40 AM
  8. ToniCipriani's Avatar
    I read the article, he said he put the phone on cdma/LTE only. Thing is, the unlocked Priv does not have cdma.
    WCDMA =/= CDMA 1x/EV-DO

    WCDMA is the radio for 3G UMTS HSPA.
    CDMA 1x/EV-DO is the radio for 3GPP2 CDMA, which is the 3G network used by Verizon.
    02-20-16 10:46 AM
  9. kg4icg's Avatar
    Cdma which is what Sprint and Verizon uses. Wcdma is what at&t and T-Mobile uses
    02-20-16 10:48 AM
  10. bbhybridchris's Avatar
    Agrees but I also contacted Russell last night and he is having no issues with calls, data, text, or mms on Verizon. Apparently according to him it is only the 100-1 model that does this via the Blackberry online store. It appears maybe the hardware is there just not officially listed? I contacted BlackBerry last night and got a very vague response that it is up to Verizon to make that call and that BlackBerry officially had no comment on the situation. Seems like it may be there but they aren't willing to say.
    02-20-16 10:53 AM
  11. ToniCipriani's Avatar
    Cdma which is what Sprint and Verizon uses. Wcdma is what at&t and T-Mobile uses
    I just said that. He's using it in a VoLTE area, so he set the phone to scan WCDMA/LTE only, not CDMA/LTE like you said.
    02-20-16 10:54 AM
  12. kg4icg's Avatar
    Then he is on LTE only or they sent him a Verizon model by mistake. There is no carrier splash screen in unlocked models.
    02-20-16 11:02 AM
  13. kg4icg's Avatar
    The article said cdma/LTE
    02-20-16 11:04 AM
  14. bbhybridchris's Avatar
    Actually if you read the article the Priv he simply put the SIM in and the phone rebooted with the carrier settings installed. He did not change anything in the Priv as far as settings go.
    02-20-16 11:25 AM
  15. ToniCipriani's Avatar
    Then he is on LTE only or they sent him a Verizon model by mistake. There is no carrier splash screen in unlocked models.
    There is. My ShopBB model flashed the purple Telus screen and installed the corresponding app, when I first plugged in my Koodo SIM.
    02-20-16 11:27 AM
  16. kg4icg's Avatar
    I read the. Article, especially where he did have trouble twice. And it's going to keep happening. No 3g cdma authentication is happening so it's going to happen again
    02-20-16 11:27 AM
  17. raino's Avatar
    I have posted a few questions to Russell's post, but assuming he really does have an STV100-1 working on Verizon--including calls and texts--I'm guessing he must be in an LTE b4 ("XLTE") or b2 market. Verizon does have plans to go all-LTE in their phone lineup by the end of this year.

    That being said, if Verizon voLTE really is working on the -1, I find it very, very odd that Verizon would allow it on a phone that lacks LTE b13 (the band for their primary LTE network*) If Verizon's approval is not necessarily at all, that would be even weirder, as Verizon does not strike me as a BYOD carrier whatsoever--especially with nascent features.

    *When TMO came under fire for having OEMs remove LTE b12 from their phones, their argument was that they wanted phones to be voLTE-approved for b12's to exist in those phones. And according to TMO, the primary reason they wanted phones to be voLTE-approved was so that TMO wouldn't run afoul of e911 requirements, and if there was a TMO customer whose only network around was the b12 network, they could make a voLTE 911 call in case of an emergency. Assuming this all was true, wouldn't the same requirements apply to Verizon? Why would they allow voLTE on a b13-less phone? Do they have nationwide overlap between b13 and b2 or b4 LTE networks?
    02-20-16 03:47 PM
  18. osimo2's Avatar
    See my response on AndroidCentral. Was using an STV-001. And tried both iPhone and android VZW SIMs. Lucky enough I can perform all these experiments.
    raino likes this.
    02-20-16 03:51 PM
  19. raino's Avatar
    See my response on AndroidCentral. Was using an STV-001. And tried both iPhone and android VZW SIMs. Lucky enough I can perform all these experiments.
    I did see your replies to my questions there, much appreciated. So that everyone here is on the same page, I'm taking the liberty of posting your responses:

    Mobile data worked. 4G LTE. Could send text, email, Internet, Facebook, every function on the phone except call. Location is downtown in a large northern east coast city (full 4G LTE coverage for the whole state). Went to Verizon store, they were perplexed as well. Could not edit APNs either.

    Quite skeptical on the validity of this article.

    Was a nice experiment.

    STV-001
    A couple of follow-up questions:

    -Do you know if you are in an XLTE (LTE b4,) or LTE b2, or LTE b5 market?
    -Where did you buy your -1?
    02-20-16 03:58 PM
  20. osimo2's Avatar
    Of course, happy to help. Yes, am in an XLTE city, and purchased the phone from Amazon (sold by BlackBerry). STV-001.
    raino likes this.
    02-20-16 04:05 PM
  21. raino's Avatar
    Of course, happy to help. Yes, am in an XLTE city, and purchased the phone from Amazon (sold by BlackBerry). STV-001.
    OK, so assuming you were on that XLTE (band 4) network: voice did not work but text did.

    That's interesting to me, because if SMS can be sent over LTE (packet switched) here then why can't voice be?
    Is voLTE (just voice, literally) a b13-only service?
    02-20-16 06:25 PM
  22. Javier Briones's Avatar
    Hi, Raino, hi everyone. Off topic: finally I got the stv100-3 from a local retailer, I'll tell you more, later.
    raino likes this.
    02-24-16 04:26 PM
  23. raino's Avatar
    Added the Verizon Priv to the table, and compatible carriers.
    Last edited by raino; 03-14-16 at 09:03 PM. Reason: S&PI now available
    03-03-16 12:32 PM
  24. Norg's Avatar
    Added the Verizon Priv to the table, and compatible carriers.

    No S&PI from BlackBerry yet...
    I am truly impressed by your level of mobile comm. knowledge, awesome to see that there are folks like you and a few others hanging around these forums.

    Posted via the CrackBerry Android App with my BlackBerry PRIV
    03-14-16 01:17 PM
  25. ToniCipriani's Avatar
    So I was going through the PTCRB docs for the OS builds, just noticed that the STV100-1 doesn't have LTE Carrier Aggregation listed, whereas the STV100-3 doesn't? I do remember seeing the LTE+ symbol on my -1 though.
    03-30-16 08:46 PM
472 ... 1112131415 ...

Similar Threads

  1. Priv Clears FCC
    By lawguyman in forum BlackBerry Priv
    Replies: 43
    Last Post: 10-23-15, 09:44 AM
  2. VKB on Priv?
    By TTQ225 in forum BlackBerry Priv
    Replies: 18
    Last Post: 10-23-15, 03:02 AM
  3. Snapchat is not working on blackberry passport.
    By gauchan in forum Ask a Question
    Replies: 7
    Last Post: 10-22-15, 01:32 PM
  4. Priv by BlackBerry passes through the FCC
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-22-15, 01:30 PM
  5. Latest BlackBerry Blend update brings a few bug fixes to the BlackBerry 10 app
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 10-22-15, 12:51 PM
LINK TO POST COPIED TO CLIPBOARD