1. iamomkar's Avatar
    Hello, i have a blackberry Priv that is stuck on BB logo and just keeps on restarting and doesnt go to the main screen..
    how to solve this problem? Autoloader will help?
    I have tried 8 seconds and 32 seconds battery pull thing but nothing fruitful. I'm able to enter bootmenu but cannot choose anhything as priv restarts..
    It is a software thing or any hardware issue( Battery).
    Please help guys i'm worried
    04-17-17 02:38 PM
  2. Dunt Dunt Dunt's Avatar
    So you have gotten to the Boot Menu but it reboots before you can make any selections - Safe Mode or Factory Reset?

    Yes you could try an Autoloader and see if that fixes it, not much else you can do - other then contact support, if your under warranty.
    FF22 likes this.
    04-17-17 02:53 PM
  3. FF22's Avatar
    Bootmenu can be confusing when using an Autoloader. Bring up Bootmenu and then run the Autoloader on your computer. Do NOT try selecting the autoloader from the menu - that only circles back to the menu.
    04-17-17 04:34 PM
  4. iamomkar's Avatar
    After several hours I wrote my last comment, the phone showed the fastboot mode, restarting over and over without showing the BB Logo, but only the fastboot menu, constantly rebooting.
    I figured out that somehow the power button got jammed. I pulled the socket and problem resolved
    Thanks guys!
    Uzi and FF22 like this.
    04-19-17 12:08 AM
  5. newcollector's Avatar
    After several hours I wrote my last comment, the phone showed the fastboot mode, restarting over and over without showing the BB Logo, but only the fastboot menu, constantly rebooting.
    I figured out that somehow the power button got jammed. I pulled the socket and problem resolved
    Thanks guys!
    Great deduction! Glad it is resolved.
    FF22 likes this.
    04-19-17 01:10 PM

Similar Threads

  1. Is it possible to use a song as a ringtone on the DTEK50?
    By Kevsplitty in forum BlackBerry DTEK50
    Replies: 6
    Last Post: 05-02-17, 02:45 PM
  2. Replies: 8
    Last Post: 04-19-17, 01:28 AM
  3. Snap keeps crashing after 10.3.3 update
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 04-18-17, 03:57 PM
  4. Priv with mobile hotspot on Simple Mobile not working
    By clicketyclack in forum BlackBerry Priv
    Replies: 0
    Last Post: 04-17-17, 01:13 PM
  5. Replies: 1
    Last Post: 04-17-17, 12:25 PM
LINK TO POST COPIED TO CLIPBOARD