1. scheichberry's Avatar
    Hello
    I have something curious with my Priv.
    When attaching the loader the battery-symbol on top shows "charging" but the battery percentage does not change - even if loading for 2 hours.

    Any idea what to do?

    Thank you


    Edit:
    The BB Virtual expert shows me " charging " and at the same time a (negative) current of 128 mA (- 128 mA)

    Is that typical?
    Last edited by scheichberry; 05-26-19 at 03:28 PM.
    05-26-19 11:26 AM
  2. PRIVuser2018's Avatar
    Having a negative current isn't normal while charging. What charger are you using, original or aftermarket? What current does it provide (should say on the charging brick)? Try another charger if you can. Otherwise try cleaning the charging port.
    05-26-19 08:56 PM
  3. scheichberry's Avatar
    Thank you very much
    Meanwhile I have tried 3 different chargers (current 1,5 A) which are all (successful) charging other smartphones. So I think it is not a faulty charger.
    The charging port is definitely clean .

    Does it make sense to reflash the rom?
    05-28-19 01:22 AM
  4. hazmaju's Avatar
    Not really if you have a battery problem, as the issue seems like that. For reflashing ROM it's important to have a good charge or you could not finish autoloading properly...

    Posted via CB10
    05-28-19 06:03 AM
  5. RLeeSimon's Avatar
    this is how my Priv met its demise... the connection block above the microUSB port is very fragile, and Asa residing on the motherboard, is not an easy change-up... it's a shame... try a QI charger...
    05-28-19 08:45 AM
  6. scheichberry's Avatar
    Thank you very much
    Unfortunately I have a European Priv , so there is no QI charger preinstalled. Ans the warranty is just gone.

    But maybe there is a tutorial how to solder a Universal QI wireless charging receiver to the battery.

    You know such a tutorial?
    05-28-19 01:57 PM
  7. RLeeSimon's Avatar
    the likely culprit is the microUSB charge block that resides on the motherboard above the microUSB... I replaced (at a repair shop) the motherboard (from another PRIV off eBay with cracked screen) and microUSB (new via eBay) and it lasted a week and melted again... I have an OG Priv with QI built in and it works fine but microUSB is toast...
    05-30-19 02:02 PM
  8. scheichberry's Avatar
    Hello
    With a very special charger the problem is fixed.
    Will there be a firmware update in future?
    Regards
    06-12-19 12:45 PM
  9. astrodan13's Avatar
    Hello
    With a very special charger the problem is fixed.
    Will there be a firmware update in future?
    Regards
    Glad you fixed the problem. What type of charger finally worked for you? Just in case others have the same problem now or down the road. Thanks!
    06-13-19 09:52 AM
  10. scheichberry's Avatar
    Hello

    It is a German item called
    DUAL-PORT USB-ÄUTOLÄDEGERÄT

    and this charger loads up to 1450 mA
    06-13-19 10:10 AM

Similar Threads

  1. Replies: 41
    Last Post: 06-15-19, 08:45 PM
  2. Passport swam in the lake for 30 minutes. Now what?
    By Munchkinguy in forum BlackBerry Passport
    Replies: 28
    Last Post: 06-15-19, 07:25 PM
  3. Show me your City BBMe Group!
    By wilkto in forum Discover BBM Groups
    Replies: 21
    Last Post: 06-12-19, 02:08 AM
  4. Replies: 9
    Last Post: 05-28-19, 05:53 PM
  5. apps not installing
    By mazizys in forum Ask a Question
    Replies: 3
    Last Post: 05-26-19, 03:33 PM
LINK TO POST COPIED TO CLIPBOARD