1. markspriv's Avatar
    Could somebody with a PRIV please test this to see if this might be a software issue.

    The problem I have is that my PRIV STV100-4 will auto rotate just fine until I open up a browser in portrait (any will do I've tried Chrome and Firefox with the same results) and proceed to open up a HTML5 game that requests a rotat

    To replicate the issue, try to start this game in portrait mode, the game will ask for the screen to rotate, but it suddenly stops auto rotating and the message will stay on the screen

    Nuts For Winter Preview - CodeCanyon

    Once this issue occurs nothing will rotate, Google maps, camera etc all fail

    A reboot of the phone fixes the problem. Opening up the game again instantly brings back the problem.

    I have done a master reset of the device and not installed anything at all short of updates for the pre-loaded apps (going to try a reset again with no updates)

    I've tried an app which allows me to manually select the screen orientation and it will allow the phone to rotate
    https://play.google.com/store/apps/d...ntrol&hl=en_GB

    My phone is coming up as fully up to date when I check for updates

    Android version 6.0.1 (Shame on BB for not pushing out an update of the OS!)
    Android security patch level 5 October 2017
    Kernal version Mar 2nd 2018
    Build number AAW068

    I am wondering if the last update caused this and I just did not notice it.

    Appreciate it if you could give it a try and report back.

    Thanks
    07-15-18 12:13 PM
  2. misterabrasive's Avatar
    Happens to my Priv from time to time. When it happens either reset the autorotate under quick settings or go to system settings display and reset the when device is rotated option.
    Common occurrence along with custom ringtones resetting to default and app icons disappearing from the home screen.
    07-15-18 05:53 PM
  3. markspriv's Avatar
    I have had the phone two years and it's been working fine, I think this might be related to the last update.

    I can replicate the problem every single time I repeat the process above.

    If your phone is also up to date could you possibly try the steps above to see if it also has the same issue, that way I'll know this is not a hardware issue.

    I have tried changing the rotate settings back and forwards, it doesn't fix it, only a reboot will make it work again, but if I repeat the process above, it's back to non-functioning and needs another restart.
    07-16-18 03:57 AM
  4. markspriv's Avatar
    Appreciate it if somebody could please try to replicate the problem using the details in my original post.

    I had replaced the screen not too long ago so I'm concerned that the sensors might be in that screen/lid which was a full replacement, and I will run out of time to have the part replaced under warranty. Although I am thinking this is related to the last BB update.

    Thanks.
    07-22-18 06:25 AM
  5. gebco's Avatar
    No problem on my Priv. Rotated back and forth several times.


    Appreciate it if somebody could please try to replicate the problem using the details in my original post.


    Thanks.
    07-23-18 01:26 AM
  6. markspriv's Avatar
    Thanks for checking, now I'm starting to wonder if it's the new screen (although I am unsure if the senors are in the lid)

    Could you check it you have the same software versions as mine
    Android version 6.0.1 (Shame on BB for not pushing out an update of the OS!)
    Android security patch level 5 October 2017
    Kernal version Mar 2nd 2018
    Build number AAW068

    You checked it on the nuts for winter game?

    Thanks
    07-23-18 03:08 AM
  7. gebco's Avatar
    Yes to everything :

    Thanks for checking, now I'm starting to wonder if it's the new screen (although I am unsure if the senors are in the lid)

    Could you check it you have the same software versions as mine
    Android version 6.0.1 (Shame on BB for not pushing out an update of the OS!)
    Android security patch level 5 October 2017
    Kernal version Mar 2nd 2018
    Build number AAW068

    You checked it on the nuts for winter game?

    Thanks
    07-23-18 10:29 AM
  8. markspriv's Avatar
    Thanks. It certainly looks like this new lid/screen is suspect

    Perhaps one more person could give it a check before I have to pay for another screen install as I bought the screen from Ebay and had a local shop install it, which now I look back was a bad idea.
    07-23-18 11:00 AM

Similar Threads

  1. KEY2 and Android Auto not working
    By arniebirdy in forum BlackBerry KEY2
    Replies: 14
    Last Post: 08-28-19, 10:37 AM
  2. Replies: 5
    Last Post: 09-22-18, 06:20 PM
  3. Rotate Screen & Smart Case
    By yybenedb in forum BlackBerry KEY2
    Replies: 3
    Last Post: 07-29-18, 02:49 AM
  4. Weird auto-correction German and Swedish
    By speedycath in forum BlackBerry KEY2
    Replies: 1
    Last Post: 07-15-18, 02:12 AM
  5. Android Auto - Google Assistant
    By cb900f2 in forum BlackBerry Motion
    Replies: 2
    Last Post: 07-12-18, 01:03 PM
LINK TO POST COPIED TO CLIPBOARD