1. Vince42's Avatar
    I wanted to try to access my PRIV via ADB, but my device list is always empty. I searched for a lot of tutorials, downloaded all the files, tried every solution - still without success.

    The USB debugging is enabled, the drivers are loaded finde (according to device manager under Windows 10, 64 Bit).

    What am I missing? Is there a working tutorial on accessing the PRIV with ADB?
    02-05-18 12:00 PM
  2. ToniCipriani's Avatar
    Did you switch to File Transfer mode? There's also another toggle that enables it for Charging mode but it defaults to off.
    02-05-18 06:26 PM
  3. Vince42's Avatar
    I tried PTP and MTP and even "USB debugging while charging" - none of the scenarios showed anything in my device list. I do not want to install the whole Android Studio and I am quite sure that I am using the most current command line version of adb.
    02-05-18 06:42 PM
  4. Vince42's Avatar
    Any other ideas? I really would like to test the "reduce resolution in favour of battery life" setting on my Priv - but I am stuck.
    02-09-18 05:16 AM
  5. ToniCipriani's Avatar
    AFTER you enable MTP and ADB in Dev options, check Device Manager on Windows to make sure there are no unknown devices. Then try adb device again.
    02-09-18 10:26 AM
  6. Vince42's Avatar
    In order to make sure that I am using the most recent adb - could you point me to the download site with the most recent version? I read something about a 500kish vs a 800kish version of adb. And my attempts to download the most recent SDK always ended up in download offers for Android Studio, which I do not want to install.
    02-09-18 10:47 AM
  7. ToniCipriani's Avatar
    02-09-18 01:47 PM
  8. Vince42's Avatar
    The new download seemed to have done the trick - awesome! Thank you!
    02-09-18 06:21 PM
  9. kash2001's Avatar
    Hi everyone as the original poster I have no system devise manage errors the blackberry priv is detected without issue and I can access the hard disk without issue. Portable devices shows the Priv not MTP though.

    I have the latest XDA ADB files and blackberry drivers in place, as said no issue in device manager so I assume all good.

    Got ADB on the HD. and Cmd prompt in admin mode. But when I type adb devices I cannot see the priv, Ive tried loads of ways but this is the stumbling point, what else can I do. Can I do this via and android app simulating adb ? or has it got to be done via USB?

    Any thoughts and help very much appreciated.

    ATB
    01-30-19 09:15 AM

Similar Threads

  1. 9900: Favourite tasks/Perfect Device
    By RaybanRJ in forum BlackBerry Bold 9930/9900
    Replies: 118
    Last Post: 08-08-18, 11:55 AM
  2. Replies: 10
    Last Post: 04-16-18, 09:52 AM
  3. How do I change the device name on a US Motion?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-04-18, 01:57 PM
  4. Updated list of todos for new Keyone :)
    By Thalakar in forum BlackBerry KEYone
    Replies: 1
    Last Post: 02-03-18, 06:59 AM
  5. Replies: 1
    Last Post: 01-29-18, 03:55 AM
LINK TO POST COPIED TO CLIPBOARD