1. eljipe's Avatar
    Using the stock browser, I downloaded a zip file then opened it. Zipped files are correctly extracted, along with the directories structure.

    The problem is when files are unzipped with read-only attributes : I can't delete these files (nor directories containing read-only files, as expected).

    Has someone experienced the same problem ?

    A File manager able to perform an 'attrib/chmod' would be fine...


    - problem appears with zip file containing an hidden '.DS_Store' file (from Mac OS).
    - to reproduce the problem, download from playbook browser this free Moodyman album here : http://www.scionav.com/collection/947
    Last edited by eljipe; 04-19-12 at 06:24 AM.
    04-17-12 09:36 AM
  2. eljipe's Avatar
    Wow! I suspect my problem is not a worldwide interest subject
    I'm surprised no one had this problem before...
    Anyway...BB support was unable to solve my problem (if they understood it).
    The fact is the files I want to delete show the following properties (Windows XP):

    1000_Shared (Unix Group\1000_shared) : read only right.
    100141000 (Unix User\100141000) : read and write rights.
    Everybody : read only right.

    So, just before doing a security wipe, if someone has an idea how to solve my problem, thanks a lot !

    Edit: corrected groups rights.
    Last edited by eljipe; 04-24-12 at 08:13 AM.
    04-19-12 06:25 PM
  3. HybridGT's Avatar
    I had the same problem.
    Unfortunately yes, you must now security wipe.
    04-19-12 06:29 PM
  4. pauldriver's Avatar
    I too have this issue.
    04-19-12 11:23 PM
  5. FF22's Avatar
    You can't delete using usb or wifi sharing to access via Explorer? What if you reboot the pb - would it maybe free the files from something "reserving" them?
    04-20-12 05:40 PM
  6. jeroen_13's Avatar
    Try the Astro File Manager (android app)
    It gives you root acces too
    04-21-12 09:33 AM
  7. eljipe's Avatar
    @F2 : can't delete files after rebooting with Wifi file sharing.

    @jeroen_13 : Astro file manager didn't succeeded deleting files, as others file managers (what's more, with AFM files where not inititially displayed, had to figure out there was a Splitter sticked to the right of the screen )

    Anyway...tried via Cygwin, and here's the result of ls -l for the folder created when unzipping downloaded zip file:
    drwxrwxrwx 1 ???????? ???????? 0 16 avr. 15:51 Moodymann_Pictur
    Yes....strange user and group name, going to sub-dir :
    drwxr-xr-x 1 ???????? ???????? 0 10 avr. 22:20 ScionAV_Moodymann_PictureThis
    Going to sub-dir 'ScionAV_Moodymann_PictureThis' :
    $ ls -l -a
    total 109568
    drwxr-xr-x 1 ???????? ???????? 0 10 avr. 22:20 .
    drwxrwxrwx 1 ???????? ???????? 0 16 avr. 16:29 ..
    -rw-r--r-- 1 ???????? ???????? 12292 10 avr. 22:20 .DS_Store
    -rw-r--r-- 1 ???????? ???????? 20216400 10 avr. 22:19 01 9 Nites 2 Nowhere.mp3
    -rw-r--r-- 1 ???????? ???????? 10435108 10 avr. 22:19 02 Basement Party.mp3
    -rw-r--r-- 1 ???????? ???????? 10977416 10 avr. 22:19 03 Saturday at the Rock.mp3
    -rw-r--r-- 1 ???????? ???????? 10102825 10 avr. 22:19 04 U Ranaway.mp3
    -rw-r--r-- 1 ???????? ???????? 18680395 10 avr. 22:19 05 Pray 4 Love.mp3
    -rw-r--r-- 1 ???????? ???????? 9988934 10 avr. 22:19 06 Hold It Down.mp3
    -rw-r--r-- 1 ???????? ???????? 16307433 10 avr. 22:19 07 Got 2 Make It.mp3
    -rw-r--r-- 1 ???????? ???????? 11467472 10 avr. 22:19 08 Got 2 Make It (Dub).mp3
    Trying to delete of change file's permissions with chmod results in a 'permission denied' message.

    So a backup + security wipe seems to be the only solution...

    Thanks everybody!

    - backup'd all, security wipe, updated O.S. (BDS reports O.S. v1 bundle 0 !, disabling restoration ), finally Restore !

    - Problem fixed ! Able to delete these pesky files & directories.

    - Demo video and wallpapers lost (expected, were saved before) but also Bluetooth settings (NOT expected )
    and calendar data too !!!!
    Last edited by eljipe; 04-25-12 at 07:22 AM.
    04-24-12 08:04 AM
  8. EdY's Avatar
    Same problem here. The folder in question is only a 500KB in size, so I won't bother doing a security wipe. Too much work to bother, I will just lose the small amount of space for now and hope a fix comes up later.... Like hopefully when the BB10 update hits (see my commentary BELOW!)...

    For what it's worth.... (although I doubt anyone from RIM would ever read this post... ):

    Perhaps RIM could update the stock File Manager app on the Playbook to allow browsing through all user-related directories in the user accounts shared folder, rather than just showing "Pictures", "Videos", "Music" and Documents" all conglomerated together. Then give us permissions to delete folders which are not supposed to be part of the "stock Playbook" folder structure (including those with screwed-up permissions). How about it?

    Please RIM, improve the built-in File Manager, it is really bad. I mean really really bad. Even my BB phone File Manager app gives me better access to the directory and folder structure in my BB. That is one of the OVER-WHELMING features that Blackberry offers over iOS. For example, if I want to email or attach a "non-recognized file type" with any extension possible, I can do so in my BB phone by going through the directory structure and picking any file. However, with the Playbook email attachment or with File Manager.... NOTHING shows up unless it fits into that silly all-grouped-together Picture/Video/Music/Document folder.... I am basically STUCK accessing anything on the Playbook or emailing anything.

    I can tell you that if BB10 ends up not having a File Manager with access to the folder and directory structure and any file extension, like all the other BB phones up to now, you will have one very unhappy camper! If the BB10 File Manager looks like a Playbook File Manager, I will be sorely disappointed. It is one of the biggest strengths for business people who need to send and attach all sorts of obscure file types from their emails and access and organize it on their device. If BB10 groups everything into the horrible structure that Playbook does, and not let you see all folders and files (like previous existing BB phones) then it will be a huge FAIL.

    Please RIM, someone... anyone... please read this post or forward it to RIM.
    10-08-12 11:10 PM
  9. Herve5's Avatar
    FWIW, there are other android-ported applications that change file attributes in ways that you then cannot modify.
    One of them is PasswdSafe, which when editing locally a password file turns it into a kind of read/edit only, not preventing you to delete it but actually preventing any copy or transfer elsewhere. A nightmare before I found this (while at the same time PasswdSafe is the only mature open-source multiplatform password wallet on PB...)
    I discussed this issue with various persons, and I must say the dev from 'File and Folders' was quite reactive and understood the issue. At the time being he is working on it, while not sure PB OS will ever allow him to solve the issue...
    Clearly, there is a way for Android-originating applications to change file attributes in a way that native PB apps then cannot reach -which indeed is a burden.
    Maybe the next root trick will come through an android port

    Also, this means that serious 'unzippers' around here should consider upgrading attributes on-the-fly (instead of, presumably, just relying on the basic unix command) so as to solve the issue straight when creating the file.
    Speaking of which, it would be interesting to know which utilities you guys did use when unzipping. Indeed maybe there already is a peculiar file manager that solved it!

    [edit] in nov 2012: the unchanged PasswdSafe application now has its files handled just properly (I can copy them elsewhere, see them from the connected PC etc.)
    As I didn't update the app, I imagine that's because of the last OS update (now in; I may be wrong but that'll be the best I can say... You may want to try your ftp app again!
    Last edited by Herve5; 11-08-12 at 09:28 AM. Reason: no more trouble at least for the other apps that didn't work properly
    10-09-12 10:06 AM
  10. EdY's Avatar
    The unzip utility is actually part of the Playbook OS itself. When you tap on your ZIP attachment in Messages email app, it will unzip and create the folder in Downloads along with all the unzipped files.

    Funny enough, somewhere else on this forum I believe someone said if you save the ZIP and then use AirBrowser to unzip it will let you delete later.

    I can tell you that when I was checking my email and attachment showed up, I accidently must have clicked it and didn't have a chance to "refuse" unzipping... The native Playbook Messages email app just did it.

    This app therefore should be given rights to delete what it creates also, or at least make the native File Manager app more robust to allow you to at least clean up files made in your User/Shared folder created by your own native Messages app. Give us some power to rename files and move them into folders of our own choosing, and to select whether to display files by folder structure of media type (like it does now).

    The current native File Manager is very poor. The Air Browser should be standard and given higher permissions to let you manage files created by normal system apps you would use on a daily basis, in case you unzip or save something. I mean, you can't even attach a file of an unrecognized extension to an email on the Playbook. I can do that on my Blackberry phone!

    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    10-11-12 01:14 PM
  11. strange6ug's Avatar
    I used the BlackBerry Desktop Software to 'Restore' only the "Media" component of a pre-existing BlackBerry Backup archive to my PlayBook (after manually copying all of my PlayBook files--from 'books', 'camera', 'documents', 'downloads', etc.--to the P.C., first; a Desktop Software Backup would contain the offending directory, of course). This resolved the problem of the directory that could not be deleted (which was created after extracting files from a ZIP archive) by deleting (over-writing with the Backup archive) only my directories and files--not the "Application Data" or "[PlayBook] Settings." A much better 'work-around' than a Security Wipe, if you're seriously considering doing that (which I was, initially)! Attached is a ZIP archive (created by Windows Explorer) of the 6 KB "BBB" file that I successfully 'restored' to my PlayBook with the BlackBerry Desktop Software.
    Last edited by strange6ug; 12-25-14 at 08:49 AM. Reason: obsessive-compulsiveness
    12-24-14 11:42 PM
  12. DenKlomps's Avatar
    Interesting, I have a similar "bug" in my Passport download files on the device

    Posted via CB10
    12-26-14 11:15 AM
  13. skrble's Avatar
    Interesting, I have a similar "bug" in my Passport download files on the device

    Posted via CB10
    Have you managed to solve the problem? It appeared on my Q10 today as well.
    05-17-17 05:26 PM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.