02-15-13 12:55 PM
79 ... 234
  1. mattyturner's Avatar
    New to this hope I can get a fix. My mums playbook just stopped working and it seems dead. When I plug in the charger the led does not even come on or blink or anything. I get no indication that the playbook is taking a charge. When I hold down the power button the red light comes on then is replaced by 5 flashing amber lights then nothing. It would appear the battery is drained. Could it be the charger connector in the playbook is not connecting correctly to the prongs on the charger. I have used different chargers with my phone etc and also the pc usb which recognises the phone but not the playbook. Any advice would be great. Phoned pc world who gave a number for support and spoke to them and they have arranged to take it away and check it, however the playbook was only bought in January so I thought that pc world would deal with it under warranty. My mum doesnt want to lose all pics vids etc.
    11-01-12 04:20 AM
  2. EdY's Avatar
    THANKS!!!! You are a GENIUS!!!! Fixed using your "last resort" technique.

    Had this problem on a friend's Playbook.... So I didn't mind taking it apart :-)

    Did exactly what you said. "Spudged" it open with some plastic tools (plastic miniscrapers available at your local paint shop). Plugged into socket with the battery connector REMOVED, then plugged battery connector back.... all while it was still plugged in. Seems to be a bug in the chip on-board the battery. There are an awful lot of leads coming off that single battery connector and I suspect there is some serious "talking" going on between the main board and battery.

    I bet there is a flaw here that resets itself once the connection is disabled and re-enabled.

    Anyways, the thing booted IMMEDIATELY upon disconnecting/connecting the battery connector, and now on the main app icon screen, showing 8% battery. I'll leave it plugged in and won't use it so it can charge over-night.

    Definitely A GREAT TIP!!!!

    (Unfortunately, Not everyone will be comfortable "spudging" open their Playbook......Although I must admit, there is NO GLUE or double-sided tape so Kudos to RIM for at least making it easy to get inside the guts and out without any major problems).
    11-12-12 10:54 PM
  3. mdasent's Avatar
    So Ive tried the open PB method and get to charging icon which stays up for 15 secs after which if come off and i get a slow green led that last a second then the proceedure cycles. This happens with the battery connected and without is my PB definetly bricked because of a battery drain. I'm pro RIM but this would leave a sour taste in my mouth. Any other suggestions
    01-23-13 04:06 PM
  4. fabio984's Avatar
    im having this problem and i found this in the this topic:

    WOW, i tried EVERY SINGLE Step out there and the one step that worked ... was HOLDING down the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear.. the it will charge with just a flashing green..... lol wasted 4 hrs for nothing hope this works for everyone else "

    so the playbook is bliking yellow and i will leave it until somethinh happens!!
    02-15-13 12:55 PM
79 ... 234