Built for Business - Learn more about BlackBerry KEY2
11-04-13 08:04 PM
38 12
tools
  1. Graheem's Avatar
    I'm pretty savvy with my BB phone, but I am in a tough spot with my Playbook right now with several issues I can't seem to over come. I have read tons of stuff here, and elsewhere online, and tried it all, but so far I'm still stuck.

    I bought an 'open box' PB which I assume had been security wiped. When I was downloading some apps from appworld, somehow the appworld icon disappeared. Security wipe supposed to clear that up (nope, not for me) and original Wallpapers missing. From what I read, security wipes delete the wallpaper and any preloaded video. Ok, can live with that, and for appworld, I could still access by going to BB site from browser and clicking on appworld icon, that would put me into the appworld app (so app must be on the PB, but icon missing - yes, I have looked in all folders).

    I am running the latest beta OS, 2.1....840. This is my main stumbling block as I can't downgrade. I keep encountering the error message: An error has occurred while updating your device's software. Unspecified error encountered [A:0x000000A2]

    I could even live with this, but since I security wiped and restored, no Android apps work now!!! I have a collection of some pretty good working Android apps, but now they work no more. I have read that this is a result of security wipe! Man, if only I had read all this before doing any of these things.

    Sorry for long post, but my main question is...how can I get back to factory 2.0.xxx to try and start fresh and get my Androids apps back working???

    Thanks.
    Last edited by Graheem; 08-27-12 at 02:37 AM.
    08-26-12 12:27 PM
  2. TheScionicMan's Avatar
    The instructions for rolling back are on the same page where you signed up for the beta.
    08-26-12 12:36 PM
  3. Graheem's Avatar
    Yes, and it doesn't work.
    08-26-12 12:55 PM
  4. b1g1an's Avatar
    You can only roll back to 668 and as that's been removed and 358 is the latest, I guess that's why the debrick doesn't work. Just download cfp and a copy of 668 and do it manually, nuke, wipe and reinstall. Did it myself this afternoon and worked perfectly.
    Last edited by b1g1an; 08-26-12 at 06:21 PM.
    Graheem and DOCTOREVIL8 like this.
    08-26-12 04:34 PM
  5. Graheem's Avatar
    Thanks b1g1an. I will try to find both those items and give that a try.
    08-26-12 04:52 PM
  6. b1g1an's Avatar
    No worries, if you don't have any luck I'll dig out the links I used in the morning as it's bedtime over here
    08-26-12 06:23 PM
  7. Graheem's Avatar
    @ b1g1an - Thank you, thank you, thank you!!! I thought I was going to have to wait for an official 2.1 but your suggestion was right on the money. Now my 'open box' has been factory reset, and is back up to 2.1.0.840 with Appworld Icon, original Wallpapers, and Android sideloads working. Perfect. Thanks again!
    b1g1an likes this.
    08-27-12 02:25 AM
  8. jeroen_13's Avatar
    Debrick: Turn off PB
    Open Desktop Manager
    Plug-in PB
    There will be a message with; Corrupted OS -> Downgrade/Update-> 2.0.1.358

    It can take a while, but you'll get back the FULL OS with the Pictures and Movie !
    08-27-12 03:37 AM
  9. b1g1an's Avatar
    @ b1g1an - Thank you, thank you, thank you!!! I thought I was going to have to wait for an official 2.1 but your suggestion was right on the money. Now my 'open box' has been factory reset, and is back up to 2.1.0.840 with Appworld Icon, original Wallpapers, and Android sideloads working. Perfect. Thanks again!
    You're more than welcome, I'd been scratching my head for ages before I had one of those "I wonder if..." moments so pleased I could save you a bit of the stress.
    08-27-12 06:13 AM
  10. DOCTOREVIL8's Avatar
    I had the exact same problem. Security wipe while on 2.1.0.840 has been less then pleasant. Using 2.0.1.668 and Dingleberry to downgrade works too.
    08-27-12 07:52 AM
  11. HookerOne's Avatar
    b1g1an or Graheem could you please send me the links required to sort this out as I am suffering from exactly the same problem. Cheers.
    08-27-12 08:23 AM
  12. Graheem's Avatar
    HookerOne - I pm'd link to you.
    08-27-12 11:53 AM
  13. 715dixon's Avatar
    I would apprciate the links to get cfp and the 668 restore file also

    thanks in advance
    08-27-12 03:27 PM
  14. z3000w's Avatar
    Hi, I'm having the same issue as well. Could someone please PM me the links? Thanks!
    Last edited by z3000w; 08-27-12 at 10:46 PM.
    08-27-12 10:44 PM
  15. BB_Bmore's Avatar
    ME too man this stinks!!
    08-27-12 11:39 PM
  16. higgs_muc's Avatar
    Same situation here. Can you PM me as well?

    Another question: after the described procedure will I be back on .668 or is there another step to get back to current official .358?

    Thanks,
    Higgs
    08-28-12 06:56 AM
  17. bimboum's Avatar
    Hello

    I'm stuck with this OS . Could someone please PM me the links? Thanks! to downgrade.

    See you
    08-28-12 09:46 AM
  18. amnan.pahamin's Avatar
    im facing the same problem and ive tried almost every other thing for the past 3 days and none seems to work, b1g1an or Graheem could u pass me the link as well please..
    08-28-12 10:38 AM
  19. BB_Bmore's Avatar
    Guys I had the same problem and there is a great thread on using cfp in the PlayBook rooting section. I used it to wipe my PlayBook, flash an older version and then upgrade to an official version and all is well now
    08-28-12 10:52 AM
  20. corybullis's Avatar
    could someone PM me the links I am having the same issue with Android apps not working and am unable to downgrade. It would be greately appreciated. Thank you
    08-28-12 11:32 AM
  21. z3000w's Avatar
    Alright folks. After some poking and prodding around the forums here's the info to downgrade back to 2.0.1.668 from 2.1.0.840.

    This worked for me. Android apps are now functioning again, and the wallpapers are back.

    This may work for you, it may not. If it doesn't work, I can be of no help at all. I'm no expert, and take no responsibility if you mess up your device.

    That being said...

    Download 2.0.1.668 :

    http://cdn.fs.sl.blackberry.com/fs/q...873.signed.bar

    Once the download complete, need to change the file extention for your recently downloaded file - change the ".bar" at the end of the file's name to ".zip" (your new file should now be named "qcfm.image.com.qnx.coreos.qcfm.os.factory_sfi.des ktop.GR2_0_1.668.239873.signed.zip". Open your newly named ".zip" file in WinZip and extract "qcfm.image.com.qnx.coreos.qcfm.os.factory_sfi.des ktop.GR2_0_1.668.239873.signed" to your desktop.

    Download cfp. You can get it by looking around here :

    http://forums.crackberry.com/playboo...aybook-717974/

    Once downloaded, extract "cfp.exe" to your desktop.

    Do a security wipe on your PB. When it reboots, turn it off. Don't go though initial setup.

    Go to the Windows command prompt. (I'm using XP, so... Start menu - Run - then type "cmd").

    Type "cd desktop" and press enter.

    Type "cfp load qcfm.image.com.qnx.coreos.qcfm.os.factory_sfi.desk top.GR2_0_1.668.239873.signed" and press enter.

    It'll the say "Connecting to bootrom". Connect your Playbook to the computer.

    After that, the program should do the rest! All you'll have left to do is to redownload your apps from App World.

    Good luck.

    Edit : "desktop" in the file's name should be in one word. For some reason the forums here want it to be in two words...
    Last edited by z3000w; 08-28-12 at 09:05 PM.
    08-28-12 08:59 PM
  22. FF22's Avatar
    z3000w:

    Thanks for sharing that info. It could help some folks willing to try it. Just one question - about how long did the process take?
    Last edited by F2; 08-29-12 at 09:57 AM.
    08-29-12 09:46 AM
  23. HookerOne's Avatar
    I have follwed the instructions but I get the following message when I try to run cfp.

    "cfp is not a reconized as an internal or external command, operable program or batch file".

    Any ideas what I am doing wrong.
    08-29-12 10:58 AM
  24. z3000w's Avatar
    @F2 - It was relatively quick. Didn't time it but once the command is entered and the PB is updating, I'm pretty sure it took less than an hour.

    @HookerOne - As mentionned, I'm not an expert. The steps described worked for me, on my system. Didn't try on another computer or version of Windows. That being said, make sure you're logged in as Administrator on your PC, and make sure cfp.exe is on the desktop (not the .rar file, the actual .exe).
    08-29-12 12:38 PM
  25. DOCTOREVIL8's Avatar
    If you are having difficulties or concerns with the above method, I found Dingleberry to be much easier. Turn on Development mode on the Playbook. You can use the same 2.0.1.668 file as noted above, but you leave the file as is. Start Dingleberry so it creates a CUSTOM folder inside its Firmware folder. Place this file into the CUSTOM folder. Ensure your password is entered at the top of the Dingleberry window. And click on FIRMWARE. Select CUSTOM, then FULL OS and click on UPDATE. That's it!

    Note: Connect the Playbook to the PC and enter the password before starting Dingleberry. Windows may reject your password if Dingleberry is running.

    Sent from my BlackBerry 9900
    08-30-12 06:31 AM
38 12
LINK TO POST COPIED TO CLIPBOARD