Built for Business - Learn more about BlackBerry KEY2
07-10-15 02:10 AM
65 123
tools
  1. khat17's Avatar
    HIJACK!!! - well...........piggy back...........

    Trying to fix one for someone. Gonna post video of what's going on. Happens with both charger or dock. Charger is 1.8A and dock is 2A. Basically it gives red light - then battery icon - then amber light steady (not blinking) then nothing. If I leave it for a few mins after it starts to boot. Then the screen during booting gets a little brighter and it keeps loading. Then it just shuts off and doesn't come back on. Then if you unplug/replug it keeps doing that.

    Tried the stack charging method - maybe 10 times unplug/replug (an dock) and I notice that the back starts to get warm as if it's actually doing something. If I just leave it however it doesn't do anything to indicate charging.

    What I've tried so far is the stack method about 10 times. The holding the power button for 20-40 seconds then putting it on charge. Sprinkling it with Holy Water (just kidding).

    The video is uploading now - quality is kinda poor because of the lighting and I had to be tending to my kid at the same time.......so video with one hand.

    Thing I've noticed is that the charge light does not flash - it stays amber for a few seconds then goes out. I'm probably gonna have to look for the pinouts for this and connect direct power maybe........Don't want to do that just yet tho - so any other suggestions? Or has anyone seen this kind of issue before?

    Video ->
    Last edited by khat17; 06-12-14 at 10:15 PM.
    06-12-14 08:59 AM
  2. Gavinjon's Avatar
    lithuiums over heat easy after it gets under 3.45 volts so they put that on there so no fire or burned inside playbooks just got rapid charger keep you posted
    08-03-14 10:28 PM
  3. damianiw's Avatar
    Any luck I have exactly the same issue - I suspect faulty port or charger as I couldn't get the playbook to charge above 88 percent before coming on holiday then when plugged in watching movies it drained and now I'm stuck with the same issue posted above - tried stack charge for an hour and got to same position as you - tries to boot then black and dies :-(

    I'm using the 2amp charger which came with uk playbook would like to know how you got on with 5amp rapid charger



    Regards

    Damian
    08-11-14 02:32 AM
  4. damianiw's Avatar
    Well got it home and plugged it in, damn thing turned on ok but oddly shows zero percent charge and no charging lightning bolt, I've ordered the rapid charger so will see what happens

    Regards

    Damian
    08-19-14 04:18 PM
  5. damianiw's Avatar
    Rapid travel charger doesn't appear to solve it, still the same will try stack charging with the new charger now


    Sent from my iPhone using Tapatalk
    08-22-14 08:46 AM
  6. ceaser13's Avatar
    Thanks for the trick mate !!!!
    09-04-14 06:41 AM
  7. kram437's Avatar
    Is there any 10.3 auto loaders for the Z10 ??
    If yes where can I find it please

    Z10 ? loving it ??
    09-04-14 06:47 AM
  8. GougeUK's Avatar
    I have exactly the same problem. PB was actually sitting on a rapid charging stand for a couple of weeks and then would not switch on.

    Odd thing was this happened after a power cut but not sure if it is related.

    This fix doesn't seem to do anything and neither does stack charging.

    Did you get a solution?

    I did wonder if the rapid charging adapter might allow the usb connection to be connected to a PC at the same time so the PB would allow for debrick method when coinnected to PC. At present the PB will not switch on long enough for the PC to reinstall the software because it seems to not have enough charge.
    09-18-14 06:26 AM
  9. glamrlama's Avatar
    Method in the OP worked for me. Much thanks. Really this was the first hiccup with the hardware for me in almost 2 years. Never had a charging issue until today.
    09-23-14 12:14 PM
  10. bnortey's Avatar
    I give it my phone charger to give it initial power and then use its own charger. Works all the time.

    Posted via CB10
    09-30-14 12:59 PM
  11. Shilpa Iyer's Avatar
    Hi,

    I am facing the same problem that you are having with your playbook
    were u able to get a solution
    if yes, do let me know . thanks
    02-16-15 02:44 AM
  12. Wireless Gadget's Avatar
    Had my PB on 2amp magnetic charger all summer and now winter. It booted once or twice showed full battery but it would shut off and need step charge again. Giving up. Sound promising bit the effort and time spent. Get a new tablet. Sorry not BB bashing, just the facts. This PB is in my room as a paper weight.
    02-16-15 03:41 PM
  13. Prem WatsApp's Avatar
    Tried getting a new one installed?

    Hey, a few bux, might be worth it:

    http://rover.ebay.com/rover/1/711-53...item5b016d63ce

    :-D

      "Oh Classic, you are the fairest here so true. But Passport is a thousand times more powerful than you..." (no offense, Classic is a great device, when it's charged)  
    02-26-15 09:54 PM
  14. lycan666's Avatar
    Try this....

    HOLD the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear, after that the blinking green will appear and screen will go off.. now its charginggg..... lol wasted 4 hrs tyrign every other method, stack charging everything.... and this one worked for me...hope this works for everyone else
    after trying this , i get a steady red light , but after that i get 5 blinks of yelllowish green light and then again blank
    05-17-15 07:11 AM
  15. Kennedy Onjure's Avatar
    this did not work for me, still get the red light for about 10 seconds and then the amber for 3-5 seconds then nothing
    07-10-15 02:10 AM
65 123
LINK TO POST COPIED TO CLIPBOARD