Built for Business - Learn more about BlackBerry KEY2
  1. mr.interested's Avatar
    UPDATE:Solution at end of this post.

    Recently I had to delete my Gmail email account from my Playbook, since my Blackberry Playbook Mail app was giving me an error and would not load up, and all online advice stated to just delete all the email accounts and start from scratch. Deleting all my mail accounts fixed the issue; i could once again load up the mail app.

    Once the Mail app was working again, I was able to re-add all of my mail accounts, except my gmail.com one.

    Now when i try to add my gmail.com email account it tells me to check to see if my login info is correct, even though it is correct.

    After searching online i have found others that have said to generate a device specific password due to 2 step identification used by some google accounts. I confirmed that I do NOT have 2 step identification enabled on this gmail account so there is no way to generate a device password for the playbook.
    Also my gmail used to work fine before I deleted it.
    My old setup (before i deleted it) used m.google.com as the mail server.
    I tried to manually setup gmail using the same m.google.com server and it would not work. I also tried the following setup advice given by google as seen here for IMAP, and here for POP and it did not work

    TL;DR As of December 2014, what are the steps for me to add my Gmail account (emails only) to the mail app on my playbook?

    Thanks in advance for any help you can provide.

    UPDATE: I figured out the solution to my issue
    This is how i setup Gmail on my Playbook I will post step by step how i was able to get it working for me in case someone else is searching for the same info.

    Click on cog wheel in top right hand corner of your playbook screen.
    Click on accounts, then Add New Account.
    Select Email, Calandar and Contacts
    Type in your gmail email address, and password, DO NOT select continue.. instead select Advanced setup.

    OK here is the important part, do NOT select either Gmail, IMAP, or POP (those were my mistakes, i tried them all none work even using the details provided by google for each configuration).

    Instead select "Microsoft Exchange ActiveSync"

    in here make sure username is your full gmail email address.
    For server address enter m.google.com
    Leave the port at 443
    Leave Use SSL On
    Leave Push On

    Then choose if you want emails, contacts, calandar.

    That is all i did and now my gmail is working again.

    I did not need to do the Gmail captcha or "2 step verification" procedure.
    I also did not have to enable " Allow access for less secure apps" in my Gmail security settings.

    Email is working as it was before, with exact same m.google.com server i was using prior to deleting account.

    hope this helps someone else with the same problem.
    Last edited by mr.interested; 12-08-14 at 09:25 PM.
    mh1983 likes this.
    12-08-14 01:16 PM
  2. lforce's Avatar
    I've been having the same issue but it's only happening with 1 of my 3 Gmail accounts. If I'm able to isolate and fix the problem I'll let you know.
    12-08-14 02:24 PM
  3. fof9l's Avatar
    GMail has been really annoying lately, and in approximately July they instituted this 2-step sign-on process. All new accounts have it turned on by default, and it's not at all obvious how to turn it off. For existing accounts, it is not turned on by default, but they do bug you to turn it on every so often.

    From their FAQ, you may find this link useful:

    App passwords not working

    If you’ve double-checked to make sure you’ve entered the App Password in correctly but it’s still not working, try going to https://g.co/allowaccess on your device’s browser. Enter your username and password, then type the letters on the screen. Then go back to the application you're trying to access and enter your App Password.

    This takes you to a screen where, next time you log in, you use a CAPTCHA security device (I hate those!) but it seems that it will then let you set single-level security. Good luck.
    Leatherfacez10 likes this.
    12-08-14 06:39 PM
  4. mr.interested's Avatar
    Gmail was working fine on my playbook mail app prior to my having deleted all my email accounts a day or so ago. I have had my gmail on my PB for years.

    While i am positive that i do not have the 2 step verification enabled on this gmail account ( i verified it in my gmail security pages); I went ahead and tried out that page, and logged in with the blackberry webbrowser.
    at the end The google page said that my device was now authorized and that i should try to log in again in the app.

    My Playbook Email app however is still asking me to put in the correct password to log into the IMAP password for imap.gmail.com. So it still does not work.

    Thanks for trying to help.
    12-08-14 07:49 PM
  5. mr.interested's Avatar
    I finally figured out the proper way to get my gmail working again.
    I will update the OP with the solution.
    12-08-14 08:27 PM
  6. Nirmal Sharma1's Avatar
    Thank you very much. problem solved. great help.
    08-06-16 04:34 AM

Similar Threads

  1. Android apps not loading
    By brian4591 in forum BlackBerry Passport
    Replies: 8
    Last Post: 02-10-15, 11:51 PM
  2. Z30 users can you help me with this...?
    By cen89 in forum BlackBerry Z30
    Replies: 37
    Last Post: 12-11-14, 03:24 PM
  3. How do I answer an in coming call on my new Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 12-09-14, 05:24 AM
  4. On my Q10, why can't I turn the sound back on?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 12-08-14, 03:00 PM
  5. 3 Channels for the Geek at heart
    By joEyD90 in forum Discover BBM Channels
    Replies: 2
    Last Post: 12-08-14, 01:01 PM