1. rocketman3010's Avatar
    Hi all,

    I recently let my playbook go dead for some unknown reason (i'm am a total fool!) after not being able to charge it I read up on the forums and learnt vaguely about playbooks and their dead battery problems. I tried stack charging and that started to work but after 2 or 3 tries, the LED stopped coming on and now it does nothing. I've left it on overnight with the mains charger and nothing works. Also, my PC cant see the playbook, it could before the LED stopped, but now, nothing....

    Thanks in advance
    Last edited by rocketman3010; 07-30-12 at 06:31 PM.
    07-30-12 06:27 PM
  2. FF22's Avatar
    Good luck: First, more stack charing info and if that fails contact info for rim:

    Go into a dark closet and make sure it is really off - black screen with no backlighting.

    I was told about "stack" charging, 6 cycles of charge no charge, for 2 minutes each, charging for never more than 2 minutes.


    Plug the PB in with the factory charging cable (red light comes on for a several seconds, then goes off). Wait about 10 more seconds. Unplug PB for about 30 seconds.

    Repeat n times.

    n == 6 for me. Finally my PB light switched to green, then began to oscillate, signalling charging. After a few more minutes my PB came back to life.

    You might want to UNplug/Replug at the wall/socket end to avoid using or damaging the weaker usb port on the pb itself.


    Just talked to tech support, because i'm impatient sometimes. Here is the initial process they gave me to try.

    Plug in the charger for 2 mins, unplug for 10 sec -> Repeat 6 to 8 times

    Then while unplugged perform the Hard reset (POWER, VOL + and - at the same time) . **When the red light comes on PLUG IN THE CHARGER**

    The playbook is supposed to then start charging/boot.
    ...........................

    Some have now found a shorter sequence works:

    Oh man I fixed it. I stack charged it! But not for 2 minutes.

    Every time my PB red signal goes off I removed the connection from the wall charger and placed it back within a second. I repeated it for almost 25-30 times and all in the sudden a big charger button showed up on the screen and a green light on the charging LED. I left th e power connection for 2 more hrs and started using it.
    ................
    And another posting that might help....

    There are a few solutions and some are mentioned above. SO try the things I am mentioning below.... Let me know if it works .

    Problem Scenario: 1. Blackberry wont boot or turn on, on pressing the power button, the red light stays for a few seconds and does not turn on 2. Sometimes you will see the red light followed by a green/ yellow light that blinks 5 times and does not turn on.

    Reason: The main reason why both of the above things happen is because the battery is completely drained out, you could call it " Flat out". The problem with playbook is that the playbook wont charge if the playbook is Flat out drained. whereas other tablets or cellphones does....Playbook has to fix that issue. Meanwhile we do have a solution to go around that problem and that requires some patience. Some of the solutions mentioned in the previous comments indicate to charge it via computer.... "It doesn`t work" not if the battery is drained out flat.... so dont even bother trying it if u see the above mentioned problem.

    Solution: try this step by step and this are 3 different solutions so one of this would definitely work. 1. Press the Power button and you will see the Playbook Logo ( chances for this are low ) 2. Press the power button and the volume together, if there is 1 % charge left there is a chance that it would boot on, when you see the logo, immediately charge the playbook ( chances are medium ) 3. This solution requires patience. plug the charger into the socket and plug the USB into the playbook, the red light stays for 8-10 secs. Remove the USb from the playbook wait for 2 to 5 sec and replug the usb back to the charger and wait till that red light comes and goes again. repeat this step atleast 20-30 times. you might be asking why? the only power that the playbook gets is when that red light is on when plugging the usb into the playbook, once that light goes the playbook is not charging.. so what you are doing here is forcing the playbook to get charged for 8 sec every time u plug it to the playbook....this way the playbook gets that power needed to boot. Once the Playbook has that power to boot. The red light stays and changes to green but this time it blinks slowly and keeps blinking. you would also see the playbook logo return.... this green light keeps blinking until there is enough charge for the playbook to stand on its own and then changes to a solid red until it gets fully charged.

    Knowledge Base Article

    KB27705-BlackBerry PlayBook Power - Battery charge and discharge characteristics


    The PB has a one year warranty to the original purchaser. It also has 90 free Tech support. I do not know how Rim deals with "quasi-tech support v. warranty"

    Rim Support
    Tel:
    Canada Toll Free: 1-877-644-8405
    United States Toll Free: 1-877-644-8410
    Puerto Rico Toll Free: 1-855-651-4936
    Email: playbooksupport@blackberry.com (this route generally does not work and a call is necessary)

    (UK Support) 0800 096 2805

    Playbook French Support
    http://fr.blackberry.com/playbook-ta...ok-support.jsp
    Phone : 0800 914 533 (within 90 days from activation)
    AliasCBG likes this.
    07-30-12 08:39 PM
  3. reinkarnation's Avatar
    Try this....
    HOLD the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear..... lol wasted 4 hrs tyrign every other method stack charging and this one worked for me...hope this works for everyone else
    07-30-12 11:09 PM
  4. benvent's Avatar
    I too am in the same boat. Updated to .688 on Thurs and today am the proud owner of a paperweight. Thanks for all of the input boys. I have tried everything that I have read thus far. No dice. I don't even get a red light anymore when trying to stack charge. I have a call into BB Support. Will see if they come up with something.
    08-04-12 04:45 PM
  5. fabfreddie's Avatar
    I had this problem last week with my daughter's tablet, it is not a .668 problem, it is a Playbook problem, .668 makes it worse cause your battery runs out just cause you looked at it.

    The solution is very simple but time consuming and very annoying.

    You have to literally plug and unplug it lots of times, I say lots of times because there is no fixed number to it.

    Here's what you need to be aware of, it is so dead the OS does not have enough juice to recognize it's plugged in, so what you need to do is plug it in, when you see the red light, THAT IS THE ONLY CHARGE IT'S GETTING, when the light goes out, it's not charging, so unplug and repeat the process over and over again, you will start to notice the red light stays on a lil longer.

    Do this stupidity until the battery with lightning bold comes on the center of your screen, once it does, leave it plugged in, eventually when it has enough juice the PB will fire up on it's own.

    It took me about 40 minutes of plugging and unplugging.
    benvent likes this.
    08-04-12 05:00 PM
  6. benvent's Avatar
    Thanks fabfreddie. But the light doesn't even come on anymore. Been at it for 3 hours
    08-04-12 05:31 PM
  7. fabfreddie's Avatar
    Check the charger, make sure it works, plug it into your handset and see if it charges that.
    08-04-12 05:34 PM
  8. kbz1960's Avatar
    Flip the blades a few time on the plug end too. Easier if you use a power strip and the button on it to turn on off / plug unplug. Saves a lot of wear and tear.
    08-04-12 05:45 PM
  9. benvent's Avatar
    My unit has been RMA'd. Just got off the phone with tech support. They couldn't really help me. You guys on here are more helpful! Thanks again.

    Guess I just lost all of my pictures, music, etc that was on there that I hadn't backed up Oh well.....live and learn.
    08-05-12 11:14 AM
  10. benvent's Avatar
    Got my tablet back today! Or so I thought. Let me start off by saying....I am really impressed with the turnaround from RIM. Sent it away on Tues and got it back this morning.

    However, I am really not impressed with what transpired after that.

    Seems I got a different Playbook than the one I sent in. Livid now. How do I know what condition it's in and my screen protector is gone?? So I call technical support. Hoping to get someone to understand that they should extend the hardware warranty starting today for 1 year and to send me a new screen protector. No dice. Spoke with 2 supervisors and they said they couldn't give me that. Well, I guess you are supposed to take your screen protector off and try to re-use it

    Anyway, I am not happy. Lost all of my pictures, videos, and music. Not to mention, I have to do the software update to 2.0.1.

    Unfortunately, this incident has totally turned me off of RIM. I am a good old Canadian boy who wants to see companies like RIM succeed. However, its things like this that cause people to change loyalties.

    Do you think RIM should try and help someone out when this happens? All that it would have taken was a lousy screen protector to put a little smile back on my face and not write this post and make me think not to buy another RIM product again. And I said this to the 2 supervisors. Too bad.
    08-10-12 12:55 PM
  11. pkcable's Avatar
    You should not have lost anything, just load your latest backup from Desktop Manager. Ok let me guess, you never bothered to backup.
    08-10-12 01:12 PM
  12. benvent's Avatar
    Not before I did the update. I have some stuff, but not everything unfortunately. But how does that give me back my screen protector ?
    08-10-12 01:29 PM
  13. FF22's Avatar
    I don't recall the packing instructions for shipping it back to them but I think they do not promise to return it with the same files when it was shipped. I got a replacment pb and so it was fairly naked. But since I was a bit concerned about my data, I wiped it before shipping it to them anyway. I don't recall if Screen protectors were mentioned in the literature but I did remove mine.
    08-10-12 05:40 PM
  14. epsilon3's Avatar
    I have the same issues as rocketman3010.

    I called RIM Support and they easily gave me an RMA. They will send me a return envelope to ship it back to them for repair-replacement.
    I will ship the Playbook Monday ans came back with what happened further.
    09-14-12 02:01 PM
  15. Huntaway's Avatar
    Thank you very much reincarnation. Your solution worked first time.

    “HOLD the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear”

    And it did.
    Last edited by Huntaway; 04-24-13 at 04:18 AM. Reason: incompetence
    04-24-13 03:51 AM
  16. Thomas Brown2's Avatar
    reinkarnation CrackBerry User Posts:22 Posts

    07-30-2012, 10:09 PM #3

    Try this....
    HOLD the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear..... lol wasted 4 hrs tyrign every other method stack charging and this one worked for me...hope this works for everyone else

    Unbelievable. reinkarnation has 22 posts and this one July 30 last year.

    CASE STUDY # 2 reinkarnation has 2 who successfully accomplished duplicating his feat.

    I also spent 3 days with no luck. PlayBook has no use whatsoever. So, May 2012, I quit using it and decided it was best for the battery to let it just use itself up. Batteries last longer like that folks. So, now almost May 2013 today 27 April. I plugged it in and nothing.

    Several days of plugging and unplugging. Nothing. At one point of plugging and unplugging, I had seen the red light stay on on being plugged-in for 28 seconds.

    I nearly had it then.

    I think.

    Then, I kept reading all these suggestions and kept trying every posters comments and, it went out. Plug in, get nothing.

    One poster explained here at the end, that it only charges when the red light is on. Therefore, I was getting 28 seconds of charge.

    Then, I used that up, trying these other methods.

    Not used a year.

    I have a dead battery, fully drained. Totally.

    Even after now 3 days of plugging and unplugging. When it had gone up from 8 seconds red light to 28 seconds. I was getting somewhere.

    If I had just spent another 7 days, it might have charged for 35 seconds at a time.

    But, it is still green while I continue to type.

    What did I do ?

    I tried a combination of every idea here.

    I plugged and unplugged AC and sometimes a flicker for a nanosecond and sometimes nothing.

    Desperate now, and know I had wasted 2 days worth of plugging and unplugging to where I knew I had used up all that I stored in the battery.

    Only then, did I try reinkarnations solution. I pressed all 3 together, reset with left hand, and volume up and down with 2 digits on right hand.

    That got me nowhere, but is in my opinion what ruined it. Used up my battery. Now nothing when I plugged-in.

    (1) reinkarnation said press only the reset, hold down with finger for 20 seconds, then plug in. I did that several times forgetting to instantaneously let go of reset when I plugged-in. Pat your head, rub your belly.

    # 1 restated :

    Press Reset
    Hold Reset in with right index finger
    Hold 20 seconds

    Pressing PlayBook to your belly with right hand sorta wrapped around it, holding reset button in for 20 seconds, take your left hand and plug in the plug remembering to at that exact moment let go of the Reset Button with your Right Hand, while not letting the PlayBook fall out of your right hand.

    Worse than Pat your head, rub your belly.

    Each time, I looked at the red light.

    Finally I hit it.

    Red Light came on and went away, and then a few seconds later

    LIGHTNING BOLT.

    When you see that, you got it.

    Green Light is pulsating on and off fading away now and then back bright green.

    Screen is blank now. So I have no idea how long this will take. But I aint touching it. It can stay there 3 days.

    Been a year. Whats 3 days, eh ?
    04-27-13 05:11 AM
  17. IslandGuy's Avatar
    Genius! The 20 second power button just worked for me. I was in a panic here for a few hours because unlike others I had no signs of life (red light) from my playbook. I thought it was completely gone. Now charging with pulsing green light.
    FF22 likes this.
    06-10-13 08:15 AM
  18. AmesBuns's Avatar
    Thank you SO much for this. I tried everything I could find on this forum when my new Priv powered off and died. Nothing worked until this. Thank you!
    01-13-16 08:55 AM
LINK TO POST COPIED TO CLIPBOARD