1. hreiner1's Avatar
    go to accounts
    add new account
    use advanced set up
    and follow instructions below
    it took me less than 3 minutes


    Yahoo POP3 and SMTP Settings:

    Find below the basic POP3 settings for configuring any email program where you want to receive Yahoo mails.
    ■ POP3 Server Set the POP server for incoming mails as pop.mail.yahoo.com. You will have to enable SSL and use 995 for Port.
    ■ SMTP Server Set the SMTP server for outgoing mails as smtp.mail.yahoo.com. You will also have to make sure that SSL is enabled and use 465 for port. you must also enable authentication for this to work.
    ■ Account Name or Login Name Your Yahoo Mail ID i.e. your email address without the domain @yahoo.com.
    ■ Email Address Your Yahoo Mail address i.e. your email address including the domain @yahoo.com. E.g. myname@yahoo.com
    ■ Password Your Yahoo Mail password.

    Yahoo! Mail Plus users may have to set POP server as plus.pop.mail.yahoo.com and SMTP server as plus.smtp.mail.yahoo.com.

    Note that you need to enable Web & POP Access in your Yahoo Mail account to send and receive Yahoo Mail messages through any other email program.


    You will have to enable Allow your Yahoo Mail to be POPed under POP and Forwarding, to send and receive Yahoo mails through any other email client.
    02-22-12 06:44 AM
  2. JasW's Avatar
    go to accounts
    add new account
    use advanced set up
    and follow instructions below
    it took me less than 3 minutes


    Yahoo POP3 and SMTP Settings:

    Find below the basic POP3 settings for configuring any email program where you want to receive Yahoo mails.
    ■ POP3 Server Set the POP server for incoming mails as pop.mail.yahoo.com. You will have to enable SSL and use 995 for Port.
    ■ SMTP Server Set the SMTP server for outgoing mails as smtp.mail.yahoo.com. You will also have to make sure that SSL is enabled and use 465 for port. you must also enable authentication for this to work.
    ■ Account Name or Login Name Your Yahoo Mail ID i.e. your email address without the domain @yahoo.com.
    ■ Email Address Your Yahoo Mail address i.e. your email address including the domain @yahoo.com. E.g. myname@yahoo.com
    ■ Password Your Yahoo Mail password.

    Yahoo! Mail Plus users may have to set POP server as plus.pop.mail.yahoo.com and SMTP server as plus.smtp.mail.yahoo.com.

    Note that you need to enable Web & POP Access in your Yahoo Mail account to send and receive Yahoo Mail messages through any other email program.


    You will have to enable Allow your Yahoo Mail to be POPed under POP and Forwarding, to send and receive Yahoo mails through any other email client.
    Thanks, but it's completely hit or miss with Yahoo accounts no matter if you insist that your instructions worked for you. Others have similarly insisted their method is the way with Yahoo -- and I should note that a couple of them indicated that the incoming server should be imap, not pop.

    I have six Yahoo-based accounts -- two plain yahoo.com, two att.net, one bellsouth.net, and my primary personal email, which comes with the domain and website hosting I have with Yahoo.

    I have had nothing but problems over the past 24 hours trying to get these accounts on my PB, no matter whose instructions I follow.

    I was finally able to get three of them on my PB last night (two imap, one pop), doing nothing different than I had done earlier in the day. Others have reported the same -- they try different servers (imap or pop), different ports, etc. -- and finally one of them clicks even though they had tried the precise same settings several times previously.

    Also, I notice that two of the Yahoo-based accounts I was able to get going last night are now showing as "not connected" right now (I am bridged, not on wifi as I was last night). My Gmail and Hotmail accounts, and my primary personal accounts show no problems.

    This is a joke, frankly. I'm a tech head, and it's painfully obvious this is a problem with the PB and not Yahoo. How RIM can expect the average joe to put up with this kind of crap is beyond me.
    02-22-12 07:10 AM
  3. asianguy80's Avatar
    For some reason when I tried setting up 2 -Yahoo's and 1 sbcglobal.net they were not working. I added my own personal yahoo and it worked but 2 other's weren't.

    I googled smtp yahoo and came up with this website:

    Incoming and Outgoing Mail Server Settings for Hotmail, Yahoo, Google GMail, AOL, MSN and more

    Anyways, I edited the advanced settings for the incoming to "imap.mail.yahoo.com" and now they magically started working along with the settings in the OP. Go figure. Maybe RIM fixed the problem just now but over the last 2 days I couldn't get any of those three e-mails to add but now they work just fine with the right settings. Must be hit or miss sometimes. Hopefully it gets working soon for everybody.
    02-23-12 06:47 PM
  4. Michel Souris's Avatar
    Do you get your IMAP sub folders?
    02-23-12 07:33 PM
  5. asianguy80's Avatar
    Unfortunately, no. All you get is the standard inbox, draft, sent folders.
    02-24-12 12:56 AM
  6. bounce007's Avatar
    Thanks, but it's completely hit or miss with Yahoo accounts no matter if you insist that your instructions worked for you. Others have similarly insisted their method is the way with Yahoo -- and I should note that a couple of them indicated that the incoming server should be imap, not pop.

    I have six Yahoo-based accounts -- two plain yahoo.com, two att.net, one bellsouth.net, and my primary personal email, which comes with the domain and website hosting I have with Yahoo.

    I have had nothing but problems over the past 24 hours trying to get these accounts on my PB, no matter whose instructions I follow.

    I was finally able to get three of them on my PB last night (two imap, one pop), doing nothing different than I had done earlier in the day. Others have reported the same -- they try different servers (imap or pop), different ports, etc. -- and finally one of them clicks even though they had tried the precise same settings several times previously.

    Also, I notice that two of the Yahoo-based accounts I was able to get going last night are now showing as "not connected" right now (I am bridged, not on wifi as I was last night). My Gmail and Hotmail accounts, and my primary personal accounts show no problems.

    This is a joke, frankly. I'm a tech head, and it's painfully obvious this is a problem with the PB and not Yahoo. How RIM can expect the average joe to put up with this kind of crap is beyond me.
    Yup, hit or miss with Yahoo. It's annoying really so after several hours of trying to get it working flawlessly I just decided to do without Yahoo on my PB. It comes to my handset and Outlook already, so I don't necessarily NEED it on my PB (though it would be nice)
    02-24-12 01:04 AM
  7. JasW's Avatar
    Yup, hit or miss with Yahoo. It's annoying really so after several hours of trying to get it working flawlessly I just decided to do without Yahoo on my PB. It comes to my handset and Outlook already, so I don't necessarily NEED it on my PB (though it would be nice)
    You had said in the other, longer Yahoo email thread that your Yahoo account was working while bridged. Are you sure about that? RIM has now said that IMAP/POP accounts (e.g., Yahoo-based accounts) will only work when connected to wifi, and not when bridged. (Gmail and Hotmail use ActiveSync, so they work whether bridged or on wifi.)
    02-24-12 06:07 AM
  8. bounce007's Avatar
    Let me check right now... Will update in 5 minutes

    UPDATE 1: I was able to receive messages while bridged (no wifi) through Yahoo (native email client) but I was not able to send... This beats me. I am still getting the enter "IMAP password for Yahoo" though. I'm gonna delete the Yahoo account then add it back

    UPDATE 2: Ok after I deleted the Yahoo email address and restarting my PlayBook and then adding the Yahoo address back, it no longer works via bridge

    Dude I really don't know what was happening. I was using regular IMAP settings.
    Last edited by bounce007; 02-24-12 at 08:21 AM.
    02-24-12 08:01 AM
  9. ricket79's Avatar
    Yahoo was working fine for me at home on wifi... At work on bridge and keep getting server errors, so my guess is that it is only supported via wifi.
    02-24-12 08:09 AM
  10. JasW's Avatar
    Let me check right now... Will update in 5 minutes

    UPDATE: I was able to receive messages while bridged (no wifi) through Yahoo (native email client) but I was not able to send... This beats me. I am still getting the enter "IMAP password for Yahoo" though. I'm gonna delete the Yahoo account then add it back
    That's bizarre that it can even receive in the native app while bridged. What are your IMAP settings? Simply imap.mail.yahoo.com?
    02-24-12 08:17 AM
  11. bounce007's Avatar
    That's bizarre that it can even receive in the native app while bridged. What are your IMAP settings? Simply imap.mail.yahoo.com?
    I updated my previous post. Check it out.
    I replied to the longer thread as well, didn't realize I was talking to you in both these threads lol
    02-24-12 08:22 AM
  12. bounce007's Avatar
    I don't get it. When you go into Settings (the gear symbol at the top) > Accounts, what does it say next to your Yahoo account? Does it say Email (or Email, Calendar, Contacts), or does it say Not Connected?
    *the quote above is from a different thread*

    JasW it's cool you can talk plain tech language with me, not a noob to these things lol (re: the gear symbol at the top)

    When bridged, all 3 accounts (1 yahoo and 2 gmail) say "not connected", and funny enough I got a an email (in gmail) through the native email client that said you posted in a thread, which means that the gmail addresses are connected. So I don't know why they say they are not connected and I am able to send and receive emails. The Yahoo one does not work at all now, since I deleted it, rebooted and re-added it.
    02-24-12 08:38 AM
  13. JasW's Avatar
    *the quote above is from a different thread*

    JasW it's cool you can talk plain tech language with me, not a noob to these things lol (re: the gear symbol at the top)

    When bridged, all 3 accounts (1 yahoo and 2 gmail) say "not connected", and funny enough I got a an email (in gmail) through the native email client that said you posted in a thread, which means that the gmail addresses are connected. So I don't know why they say they are not connected and I am able to send and receive emails. The Yahoo one does not work at all now, since I deleted it, rebooted and re-added it.
    Sorry, no offense -- there have been a lot of noobs lately, particularly in this forum, so it's no longer safe to presume one is talking to a fellow techie.

    In any event, Yahoo not working at all makes more sense. I remember that on the morning after adding a paid Yahoo account the night before on wifi, that account was showing up as connected even though I was only bridged. (I think I even posted as much earlier in this thread, knowing less than I know now.) It then switched to showing up as not connected a short while later, though, and it's remained that way any time I am bridged. I can only guess that the Account page hadn't completely refreshed itself.

    I don't get your gmail problem at all -- it should always show as being connected when you're on wifi or bridged, obviously. It might be the possible refresh thing I alluded to above, but that's only wild speculation.
    02-24-12 08:49 AM
  14. bounce007's Avatar
    Sorry, no offense -- there have been a lot of noobs lately, particularly in this forum, so it's no longer safe to presume one is talking to a fellow techie.

    In any event, Yahoo not working at all makes more sense. I remember that on the morning after adding a paid Yahoo account the night before on wifi, that account was showing up as connected even though I was only bridged. (I think I even posted as much earlier in this thread, knowing less than I know now.) It then switched to showing up as not connected a short while later, though, and it's remained that way any time I am bridged. I can only guess that the Account page hadn't completely refreshed itself.

    I don't get your gmail problem at all -- it should always show as being connected when you're on wifi or bridged, obviously. It might be the possible refresh thing I alluded to above, but that's only wild speculation.
    It's cool no offence taken. Totally understand. I am inclined to believe that the Gmail emails showing up as "not connected" is a matter of not being refreshed: I just turned on my Wifi and turned it off and they all are showing up as connected.... waited a few minutes, checked back, and the Yahoo one says not connected while the others are.

    This POP/IMAP incompatibility sucks but we (blackberry handset users) don't necessarily NEED it, as most of us have our emails set up on our phones. For the users of other handsets, I'm sure many have email on their devices. It's just the few who don't have access to their email via their handsets that might grumble and rant a bit.

    Case closed until RIM fixes this?
    02-24-12 09:05 AM
  15. mas_quemex's Avatar
    I have the following settings Z3 :
    pop.mail.yahoo.com (995)
    smtp.mail.outlook.com (465)

    It works.
    09-23-15 11:58 PM
LINK TO POST COPIED TO CLIPBOARD