1. jghellion's Avatar
    Hello all,

    Since the 2.0 update this morning I can't connect to the my company wifi, I've been using it everyday for months but today when I try to connect, the playbook bypasses the authentication page where I would log in my credentials and goes to http://blackberry.com/select/wifiloginsuccess/en/

    My BB Torch on the other hand connects fine. Did something change in the update? Maybe a setting I'm unaware of?

    Thanks in advance for any help.
    02-21-12 01:04 PM
  2. mike-berry's Avatar
    I seem to have the same problem. it worked before the update.

    Sent from my BlackBerry Runtime for Android Apps using Tapatalk
    02-21-12 01:19 PM
  3. Manic99's Avatar
    Had the same issue - rebooted both PB and phone. All is well now. Try a battery pull with phone. Hope it goes well for you.
    02-21-12 01:22 PM
  4. jghellion's Avatar
    I've already tried several reboots but still get the same results. (insanity?)

    Thanks for the input though.
    02-21-12 01:38 PM
  5. adrenaline_x's Avatar
    Delete the wireless profile. Restart. Re-setup wifi
    02-21-12 01:40 PM
  6. ptoombs's Avatar
    Try changing your security settings from WPA2 to WPA.
    02-21-12 01:45 PM
  7. jghellion's Avatar
    Thanks guys,

    The profile is not saved, it gets disabled every time it try's to connect and fails so it's always a clean start.

    The security setting is set to open.
    02-21-12 03:26 PM
  8. mike-berry's Avatar
    Thanks guys,

    The profile is not saved, it gets disabled every time it try's to connect and fails so it's always a clean start.

    The security setting is set to open.
    exactly the same problem.


    Sent from my BlackBerry Runtime for Android Apps using Tapatalk
    02-21-12 03:34 PM
  9. Thunderbuck's Avatar
    Funny... the PB should be picking up the profiles from the phone, if you've got them bridged.

    Don't know if you were migrating from 1.x or one of the 2.0 Developer Previews, but the WiFi stack DEFINITELY changed in the last Preview. Changed for the better, definitely, but it might have affected this specific connection.
    02-21-12 03:37 PM
  10. jghellion's Avatar
    I upgraded from the standard 1.x. I haven't tried it home yet, I hope I don't run into the same issue there too.
    02-21-12 03:57 PM
  11. jghellion's Avatar
    Ok gentlemen I got it working and as a tech with about 15 years under my belt I'm embarrassed to say that the fix was a lot easier than anything I was shooting for. lol

    Just as a desperate resort I turned off all the wireless connections on the BB Torch and tried it again and it connected right away. I'm not sure why this makes a difference but it was automatic after that. I haven't turned the phone back on because the Playbook is updating several email accounts but when it does I'll post what I find.
    02-21-12 04:24 PM
  12. kill_9's Avatar
    Ok gentlemen I got it working and as a tech with about 15 years under my belt I'm embarrassed to say that the fix was a lot easier than anything I was shooting for. lol
    Don't feel too bad. Sometimes the simplest and easiest fixes are not the most obvious or seem too easy to be the reason for the problem. I dare say everyone with a technical background eventually encounters a similar situation. Hindsight is always 20-20. Enjoy the Blackberry PlayBook!
    02-21-12 04:32 PM
  13. mike-berry's Avatar
    I upgraded from the standard 1.x. I haven't tried it home yet, I hope I don't run into the same issue there too.

    It won't. The thing I think is happening is the playbook is trying to pull data as a normal connection when its a hotspot. It defiantly doesn't happen to me when I am at home.

    Sent via Tapatalk(Bold 9900)
    02-21-12 05:13 PM
  14. jghellion's Avatar
    Your abosutely right mike-berry! It connected at home right away without a hicup! Tomorrow I'll try it again with the phone on at work and post the final result.
    02-21-12 06:07 PM
  15. jghellion's Avatar
    So back at work the problem persists. If I log on to the company wifi with my phone first, the playbook will bypass the authentication screen and jump to blackberry page that says your connected. (But doesn't actually connect.)

    So I tried turning the wifi off on the phone and trying to log on with the Playbook, that works! I then turned wifi on, on the phone and logged onto the company wifi. The phone connected and the playbook seems to be holding it's connection too.

    For whatever reason, if the phone is logged on first, the Playbook wont connect but if you connect the Playbook first there are no issues.

    Any opinions as to what might cause this?
    WeekendRacerx likes this.
    02-22-12 10:18 AM
  16. mike-berry's Avatar
    Its the the bridge browser. it pulls the data from the phone before the wifi connection. so since its connected on your phone it is pulling the data from the phone hence the logged in successful.

    Sent from my BlackBerry Runtime for Android Apps using Tapatalk
    02-22-12 11:56 AM
  17. jghellion's Avatar
    That sounds plausible. Not a major issue but it wasn't a concern prior to 2.0. I just have to remember to log my Playbook in first. Thanks Mike.
    02-22-12 01:38 PM
  18. WeekendRacerx's Avatar
    So back at work the problem persists. If I log on to the company wifi with my phone first, the playbook will bypass the authentication screen and jump to blackberry page that says your connected. (But doesn't actually connect.)

    So I tried turning the wifi off on the phone and trying to log on with the Playbook, that works! I then turned wifi on, on the phone and logged onto the company wifi. The phone connected and the playbook seems to be holding it's connection too.

    For whatever reason, if the phone is logged on first, the Playbook wont connect but if you connect the Playbook first there are no issues.
    6 months of solid usage with Bold 9930 and Playbook, suddenly after latest mild updates to BOTH OS...my Playbook becomes picky about networks it will allow connection to. It sees them just fine, but if my Bold 9930 wifi is on and connects first the Playbook will simply recognize the saved wifi location and display a red message that it will not connect. Followed the above advice, turned off my Bold 9930 connection then the told my Playbook to search again and waaalaaa! now all is right with the world Playbook has connection. Turn on the wifi on Bold and waaalaa! both are connected. Great that this works but shame on BB for adding such a particular bug to our seamless tablet/phone system.
    08-17-12 10:15 AM
LINK TO POST COPIED TO CLIPBOARD