08-30-12 03:37 AM
95 ... 234
tools
  1. greenpoise's Avatar
    After more than a week, I finally found a solution, hopefully temp solution, for my wifi woe.. Tried WPA2, WPA, WEP 128bit, nothing NOTHING would work. Tried all possible combinations of channels and wireless mode and they were all inconsistent... This "fix", did not compromise the need to limit my devices (wireless mode in mixed and 40Mhz) but it does compromises security. All I did was under my router, created a virtual interface just for the playbook with just WEP 64bit encryption enabled. That was the only way this thing would work. I hope RIM comes up with an update to solve this. For now, it works. THanks for all of you guys who gave leads and for all the help. Appreciate it.
    04-30-12 11:48 AM
  2. samab's Avatar
    You have no idea what you are doing.

    WEP will kill your wifi throughput --- because all the encryption is done in software (instead of hardware acceleration for AES encryption for WPA2).

    Linksys WRT600N Review: Dual-Band 11n comes to Linky-land - Wireless Performance, Max Throughput-2.4/5GHz - SmallNetBuilder

    Your wifi router has a Atheros chipset --- which the article stated that it loses 90% of its throughput when WEP is enabled. So you are doubling your channel to 40 MHz, and then take a 90% hair cut --- so you ended up with a connection that is 80% slower than just setting your router to 20 MHz WPA2/AES.

    As I said before --- the vast majority of all wifi problems are user misconfigurations.

    Just because there is an option to enable wide 40 MHz channels --- doesn't mean that it's actually faster to use that feature (especially when you live in high rise apartments and there are 20 other wifi networks near your apartment).

    Just because you want your little connection icon to say "connected to 300 mbps" --- doesn't mean that your wifi is actually faster --- that's just an useless label. Your 40 MHz WEP encrypted 802.11n network's throughput will be much worst than a 20 MHz WPA2/AES encrypted 802.11n network.

    Your whole network will be faster if you just stick with the basics --- N-only or Mixed G/N (if you have legacy devices like the wii), 20 MHz channel, WPA2/AES. 99.99% of the general population shouldn't even try to enable 40 MHz channels (especially everybody has wifi routers and are crowded even in the suburbs, not just high-rise apartments) --- it is an useless feature that does absolutely nothing to the actual speed of your wifi network (except for the pretty icon that tells you that it's connected at a nominal speed of 300 mbps)
    Last edited by samab; 04-30-12 at 02:50 PM.
    04-30-12 01:52 PM
  3. greenpoise's Avatar
    You have no idea what you are doing.

    WEP will kill your wifi throughput --- because all the encryption is done in software (instead of hardware acceleration for AES encryption for WPA2).

    Linksys WRT600N Review: Dual-Band 11n comes to Linky-land - Wireless Performance, Max Throughput-2.4/5GHz - SmallNetBuilder

    Your wifi router has a Atheros chipset --- which the article stated that it loses 90% of its throughput when WEP is enabled. So you are doubling your channel to 40 MHz, and then take a 90% hair cut --- so you ended up with a connection that is 80% slower than just setting your router to 20 MHz WPA2/AES.

    As I said before --- the vast majority of all wifi problems are user misconfigurations.

    Just because there is an option to enable wide 40 MHz channels --- doesn't mean that it's actually faster to use that feature (especially when you live in high rise apartments and there are 20 other wifi networks near your apartment).

    Just because you want your little connection icon to say "connected to 300 mbps" --- doesn't mean that your wifi is actually faster --- that's just an useless label. Your 40 MHz WEP encrypted 802.11n network's throughput will be much worst than a 20 MHz WPA2/AES encrypted 802.11n network.

    Your whole network will be faster if you just stick with the basics --- N-only or Mixed G/N (if you have legacy devices like the wii), 20 MHz channel, WPA2/AES. 99.99% of the general population shouldn't even try to enable 40 MHz channels (especially everybody has wifi routers and are crowded even in the suburbs, not just high-rise apartments) --- it is an useless feature that does absolutely nothing to the actual speed of your wifi network (except for the pretty icon that tells you that it's connected at a nominal speed of 300 mbps)
    Samab, is what only works. I know what I am doing. I am an IT Specialist with 13 years under my belt. This, surprisingly enough, is the only device that does not work (after the upgrade) with my Router. My router, even though it has a DDWRT firmware, its pretty much untouched. This is no user misconfiguration or none of that stuff as you say..This is RIM lack of getting its act together and making it work for AUTO configurations, something that happens with pretty much any device on the market. They simply work. Let me tell you, I have an Apple TV, four laptops (two of them OLD AS a junk), one desktop, a BoxeeBox, two cell phones (blackberry by the way) and they all connect brilliantly. THe playbook does not. And unlike what you said, even if its WEP, it is faster than a connection that constantly disconnects. I love my playbook, is not about that. Is about a product being a compatible device with routers.
    04-30-12 06:03 PM
  4. samab's Avatar
    The official 802.11n spec calls for a default 20 MHz channel.

    From your previous comments, the following set-up works for your network and all your devices --- a 20 MHz channel, Mixed G/N, WPA2 with AES and auto ACT Timing (set to 0 using DD-WRT).

    This is what the official 802.11n spec set-up looks like --- and it works for your network and your playbook. If you make further changes to it --- like changing it to 40 MHz channel and it doesn't work, then it's user misconfiguration.

    There is a valid reason why the official 802.11n spec calls for a default channel width of 20 MHz --- interference with a million devices (from bluetooth to home cordless phones to microwave oven) to your neighborhood wifi routers.

    You have old laptops with ancient wifi drivers that probably violated a number of official 802.11 specs. There are probably other devices that you have with wifi drivers that breaks with official 802.11 specs as well --- like allowing connection with 802.11n networks with only WEP or TKIP (whereas Playbook refuses to connect 802.11n networks with only WEP or TKIP).

    You probably have many devices that breaks all kinds of 802.11 specs yet able to connect to each other perfectly. And Playbook may be the only device that have problems in your present wifi set-up.
    04-30-12 06:27 PM
  5. greenpoise's Avatar
    The official 802.11n spec calls for a default 20 MHz channel.

    From your previous comments, the following set-up works for your network and all your devices --- a 20 MHz channel, Mixed G/N, WPA2 with AES and auto ACT Timing (set to 0 using DD-WRT).

    This is what the official 802.11n spec set-up looks like --- and it works for your network and your playbook. If you make further changes to it --- like changing it to 40 MHz channel and it doesn't work, then it's user misconfiguration.

    There is a valid reason why the official 802.11n spec calls for a default channel width of 20 MHz --- interference with a million devices (from bluetooth to home cordless phones to microwave oven) to your neighborhood wifi routers.

    You have old laptops with ancient wifi drivers that probably violated a number of official 802.11 specs. There are probably other devices that you have with wifi drivers that breaks with official 802.11 specs as well --- like allowing connection with 802.11n networks with only WEP or TKIP (whereas Playbook refuses to connect 802.11n networks with only WEP or TKIP).

    You probably have many devices that breaks all kinds of 802.11 specs yet able to connect to each other perfectly. And Playbook may be the only device that have problems in your present wifi set-up.
    I get that. All along I have followed your and many other advices. Let me summarize the settings that do work with my router:

    1. N-Only with WPA2 personal encryption and 20Mhz - This works for the playbook BUT not for my old laptops. So this is not an option for me.

    2. NG Mixed with WEP 64 bit. It works with 20Mhz and with 40Mhz - best working option.

    3. G -only with WPA2 personal @ 20Mhz. This settings drop like 5-10mbps out of my devices. So this is not an option for me.

    4. NG mixed with WPA2 or WPA @20Mhz does not work (AES or TKIP)

    5. Mixed - does not work at all

    THats it. Any other setting will simply not work.
    04-30-12 06:42 PM
  6. samab's Avatar
    You set ACK Timing to auto in all your tests, right?

    Have you updated your other devices' drivers? There is something wrong with your network if Mixed with no encryption doesn't work.

    Toshiba has the largest collection of wifi drivers in one convenient webpage that you can download (that works for non-Toshiba laptops as well).

    Toshiba Wireless Connection Portal:
    Last edited by samab; 04-30-12 at 06:57 PM.
    04-30-12 06:54 PM
  7. samab's Avatar
    Since you are an IT Specialist, you probably have an ancient 802.11G router lying around.

    If all things fail, then attached the G router to the N router with an ethernet cable, set the G router to slave the N router (i.e. Disable DHCP on the G router), then set up the G router to G only and the N router to N only.
    04-30-12 07:05 PM
  8. greenpoise's Avatar
    Since you are an IT Specialist, you probably have an ancient 802.11G router lying around.

    If all things fail, then attached the G router to the N router with an ethernet cable, set the G router to slave the N router (i.e. Disable DHCP on the G router), then set up the G router to G only and the N router to N only.
    I do have a g router and thought about that but I will skip that option ..wont sit well with my wife to see another device in the living....I am going to try the settings mentioned in your previous threads again. Will post.
    04-30-12 07:52 PM
  9. samab's Avatar
    I do have a g router and thought about that but I will skip that option ..wont sit well with my wife to see another device in the living....I am going to try the settings mentioned in your previous threads again. Will post.
    Which settings?
    04-30-12 08:38 PM
  10. okader's Avatar
    Very interesting, now I know what those numbers mean and do. I love IT talk.
    04-30-12 09:59 PM
  11. FunktasticLucky's Avatar
    I had the same issues. I have a WNDR3700v2 router running DD-WRT and it kept doing as you described. My solution. I set the 2.4GHz band to G only and fixed the issues. Running WPA2 Personal and everything stays connected just fine.
    04-30-12 10:15 PM
  12. berrybooktime's Avatar
    Hi guys,

    This is my set-up:

    Playbook with 2.0.1.358
    Netgear WNDR3700 with 14896 f/w

    I encountered the same wifi connection problem as many described in this thread after the 2.0.1.358 update. As some have suggested to update the router firmware, I went ahead and updatd te WNDR3700 to 18777 firmware. This seemed to solve the problem. The 2.4 GHz connected well with stock settings, the 5GHz seemed to struggled for a bit (no clear reason why yet, will play with this for a bit). So, if anyone who seems to get stuck with this problem, update your router firmware!

    Thanks for all the suggestions! This forum rocks!
    I too am having issues connecting to wifi while traveling..Even open networks won't connect, at least with my playbook. My kindle fire has no trouble connecting. Pretty embarrassing, considering I spend all of my time praising the playbooks...
    Unfortunately, I am unable to get all of the routers I encounter updated, matter of fact I can't get any of them updated, as they aren't mine. So I am stuck traveling with two tablets, one lacking in features, the other with broken functionality ....
    05-03-12 05:30 PM
  13. Steel361's Avatar
    i was having the same problem, suddenly stopped detecting wifi at work then at home, I tried the debrick method but didn't work, the PB was detecting my neighbors wifi but not mine, weird, so I clicked on my saved router and clicked on save and connect and that did it, it connected to my router again just like before....no reinstallation of software or anything...enjoying playstation emulator with tekken3, dead or alive, Marvel vs Capcom and street fighter....yay!!
    06-02-12 08:33 PM
  14. MrGD's Avatar
    yeah few days into a new Playbook and it won't connect to wi-fi anymore.

    worked fine at first, then day 2 it was flakey as and kept loosing it's signal and now day 3 it won't connect at all.

    RIM phone support first said "turn off the router and reboot" which frankly is AWFUL advice, am I supposed to ask every place with wi-fi that my Playbook has problems with to reboot their routers? lol

    My advice to others here is ask RIM support for a new Playbook replacement to be sent. That's what I've done, and if that doesn't work I'm getting my money back and buying an ipad or Samsung Galaxy that WILL work... )

    Don't get me wrong, I love my BB phone, but RIM won't last long in this game if they continue on their current path, making products like the Playbook that are (were) way overpriced and do things like only work on certain types of wi-fi... )

    plus, the more RIM refuse to support apps like Viber, Skype etc simply less and less people will buy the Playbook and it'll become the betamax of tablets!
    08-28-12 05:59 PM
  15. ssc13's Avatar
    Anyone have ANY advice? Playbook was working fine yesterday. Let the battery drain completely by accident. Plugged it and let it charge overnight

    and when I woke up this morning, it won't connect to my router. ALl my other devices are connected except the PB. Says authentication timed out,please check your password and try again. Like I said, password is correct because i connected all my other devices. and theyre working well. Pleaaaase ?! I need to talk to my wife!
    08-29-12 02:15 PM
  16. kbz1960's Avatar
    Turn wifi off and then not again? Reboot the pb? Delete the profile and reboot and add again? Restart the router?

    Have to talk to your wife? Ever try a phone?
    08-29-12 02:32 PM
  17. ssc13's Avatar
    did all those things...


    And sorry, dont have to be a smartass man. Just frustrating when it was working yesterday. Its hard to do when youre 6k away. Better in camera than through a phone.
    08-29-12 02:46 PM
  18. Ishaq786's Avatar
    My Playbook, also has wı-fı problems wıth certaın wı-fı's.
    08-29-12 05:59 PM
  19. kbz1960's Avatar
    did all those things...


    And sorry, dont have to be a smartass man. Just frustrating when it was working yesterday. Its hard to do when youre 6k away. Better in camera than through a phone.
    Read it how you want. Wasn't being a smart a but if you HAVE to talk to your wife I think a phone would do. If you HAVE to video chat with her that's a different story.
    08-29-12 07:43 PM
  20. ssc13's Avatar
    Yeah, but the router and playbook were cooperating for weeks without a problem. Until one day,poof gone.

    not working anymore
    08-30-12 03:37 AM
95 ... 234
LINK TO POST COPIED TO CLIPBOARD