08-30-12 03:37 AM
95 1234
tools
  1. greenpoise's Avatar
    Sorry to hear...



    Go into your Wireless tab on DD-WRT, basic settings and then check the "Advanced Settings" box. On "Sensitivity Range (ACK Timing), set it to 0 and Save Settings and Apply. My connection seems to be semi-stable after doing that.



    I think this did the trick!! thanks!! initially I changed it and it went back to 2000..did it again and made sure it stayed in 0 and it worked!! THANKS..well...it worked for now..kind of not trusting of its stability..but thanks!
    04-26-12 04:07 PM
  2. samab's Avatar
    So you did #2 (switched to G-only) and it connected.

    Then you did #3 (n-only with 20 MHz channel with WPA2/AES) and it didn't connect? Did you reboot your router?
    04-26-12 04:17 PM
  3. samab's Avatar
    After working on the issue, I believe that it is related to WMM and ACK timing. ...the problem is that WMM is necessary to achieve N speeds.

    For me, setting the "Sensitivity Range (ACK Timing)" in DD-WRT to 0 helped the issue.
    Setting ACK Timing to 0 for DD-WRT on Atheros chipset routers --- means setting ACK Timing to Auto.

    Atheros/ath wireless settings - DD-WRT Wiki

    DD-WRT Forum :: View topic - ack timing - Lets clear this up

    Which means that there is NOTHING wrong on the RIM's side of programming.
    04-26-12 04:23 PM
  4. greenpoise's Avatar
    So you did #2 (switched to G-only) and it connected.

    Then you did #3 (n-only with 20 MHz channel with WPA2/AES) and it didn't connect? Did you reboot your router?
    I appologize, I keep coming back and editing my posts because I tried so many settings. Each time I did a change, I rebooted my router. And I must thank you as well because, these settings worked (and you previously suggested some of them)

    So here are my settings:

    N-Only (2.4 GHz)
    Channel Width Full 20 MHz
    ACK Timing 0

    That did the trick. Any other combination didnt work. Now, I am hoping that when I get home and I change the settings on my router (which is the same), that it works...So..I will post later what happens at home.




    Thanks!!
    04-26-12 04:26 PM
  5. samab's Avatar
    As I posted just minutes ago, ACK Timing set to 0 means auto ACK Timing. If that works for you, then it means that DD-WRT's default settings are to blame.
    04-26-12 04:29 PM
  6. greenpoise's Avatar
    So you did #2 (switched to G-only) and it connected.

    Then you did #3 (n-only with 20 MHz channel with WPA2/AES) and it didn't connect? Did you reboot your router?
    I did reboot when I changed it to N-only with 20 MHz..However, I will retry these when I get home..will let you know..but I think what Pynk Floyd suggested was necessary..my default was 2000
    04-26-12 04:30 PM
  7. xoenik's Avatar
    Only asking here as it regards the 2.0.1 release.
    Has anyone noticed strange battery drain?
    I've put my playbook on sleep overnight, battery went 79 to 50%, whereas before
    Itd last up to a week in standby
    04-26-12 04:30 PM
  8. greenpoise's Avatar
    As I posted just minutes ago, ACK Timing set to 0 means auto ACK Timing. If that works for you, then it means that DD-WRT's default settings are to blame.
    True however, my playbook worked fine with ACK Timing at 2000 before the upgrade.
    04-26-12 04:31 PM
  9. greenpoise's Avatar
    Only asking here as it regards the 2.0.1 release.
    Has anyone noticed strange battery drain?
    I've put my playbook on sleep overnight, battery went 79 to 50%, whereas before
    Itd last up to a week in standby
    Mine is doing better actually.
    04-26-12 04:35 PM
  10. xoenik's Avatar
    It should be noted I have security wiped, and disabled mail for now.
    Maybe its the result of instability? I once had an uptime of 3 months, but QNX is supposed to be stable
    04-26-12 04:41 PM
  11. greenpoise's Avatar
    It should be noted I have security wiped, and disabled mail for now.
    Maybe its the result of instability? I once had an uptime of 3 months, but QNX is supposed to be stable
    who knows right? now that I am playing with this new version, I hardly notice the changes/additions but it broke my wifi. Is like, dont break it if its not broken.
    04-26-12 04:48 PM
  12. 5k0oby's Avatar
    Hi guys,

    This is my set-up:

    Playbook with 2.0.1.358
    Netgear WNDR3700 with 14896 f/w

    I encountered the same wifi connection problem as many described in this thread after the 2.0.1.358 update. As some have suggested to update the router firmware, I went ahead and updatd te WNDR3700 to 18777 firmware. This seemed to solve the problem. The 2.4 GHz connected well with stock settings, the 5GHz seemed to struggled for a bit (no clear reason why yet, will play with this for a bit). So, if anyone who seems to get stuck with this problem, update your router firmware!

    Thanks for all the suggestions! This forum rocks!
    04-26-12 09:15 PM
  13. kbz1960's Avatar
    Hi guys,

    This is my set-up:

    Playbook with 2.0.1.358
    Netgear WNDR3700 with 14896 f/w

    I encountered the same wifi connection problem as many described in this thread after the 2.0.1.358 update. As some have suggested to update the router firmware, I went ahead and updatd te WNDR3700 to 18777 firmware. This seemed to solve the problem. The 2.4 GHz connected well with stock settings, the 5GHz seemed to struggled for a bit (no clear reason why yet, will play with this for a bit). So, if anyone who seems to get stuck with this problem, update your router firmware!

    Thanks for all the suggestions! This forum rocks!
    Is yours v2? My firmware is 1.0.0.12.
    04-26-12 09:24 PM
  14. kbz1960's Avatar
    I said I was going to get back at this. Samab you were right. I did only needed to change my router to N-Only. I saved the settings, then I changed my channel to 20MhZ. I saved the settings and rebooted my router. No need to change the ACK timing. Bad news, the connection lasted about 5 minutes..Also one of my laptops cant connect to the router when is N-Only. That laptop is pretty much new.
    I will bet your laptop's wifi chip is b,g and not made for n.
    04-27-12 01:03 PM
  15. greenpoise's Avatar
    I will bet your laptop's wifi chip is b,g and not made for n.
    I have 2 of the same laptop. One with windows 7, the other with Linux. The windows 7 cant connect, Linux can...Same wifi chip...

    **UPDATE**

    CHANGING THE Sensitivity Range (ACK Timing) to 0 (default 2000) did work..

    So all in all, these are the steps that worked for me:

    1. Changed Wireless Network Mode from Mixed to N-Only 2.4Ghz
    2. Saved Settings
    3. Changed Channel Width to 20MhZ
    4. Saved Settings
    5. Changed ACK Timing to 0
    6. Saved settings
    7. Rebooted router.

    Its still on.
    04-27-12 01:08 PM
  16. samab's Avatar
    I have 2 of the same laptop. One with windows 7, the other with Linux. The windows 7 cant connect, Linux can...Same wifi chip...

    **UPDATE**

    CHANGING THE Sensitivity Range (ACK Timing) to 0 (default 2000) did work..

    So all in all, these are the steps that worked for me:

    1. Changed Wireless Network Mode from Mixed to N-Only 2.4Ghz
    2. Saved Settings
    3. Changed Channel Width to 20MhZ
    4. Saved Settings
    5. Changed ACK Timing to 0
    6. Saved settings
    7. Rebooted router.

    Its still on.
    As I said before, for your particular router (which is based on an Atheros chipset) and for your particular firmware (DD-WRT) --- changing ACT Timing to 0 means auto ACK Timing.

    It means that the default router setting is to blame --- nothing to do with RIM.

    Now that you managed to pinpoint the source of the problem, then you can start to optimize your router's other settings to suit your needs -- one step at a time. For example, if you have older laptops which has only 802.11g --- now is the time to change your router to G/N mixed. If that setting works for you for a couple of days, then you can optimize from 20 MHz channel to auto channel.

    As long as you change your settings one step as a time, you can pinpoint your source of the problem.
    PatrickMJS likes this.
    04-27-12 01:37 PM
  17. greenpoise's Avatar
    As I said before, for your particular router (which is based on an Atheros chipset) and for your particular firmware (DD-WRT) --- changing ACT Timing to 0 means auto ACK Timing.

    It means that the default router setting is to blame --- nothing to do with RIM.

    Now that you managed to pinpoint the source of the problem, then you can start to optimize your router's other settings to suit your needs -- one step at a time. For example, if you have older laptops which has only 802.11g --- now is the time to change your router to G/N mixed. If that setting works for you for a couple of days, then you can optimize from 20 MHz channel to auto channel.

    As long as you change your settings one step as a time, you can pinpoint your source of the problem.
    I see, so you think that if I now change my router to Mixed, then it means I can turn off my playbook, turn it on and it will still working?? I will have to do that, I mean, I cant seem to get my laptop going on N-Only.

    Thanks!
    04-27-12 01:39 PM
  18. samab's Avatar
    Is yours v2? My firmware is 1.0.0.12.
    He is using a firmware from an open source project (DD-WRT).

    www.dd-wrt.com | Unleash Your Router

    The main use for DD-WRT is (1) official firmwares often can't handle too many connections which kills bittorrent users and (2) end users want to bridge 2 wifi routers together.

    But I find that because it is an open source project --- they are basically creating a frankenstein firmware for their TWO needs. They don't touch or improve the actual wifi radio codes --- since I don't torrent nor I bridge multiple wifi routers together, I went back to official firmware because the official firmware has newer radio codes.
    04-27-12 01:52 PM
  19. samab's Avatar
    I see, so you think that if I now change my router to Mixed, then it means I can turn off my playbook, turn it on and it will still working?? I will have to do that, I mean, I cant seem to get my laptop going on N-Only.

    Thanks!
    Since your windows 7 laptop can't connect to N-only right now and you have a new laptop so it's pretty sure it has a N wifi radio --- then update your windows 7 laptop's wifi driver first. Toshiba has a collection of wifi drivers that works for everybody.

    Toshiba Wireless Connection Portal:

    Reboot your laptop and then see if it connects. A new laptop with a known N wifi radio can't connect to a a N-only router (with the most basic settings) --- then it's the laptop problem.

    One step at a time.
    04-27-12 01:58 PM
  20. greenpoise's Avatar
    As I said before, for your particular router (which is based on an Atheros chipset) and for your particular firmware (DD-WRT) --- changing ACT Timing to 0 means auto ACK Timing.

    It means that the default router setting is to blame --- nothing to do with RIM.

    Now that you managed to pinpoint the source of the problem, then you can start to optimize your router's other settings to suit your needs -- one step at a time. For example, if you have older laptops which has only 802.11g --- now is the time to change your router to G/N mixed. If that setting works for you for a couple of days, then you can optimize from 20 MHz channel to auto channel.

    As long as you change your settings one step as a time, you can pinpoint your source of the problem.
    Channel Width cant be 40MhZ. If I change that, the connection breaks.. I think something must have changed in the last update, like I said, this used to work wonders without ever disconnecting. I had ACK Timing to 2000 which in my router is the default and I also had channel width @ 40MhZ. Is really odd that all of the sudden after the update its just a no go.
    04-27-12 02:19 PM
  21. samab's Avatar
    Channel Width cant be 40MhZ. If I change that, the connection breaks.. I think something must have changed in the last update, like I said, this used to work wonders without ever disconnecting. I had ACK Timing to 2000 which in my router is the default and I also had channel width @ 40MhZ. Is really odd that all of the sudden after the update its just a no go.
    Auto channel width --- not necessarily 40 MHz.

    ONE step at a time. You didn't even know which particular setting is the problem --- maybe it had nothing to do with 40 MHz channel. My list is to isolate the problem, one step at a time. Now that you isolated that problem to be the ACK Timing default setting is wrong, then you can play with other settings.
    04-27-12 02:47 PM
  22. pynkfloydd's Avatar
    I have 2 of the same laptop. One with windows 7, the other with Linux. The windows 7 cant connect, Linux can...Same wifi chip...

    **UPDATE**

    CHANGING THE Sensitivity Range (ACK Timing) to 0 (default 2000) did work..

    So all in all, these are the steps that worked for me:

    1. Changed Wireless Network Mode from Mixed to N-Only 2.4Ghz
    2. Saved Settings
    3. Changed Channel Width to 20MhZ
    4. Saved Settings
    5. Changed ACK Timing to 0
    6. Saved settings
    7. Rebooted router.

    Its still on.
    Glad to see that it worked!!!

    I'm running N-Only on the 5 GHz band with Turbo (40 MHz). I've noticed that the last 2 DD-WRT releases have required me to set the channel manually or else it wouldn't broadcast anything.

    As for your Windows laptop, there are some additional settings in the adapter properties. Go to Control Panel -> Device Manager -> expand your Network Adapters and right click on your wifi card and then hit Properties.

    Under the Advanced tab, check your settings. There are a lot of N settings in there. Keep in mind that "WMM Enabled" must be set in "Ad Hoc QoS Mode" for N to get its full thoroughput. Hopefully that fixes your laptop issue?

    Here's a detailed wiki on it:

    http://infodepot.wikia.com/wiki/Basic_Wireless_Settings



    As I said before, for your particular router (which is based on an Atheros chipset) and for your particular firmware (DD-WRT) --- changing ACT Timing to 0 means auto ACK Timing.

    It means that the default router setting is to blame --- nothing to do with RIM.

    Now that you managed to pinpoint the source of the problem, then you can start to optimize your router's other settings to suit your needs -- one step at a time. For example, if you have older laptops which has only 802.11g --- now is the time to change your router to G/N mixed. If that setting works for you for a couple of days, then you can optimize from 20 MHz channel to auto channel.

    As long as you change your settings one step as a time, you can pinpoint your source of the problem.
    The Playbook still reports my network incorrectly. It says it's a "802.11a/n" with a max connection data rate of 65 Mbps.

    My router is set to N only and everything else on my network hits max thoroughput. If eeeeeverything else on my network is A-ok and the Playbook is not, it leads me to believe that it's a Playbook issue.

    Even with the timing change, the Playbook takes a while to load a web page. At least the connection isn't dropped...as often. (As I type, I still can't fully load the Yahoo page that's bookmarked by default.)
    Last edited by PynkFloydd; 04-27-12 at 03:00 PM.
    04-27-12 02:55 PM
  23. samab's Avatar
    99% of the DD-WRT effort is on features like torrent connection stability and bridging wifi routers. They don't touch the actual radio codes. You could be using some ancient draft n radio codes even though you downloaded the latest DD-WRT firmware --- that's the reason I went back to official stock firmware.
    04-27-12 03:28 PM
  24. greenpoise's Avatar
    Auto channel width --- not necessarily 40 MHz.

    ONE step at a time. You didn't even know which particular setting is the problem --- maybe it had nothing to do with 40 MHz channel. My list is to isolate the problem, one step at a time. Now that you isolated that problem to be the ACK Timing default setting is wrong, then you can play with other settings.
    And thats what I did. I "isolated" the problem and I go to change one thing at a time and it just breaks.. I am not even initiating ACK Timing, thats one setting I dont care about.
    04-27-12 06:21 PM
  25. samab's Avatar
    And thats what I did. I "isolated" the problem and I go to change one thing at a time and it just breaks.. I am not even initiating ACK Timing, thats one setting I dont care about.
    I don't understand what you are saying.

    Are you saying that you have wifi problems with ACK Timing at 0 and channel width set to 40 MHz?

    Do you live in a high rise apartment where there are a zillion different wifi networks? If that is the case, not a good place in general to set your wifi network to 40 MHz.
    04-27-12 07:07 PM
95 1234
LINK TO POST COPIED TO CLIPBOARD