08-30-12 02:37 AM
95 1234
tools
  1. bobtheclerk's Avatar
    I'm having the same issue with the same type router will give your solution a try and see if it works. Thanks
    I have the same issue. I took it to a free wi-fi site and everything worked fine, albeit on an open network. I'm no thechy so I'm hoping RIM puts out an amended software fix to resolve an issue that's affected lots of Playbook users
    04-24-12 02:31 PM
  2. Sotirios's Avatar
    Hello

    this is how I could finally manage the wifi issues Playbook vs AVM Fritzbox:

    Router FritzBox:

    5 ghz: DISABLE!
    802.11 wireless standard to: n + g
    Radio channel: specify fixed
    For 300 Mbit / s optimized use of radio channels: DISABLE!
    Maximum output power: 100%
    Wireless transmission for IPTV applications optimized: DISABLE!
    Security: WPA + WPA2

    Playbook:

    manually setup
    only in the 2.4 GHz,
    WPA2
    set flag on "Automatic Ip Address"

    German:

    in der FB:

    5 ghz: DEAKTIVIEREN!
    Funkstanddard auf 802.11 n+g
    Funkkanal: fest vorgeben
    Fr 300 Mbit/s optimierte Funkkanle nutzen: DEAKTIVIEREN!
    Maximale Sendeleistung: 100%
    WLAN-bertragung fr IPTV-Anwendungen optimieren: DEAKTIVIEREN!
    Sicherheit: WPA+WPA2

    Playbook:

    manuell einmelden,
    nur im 2,4Ghz,
    WPA2,
    Hkchen bei "Automatische Ip Adresse" belassen.
    optional kann man auch eine feste IP Adresse im Playbook selbst vergeben oder auch in der FB, wobei die Einstellung am PB selbst nachhaltig Wirkung zeigt. Zurzeit luft es aber wie gesagt ohne feste IP Adressenzuordnung bei mir optimal!

    Ebenfalls optional: ist bei mir zurzeit aktiviert: ipv6 und Zulassen von bergaben.


    I hope it does help anybody

    PS: pls ensure your router's firmware is up-to-date!!!

    cheers
    Last edited by Sotirios; 04-25-12 at 08:08 AM. Reason: firmware
    04-25-12 07:36 AM
  3. greenpoise's Avatar
    Same problem as above threads. It started after the upgrade..I have restored the pbook, changed the router settings, done a static ip connection..nothing works..this blows..so many props I was giving this device and the update just seemed to fix some things while break others..Any idea how to restore the device and then do the upgrade through the computer?? that was my last attempt but the playbook always tries to install the upgrade prior the playbook being able to connect to the desktop software..thanks
    04-25-12 12:23 PM
  4. samab's Avatar
    Turn off the WMM setting in your router.
    alphecca likes this.
    04-25-12 12:31 PM
  5. kbz1960's Avatar
    Wipe it, shut it off when it booted by holding the power button until it shuts off, make sure it is off and let it sit 10 minutes or so. Open dm and plug the pb in while still off.
    greenpoise likes this.
    04-25-12 12:32 PM
  6. greenpoise's Avatar
    tried that but whenever I connect the PB to the PC, it starts and does not connect to the software..is there a way to skip the upgrade?
    04-25-12 12:52 PM
  7. kbz1960's Avatar
    tried that but whenever I connect the PB to the PC, it starts and does not connect to the software..is there a way to skip the upgrade?
    I thought you said you wanted to upgrade thru dm. This upgrades thru dm. I think the location update needs to be done over wifi but not sure.
    04-25-12 12:58 PM
  8. Blkacesvf41's Avatar
    Can't imagine having all these wifi issues folks, I really do feel for ya! Mine is always flawless, doesn't matter what network I'm trying to connect to.
    04-25-12 02:13 PM
  9. pynkfloydd's Avatar
    I have the same issue. Wifi is connected fully until I actually try to use it and then it disconnects. While loading a web page, it gets about 1/4 of the way and then the signal drops.

    When reloading the OS, this makes the registration process take all day.

    (...and no, I'm not computer illiterate. I'm capable of board repairs at the component level and have no problems troubleshooting software.)


    Playbook is an early 32gb model (power button is receeded).

    I'm running a D-Link DIR-825 with DD-WRT. NOTHING else on my network has any issues connecting.

    My network includes: Samsung Galaxy Tab 10.1, Desktop, 2 Laptops, 2 Xbox 360s, Printer, BB Bold 9930, Samsung Galaxy Nexus 4G, iPhone 3GS. (NONE of these have any issues.)

    Troubleshooting I've tried: Full security wipe, 2.4 GHz and 5 GHz bands (both hidden and broadcasting SSID), assigning a static IP and reloading the OS through desktop manager, multiple reboots and hard resets.


    Since this issue started, I ordered an Android tablet to replace the Playbook. That's been the only way I've been able to "fix" this issue.

    Thanks RIM!
    04-25-12 04:33 PM
  10. Eli Bret's Avatar
    I have the same issue. Wifi is connected fully until I actually try to use it and then it disconnects. While loading a web page, it gets about 1/4 of the way and then the signal drops.

    When reloading the OS, this makes the registration process take all day.

    (...and no, I'm not computer illiterate. I'm capable of board repairs at the component level and have no problems troubleshooting software.)


    Playbook is an early 32gb model (power button is receeded).

    I'm running a D-Link DIR-825 with DD-WRT. NOTHING else on my network has any issues connecting.

    My network includes: Samsung Galaxy Tab 10.1, Desktop, 2 Laptops, 2 Xbox 360s, Printer, BB Bold 9930, Samsung Galaxy Nexus 4G, iPhone 3GS. (NONE of these have any issues.)

    Troubleshooting I've tried: Full security wipe, 2.4 GHz and 5 GHz bands (both hidden and broadcasting SSID), assigning a static IP and reloading the OS through desktop manager, multiple reboots and hard resets.


    Since this issue started, I ordered an Android tablet to replace the Playbook. That's been the only way I've been able to "fix" this issue.

    Thanks RIM!
    You may try to disable just WMM (it did it for me with the same router).

    http://forums.crackberry.com/blackbe...update-718571/
    04-25-12 06:04 PM
  11. greenpoise's Avatar
    I have the same issue. Wifi is connected fully until I actually try to use it and then it disconnects. While loading a web page, it gets about 1/4 of the way and then the signal drops.

    When reloading the OS, this makes the registration process take all day.

    (...and no, I'm not computer illiterate. I'm capable of board repairs at the component level and have no problems troubleshooting software.)


    Playbook is an early 32gb model (power button is receeded).

    I'm running a D-Link DIR-825 with DD-WRT. NOTHING else on my network has any issues connecting.

    My network includes: Samsung Galaxy Tab 10.1, Desktop, 2 Laptops, 2 Xbox 360s, Printer, BB Bold 9930, Samsung Galaxy Nexus 4G, iPhone 3GS. (NONE of these have any issues.)

    Troubleshooting I've tried: Full security wipe, 2.4 GHz and 5 GHz bands (both hidden and broadcasting SSID), assigning a static IP and reloading the OS through desktop manager, multiple reboots and hard resets.


    Since this issue started, I ordered an Android tablet to replace the Playbook. That's been the only way I've been able to "fix" this issue.

    Thanks RIM!
    haaa..I love your solution..I wish I could easily buy an android. I really liked my playbook..but man..the wifi issue is ridiculous.. I have seen a few people with DD-WRT. My router is also DD-WRT and I am also having the disconnection crap..what could it be??? Like you, I tried the same things with the same results.. My DD-WRT is pretty much in stock after I reset the router...really freaking odd.
    04-25-12 08:05 PM
  12. pynkfloydd's Avatar
    You may try to disable just WMM (it did it for me with the same router).

    http://forums.crackberry.com/blackbe...update-718571/
    Edit (4/26/2012 2:13PM): ...the option to disable WMM isn't in DD-WRT v24 pre-SP2 18777 that I'm running. Thanks for your suggestion. I did see your post prior to replying to this thread.

    After working on the issue, I believe that it is related to WMM and ACK timing. ...the problem is that WMM is necessary to achieve N speeds.

    For me, setting the "Sensitivity Range (ACK Timing)" in DD-WRT to 0 helped the issue.

    I figured that everyone should speak up that's experiencing the issue so that RIM works on a fix.


    haaa..I love your solution..I wish I could easily buy an android. I really liked my playbook..but man..the wifi issue is ridiculous.. I have seen a few people with DD-WRT. My router is also DD-WRT and I am also having the disconnection crap..what could it be??? Like you, I tried the same things with the same results.. My DD-WRT is pretty much in stock after I reset the router...really freaking odd.
    I just picked one up on eBay cheap. If you're patient, you can get a bricked Android tab that's pretty easy to recover (and same with the Playbooks).

    The only "known issue" for the WRT I see is:

    * Various 5GHz channels may be locked due to lacking DFS support and other regulatory requirements


    Which means that changing the channel on 5 GHz would "fix" the issue or that 2.4 GHz shouldn't be experiencing it. ...and that other stuff on the network would be having problems too.

    People on BB's own support forums are complaining about the issue also, so it's not that isolated.
    Last edited by PynkFloydd; 04-26-12 at 02:16 PM.
    04-25-12 08:13 PM
  13. greenpoise's Avatar
    so i was able to "fix" this issue by changing my router wireless network mode from mixed to strictly G-Only. This is two steps back. My playbook would work but my other devices would only connect at G. RIM needs to get it together. This totally blows.
    04-26-12 12:05 AM
  14. samab's Avatar
    Wi-Fi Multimedia is a trademarked QoS standard. ...it's not in DD-WRT. If disabling that option worked, it's possible that you didn't have your QoS settings correctly configured and it was blocking your Playbook from connecting.
    WMM means TWO things --- QoS and PowerSave. DD-WRT has WMM settings.

    PowerSave is a feature where the router sends a signal to the wireless device and tell the wifi radio to sleep to save power. Somehow either the router or the tablet forgot to send a signal to wake up the wifi radio.
    Last edited by samab; 04-26-12 at 01:00 AM.
    04-26-12 12:39 AM
  15. samab's Avatar
    so i was able to "fix" this issue by changing my router wireless network mode from mixed to strictly G-Only. This is two steps back. My playbook would work but my other devices would only connect at G. RIM needs to get it together. This totally blows.
    You should try to solve the problem step by step.

    (1) Update your router's firmware
    (2) G-only, WPA2 with AES, WMM off.
    (3) N-only, narrow channel, WPA2 with AES, WMM off.
    (4) N-only, narrow channel, WPA2 with AES, WMM on.
    04-26-12 12:57 AM
  16. greenpoise's Avatar
    You should try to solve the problem step by step.

    (1) Update your router's firmware
    (2) G-only, WPA2 with AES, WMM off.
    (3) N-only, narrow channel, WPA2 with AES, WMM off.
    (4) N-only, narrow channel, WPA2 with AES, WMM on.
    Any other names for narrow channel? I dont see that in mine...thanks! by the way, I have tried 1, 2.
    My router does not have anything called narrow channel or WMM
    04-26-12 11:36 AM
  17. greenpoise's Avatar
    ok..Tried narrowing the channel to 20mhz but nothing..it doesnt even connect with channel 20mhz...
    04-26-12 01:10 PM
  18. pynkfloydd's Avatar
    so i was able to "fix" this issue by changing my router wireless network mode from mixed to strictly G-Only. This is two steps back. My playbook would work but my other devices would only connect at G. RIM needs to get it together. This totally blows.
    Sorry to hear...

    Yeah, I refuse to do that. I bought it because it has N support (both 2.4 and 5 GHz). If I change my network to G then I can't stream 1080p from my NAS and that means bye bye Playbook.

    Just wondering if this will work for you...it seems to have helped me:

    Go into your Wireless tab on DD-WRT, basic settings and then check the "Advanced Settings" box. On "Sensitivity Range (ACK Timing), set it to 0 and Save Settings and Apply. My connection seems to be semi-stable after doing that.

    WMM means TWO things --- QoS and PowerSave. DD-WRT has WMM settings.

    PowerSave is a feature where the router sends a signal to the wireless device and tell the wifi radio to sleep to save power. Somehow either the router or the tablet forgot to send a signal to wake up the wifi radio.
    I'm sorry, but I don't see anything related to WMM in DD-WRT at all. I'm running a v24 pre-SP2 release of 18777. The Wiki on WMM in DD-WRT is from 2006:


    WMM - DD-WRT Wiki

    I believe that I was wrong in my previous post. After reading up on it, WMM is required to be on to achieve N speeds and it by default "on" in DD-WRT (even though there isn't an option to turn it off).


    I found a full explanation of why turning off WMM would work (in case anyone is interested):

    http://www.smallnetbuilder.com/wirel...-mess-with-wmm


    ...after consulting with Atheros (maker of the WNDR3700's wireless chipset), Intel and even the Wi-Fi Alliance, NETGEAR reported that the behavior found by the reader was normal!

    I've seen recommendations from users to disable WMM in 11n routers to either improve performance or fix problems. So I asked NETGEAR for an explanation of why WMM is required to enable link rates higher than 54 Mbps. They sent along an explanation from Atheros, which I'm paraphrasing below.

    Basically, the 802.11n spec requires devices to support 802.11e (Quality of Service [QoS] enhancements for wireless LAN) in order to use HT (High Throughput) link rates, i.e. higher than 54 Mbps. (WMM is a subset of 802.11e that was created by the Wi-Fi Alliance as a stop-gap measure while 802.11e made its way slowly through the IEEE review process.) WMM's Traffic Identifier (TID) field is key to aggregation mechanisms, including block acknowledgement (block ACK), that enable 802.11n's high throughput rates.

    Since WMM support is required for products to be certified for 802.11n, WMM comes enabled by default in all Wi-Fi Certified n APs and wireless routers. So even if you don't have any WMM-aware devices on your network, leave WMM enabled or you may find your clients connecting only at 54 Mbps rates.


    The issue that we're experiencing presents itself as a dropped connection on the Playbook only. Wifi is on and it connects until it gets about 1/4-1/2 way loading a page and then drops out. All the logs say is "Disconnect Event - remove keys".

    This issue is likely to be related to WMM then.

    See: WLAN Problem since 2.0.1.358 - BlackBerry Support Community Forums
    Last edited by PynkFloydd; 04-26-12 at 02:01 PM.
    greenpoise likes this.
    04-26-12 01:17 PM
  19. dk6px's Avatar
    You may try to disable just WMM (it did it for me with the same router).

    http://forums.crackberry.com/blackbe...update-718571/
    Here in germany Same issues. Fix only with switch off 802.11n

    Terrible work!!! RIM!!

    The only reason is to kickout the last non BB Handyusers.

    So you get it, i will buy the Google Tablet,

    they know how important the connections to the World via WLAN is ...
    And so the last Users are gone...

    Congratulations
    04-26-12 01:30 PM
  20. samab's Avatar
    ok..Tried narrowing the channel to 20mhz but nothing..it doesnt even connect with channel 20mhz...
    Did you reboot your router after each change in configuration? Unplugged your router for 30 seconds and then plug it back on.

    SHere's a full explanation of why turning off WMM would work (in case anyone is interested)

    The issue that we're experiencing presents itself as a dropped connection on the Playbook only. Wifi is on and it connects until it gets about 1/4-1/2 way loading a page and then drops out. All the logs say is "Disconnect Event - remove keys".

    This issue is definitely related to RIM's horrible job at implenting N and AES...
    There are a million different factors that go into whether you are going to have wifi problems. Notice my lists ends with WMM turn on. In a perfect world, you have a router with a firmware after the 802.11n spec was finalized and you should have WMM turn on.

    But this is not a perfect world, many people are going to have some draft n router with a firmware circa 2007-2008 --- before the 802.11n spec was finalized. And it is these routers that may be helped by having WMM turn off (if they can't find a firmware that dates after 2009).

    My list is just going back to the basics and try to isolate the potential problem. I don't doubt that WMM is necessary for higher speed throughput (as described in the link you posted). But chances are people are going to have problems with their router because they have a draft n router that don't conform to final 802.11n spec --- it might be better to turn that router into G-only (if they can't find a new firmware).

    Even your link describes the trademark WMM (the QoS part) as a stop gap measure --- which is a subset of the 802.11e draft. Then 802.11e spec was finalized --- which also contains power saving features. Then the wifi trade-group trademarked WMM Power Save and gives everybody confusion on what WMM really is.
    Last edited by samab; 04-26-12 at 02:02 PM.
    04-26-12 01:55 PM
  21. pynkfloydd's Avatar
    There are a million different factors that go into whether you are going to have wifi problems. Notice my lists ends with WMM turn on. In a perfect world, you have a router with a firmware after the 802.11n spec was finalized and you should have WMM turn on.

    But this is not a perfect world, many people are going to have some draft n router with a firmware circa 2007-2008 --- before the 802.11n spec was finalized. And it is these routers that may be helped by having WMM turn off (if they can't find a firmware that dates after 2009).

    My list is just going back to the basics and try to isolate the potential problem. I don't doubt that WMM is necessary for higher speed throughput (as described in the link you posted). But chances are people are going to have problems with their router because they have a draft n router that don't conform to final 802.11n spec --- it might be better to turn that router into G-only (if they can't find a new firmware).

    Even your link describes the trademark WMM (the QoS part) as a stop gap measure --- which is a subset of the 802.11e draft. Then 802.11e spec was finalized --- which also contains power saving features. Then the wifi trade-group trademarked WMM Power Save and gives everybody confusion on what WMM really is.
    I edited my post after further researching the issue. Please see above.

    This issue seems likely related to WMM and ACK timing. Since it only presents itself on the Playbook's latest OS update, it seems that RIM screwed something up.
    04-26-12 02:05 PM
  22. samab's Avatar
    Or RIM starts to strictly implement the wifi spec and thus non-conforming routers have problems with the Playbook.

    The majority of wifi problems are going to be outdated draft n firmware, user mis-configuration, outdated client drivers (i.e. nobody ever updates their laptop's wifi drivers because manufacturers don't post them online). Outdated router firmware works well with outdated laptop wifi drivers. Outdated router firmware may not work well with up-to-date tablet wifi drivers.
    Last edited by samab; 04-26-12 at 02:28 PM.
    04-26-12 02:15 PM
  23. greenpoise's Avatar
    well I have tried every combination possible..and G only setting the only way to make it work..what a blow..here I am doing the big talk about RIM and how I wouldnt mind investing in the company and boom..they dissapoint me with this and their tech support..
    04-26-12 02:31 PM
  24. samab's Avatar
    well I have tried every combination possible..and G only setting the only way to make it work..what a blow..here I am doing the big talk about RIM and how I wouldnt mind investing in the company and boom..they dissapoint me with this and their tech support..
    What model of wifi router and what firmware do you have? What configurations are in your wifi routers?
    04-26-12 02:33 PM
  25. greenpoise's Avatar
    What model of wifi router and what firmware do you have? What configurations are in your wifi routers?
    Thanks for your help. Here it is:

    Buffalo Infinity
    WZR-HP-G300NH v2
    Firmware: v24sp2-17798
    Firmware is DDWRT

    I appreciate your help!
    04-26-12 02:36 PM
95 1234
LINK TO POST COPIED TO CLIPBOARD